LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 09-18-2005, 01:57 PM   #1
realcr
LQ Newbie
 
Registered: Aug 2005
Location: Israel
Distribution: fedora core 4
Posts: 15

Rep: Reputation: 0
slackware and cd recorder


I am running a slackware 10.1 dist and having trouble using my cd recorder. k3b doesn't seem to see any cd recording device , and cdrecord gives this output:

bash-3.00# cdrecord -scanbus
Cdrecord 1.8.1a03 (i686-pc-linux-gnu) Copyright (C) 1995-2000 Jörg Schilling
cdrecord: No such file or directory. Cannot open SCSI driver.
cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you are root.

I have no idea what went wrong as it worked very well with fc4 , ubuntu and all the windows os I tried.

I included the dmesg output as ppl always ask me to do that...

tnx for help,
realcr.

Code:
Linux version 2.4.29 (root@midas) (gcc version 3.3.4) #6 Thu Jan 20 16:30:37 PST 2005
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
 BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
 BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 000000001fff0000 (usable)
 BIOS-e820: 000000001fff0000 - 000000001fff8000 (ACPI data)
 BIOS-e820: 000000001fff8000 - 0000000020000000 (ACPI NVS)
 BIOS-e820: 00000000fff80000 - 0000000100000000 (reserved)
511MB LOWMEM available.
On node 0 totalpages: 131056
zone(0): 4096 pages.
zone(1): 126960 pages.
zone(2): 0 pages.
Kernel command line: BOOT_IMAGE=Linux ro root=307
Initializing CPU#0
Detected 1500.096 MHz processor.
Console: colour dummy device 80x25
Calibrating delay loop... 2994.99 BogoMIPS
Memory: 515348k/524224k available (1831k kernel code, 8488k reserved, 607k data, 120k init, 0k highmem)
Dentry cache hash table entries: 65536 (order: 7, 524288 bytes)
Inode cache hash table entries: 32768 (order: 6, 262144 bytes)
Mount cache hash table entries: 512 (order: 0, 4096 bytes)
Buffer cache hash table entries: 32768 (order: 5, 131072 bytes)
Page-cache hash table entries: 131072 (order: 7, 524288 bytes)
CPU: Trace cache: 12K uops, L1 D cache: 8K
CPU: L2 cache: 256K
CPU:     After generic, caps: 3febf9ff 00000000 00000000 00000000
CPU:             Common caps: 3febf9ff 00000000 00000000 00000000
CPU: Intel(R) Pentium(R) 4 CPU 1.50GHz stepping 02
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
mtrr: v1.40 (20010327) Richard Gooch (rgooch@atnf.csiro.au)
mtrr: detected mtrr type: Intel
PCI: PCI BIOS revision 2.10 entry at 0xfdaf1, last bus=1
PCI: Using configuration type 1
PCI: Probing PCI hardware
PCI: Probing PCI hardware (bus 00)
PCI: Using IRQ router default [1106/3074] at 00:11.0
PCI: Hardcoded IRQ 14 for device 00:11.1
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
Starting kswapd
VFS: Disk quotas vdquot_6.5.1
Journalled Block Device driver loaded
vesafb: framebuffer at 0xda000000, mapped to 0xe080d000, size 1536k
vesafb: mode is 1024x768x8, linelength=1024, pages=4
vesafb: protected mode interface info at c000:0393
vesafb: scrolling: redraw
Console: switching to colour frame buffer device 128x48
fb0: VESA VGA frame buffer device
pty: 512 Unix98 ptys configured
Serial driver version 5.05c (2001-07-08) with HUB-6 MANY_PORTS MULTIPORT SHARE_IRQ SERIAL_PCI enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
ttyS01 at 0x02f8 (irq = 3) is a 16550A
Real Time Clock Driver v1.10f
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
RAMDISK driver initialized: 16 RAM disks of 7777K size 1024 blocksize
loop: loaded (max 8 devices)
Uniform Multi-Platform E-IDE driver Revision: 7.00beta4-2.4
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
VP_IDE: IDE controller at PCI slot 00:11.1
PCI: Hardcoded IRQ 14 for device 00:11.1
VP_IDE: chipset revision 6
VP_IDE: not 100% native mode: will probe irqs later
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
VP_IDE: VIA vt8233 (rev 00) IDE UDMA100 controller on pci00:11.1
    ide0: BM-DMA at 0xfc00-0xfc07, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0xfc08-0xfc0f, BIOS settings: hdc:DMA, hdd:pio
hda: ST3120026A, ATA DISK drive
blk: queue c03ad460, I/O limit 4095Mb (mask 0xffffffff)
hdc: probing with STATUS(0x50) instead of ALTSTATUS(0x7f)
hdc: probing with STATUS(0x51) instead of ALTSTATUS(0x7f)
hdc: probing with STATUS(0x51) instead of ALTSTATUS(0x7f)
hdc: ATAPI-CD ROM-DRIVE-56MAX, ATAPI CD/DVD-ROM drive
hdd: HL-DT-ST GCE-8160B, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: attached ide-disk driver.
hda: host protected area => 1
hda: 234441648 sectors (120034 MB) w/8192KiB Cache, CHS=14593/255/63, UDMA(100)
hdc: attached ide-cdrom driver.
hdc: ATAPI 56X CD-ROM drive, 128kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.12
hdd: attached ide-cdrom driver.
hdd: ATAPI 40X CD-ROM CD-R/RW drive, 2048kB Cache, DMA
Partition check:
 hda: hda1 hda2 < hda5 hda6 hda7 >
SCSI subsystem driver Revision: 1.00
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
md: linear personality registered as nr 1
md: raid0 personality registered as nr 2
md: raid1 personality registered as nr 3
md: raid5 personality registered as nr 4
raid5: measuring checksumming speed
   8regs     :  1740.400 MB/sec
   32regs    :  1072.800 MB/sec
   pIII_sse  :  1945.200 MB/sec
   pII_mmx   :  1745.600 MB/sec
   p5_mmx    :  1706.800 MB/sec
raid5: using function: pIII_sse (1945.200 MB/sec)
md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
LVM version 1.0.8(17/11/2003)
Initializing Cryptographic API
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
IP: routing cache hash table of 4096 buckets, 32Kbytes
TCP: Hash tables configured (established 32768 bind 65536)
Linux IP multicast router 0.06 plus PIM-SM
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
kjournald starting.  Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
VFS: Mounted root (ext3 filesystem) readonly.
Freeing unused kernel memory: 120k freed
Adding Swap: 1004020k swap-space (priority -1)
EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,7), internal journal
Linux agpgart interface v0.99 (c) Jeff Hartmann
agpgart: Maximum main memory to use for agp memory: 439M
agpgart: Unsupported Via chipset (device id: 3128), you might want to try agp_try_unsupported=1.
agpgart: no supported devices found.
scsi0 : SCSI host adapter emulation for IDE ATAPI devices
NTFS driver v1.1.22 [Flags: R/O MODULE]
Linux Kernel Card Services 3.1.22
  options:  [pci] [cardbus] [pm]
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Intel ISA PCIC probe: not found.
Databook TCIC-2 PCMCIA probe: not found.
ds: no socket drivers loaded!
via-rhine.c:v1.10-LK1.1.19  July-12-2003  Written by Donald Becker
  http://www.scyld.com/network/via-rhine.html
eth0: VIA VT6102 Rhine-II at 0xc800, 00:07:95:0a:2f:09, IRQ 11.
eth0: MII PHY found at address 1, status 0x7849 advertising 05e1 Link 0000.
via82xx: Assuming DXS channels with 48k fixed sample rate.
         Please try dxs_support=1 or dxs_support=4 option
         and report if it works on your machine.
PCI: Setting latency timer of device 00:11.5 to 64
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
uhci.c: USB Universal Host Controller Interface driver v1.1
uhci.c: USB UHCI at I/O 0xd400, IRQ 5
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 2 ports detected
uhci.c: USB UHCI at I/O 0xd000, IRQ 5
usb.c: new USB bus registered, assigned bus number 2
hub.c: USB hub found
hub.c: 2 ports detected
uhci.c: USB UHCI at I/O 0xcc00, IRQ 5
usb.c: new USB bus registered, assigned bus number 3
hub.c: USB hub found
hub.c: 2 ports detected
8139too Fast Ethernet driver 0.9.26
eth1: RealTek RTL8139 at 0xe0b05f00, 00:c1:26:11:4d:a2, IRQ 10
eth1:  Identified 8139 chip type 'RTL-8100B/8139D'
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
eth1: link up, 100Mbps, full-duplex, lpa 0x45E1
shpchp: shpc_init : shpc_cap_offset == 0
shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
hub.c: new USB device 00:11.2-1, assigned address 2
hub.c: USB hub found
hub.c: 4 ports detected
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
pciehp: PCI Express Hot Plug Controller Driver version: 0.5
hub.c: new USB device 00:11.2-2, assigned address 3
usb.c: USB device 3 (vend/prod 0x924/0x3d52) is not claimed by any active driver.
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
shpchp: shpc_init : shpc_cap_offset == 0
shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
pciehp: PCI Express Hot Plug Controller Driver version: 0.5
hub.c: new USB device 00:11.2-1.2, assigned address 4
usb.c: USB device 4 (vend/prod 0xc45/0x600d) is not claimed by any active driver.
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
shpchp: shpc_init : shpc_cap_offset == 0
shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
pciehp: PCI Express Hot Plug Controller Driver version: 0.5
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
shpchp: shpc_init : shpc_cap_offset == 0
shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
pciehp: PCI Express Hot Plug Controller Driver version: 0.5
usb.c: registered new driver usblp
printer.c: usblp0: USB Bidirectional printer dev 3 if 0 alt 0 proto 2 vid 0x0924 pid 0x3D52
printer.c: v0.13: USB Printer Device Class driver
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
shpchp: shpc_init : shpc_cap_offset == 0
shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
pciehp: PCI Express Hot Plug Controller Driver version: 0.5
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
shpchp: shpc_init : shpc_cap_offset == 0
shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
pciehp: PCI Express Hot Plug Controller Driver version: 0.5
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
shpchp: shpc_init : shpc_cap_offset == 0
shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
pciehp: PCI Express Hot Plug Controller Driver version: 0.5
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
shpchp: shpc_init : shpc_cap_offset == 0
shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
pciehp: PCI Express Hot Plug Controller Driver version: 0.5
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
shpchp: shpc_init : shpc_cap_offset == 0
shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
pciehp: PCI Express Hot Plug Controller Driver version: 0.5
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
shpchp: shpc_init : shpc_cap_offset == 0
shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
pciehp: PCI Express Hot Plug Controller Driver version: 0.5
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
shpchp: shpc_init : shpc_cap_offset == 0
shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
pciehp: PCI Express Hot Plug Controller Driver version: 0.5
parport0: PC-style at 0x378 [PCSPP,TRISTATE]
lp0: using parport0 (polling).
cdrom: open failed.
paride: version 1.06 installed (parport)
pg: pg version 1.02, major 97
pg0: Autoprobe failed
pg: No ATAPI device detected
paride: version 1.06 installed (parport)
pg: pg version 1.02, major 97
pg0: Autoprobe failed
pg: No ATAPI device detected
paride: version 1.06 installed (parport)
pg: pg version 1.02, major 97
pg0: Autoprobe failed
pg: No ATAPI device detected
paride: version 1.06 installed (parport)
pg: pg version 1.02, major 97
pg0: Autoprobe failed
pg: No ATAPI device detected
paride: version 1.06 installed (parport)
pg: pg version 1.02, major 97
pg0: Autoprobe failed
pg: No ATAPI device detected
paride: version 1.06 installed (parport)
pg: pg version 1.02, major 97
pg0: Autoprobe failed
pg: No ATAPI device detected
paride: version 1.06 installed (parport)
pg: pg version 1.02, major 97
pg0: Autoprobe failed
pg: No ATAPI device detected
paride: version 1.06 installed (parport)
pg: pg version 1.02, major 97
pg0: Autoprobe failed
pg: No ATAPI device detected
paride: version 1.06 installed (parport)
pg: pg version 1.02, major 97
pg0: Autoprobe failed
pg: No ATAPI device detected
paride: version 1.06 installed (parport)
pg: pg version 1.02, major 97
pg0: Autoprobe failed
pg: No ATAPI device detected
paride: version 1.06 installed (parport)
pg: pg version 1.02, major 97
pg0: Autoprobe failed
pg: No ATAPI device detected
paride: version 1.06 installed (parport)
pg: pg version 1.02, major 97
pg0: Autoprobe failed
pg: No ATAPI device detected
paride: version 1.06 installed (parport)
pg: pg version 1.02, major 97
pg0: Autoprobe failed
pg: No ATAPI device detected
paride: version 1.06 installed (parport)
pg: pg version 1.02, major 97
pg0: Autoprobe failed
pg: No ATAPI device detected
paride: version 1.06 installed (parport)
pg: pg version 1.02, major 97
pg0: Autoprobe failed
pg: No ATAPI device detected
paride: version 1.06 installed (parport)
pg: pg version 1.02, major 97
pg0: Autoprobe failed
pg: No ATAPI device detected
paride: version 1.06 installed (parport)
pg: pg version 1.02, major 97
pg0: Autoprobe failed
pg: No ATAPI device detected
paride: version 1.06 installed (parport)
pg: pg version 1.02, major 97
pg0: Autoprobe failed
pg: No ATAPI device detected
paride: version 1.06 installed (parport)
pg: pg version 1.02, major 97
pg0: Autoprobe failed
pg: No ATAPI device detected
paride: version 1.06 installed (parport)
pg: pg version 1.02, major 97
pg0: Autoprobe failed
pg: No ATAPI device detected
paride: version 1.06 installed (parport)
pg: pg version 1.02, major 97
pg0: Autoprobe failed
pg: No ATAPI device detected
paride: version 1.06 installed (parport)
pg: pg version 1.02, major 97
pg0: Autoprobe failed
pg: No ATAPI device detected
paride: version 1.06 installed (parport)
pg: pg version 1.02, major 97
pg0: Autoprobe failed
pg: No ATAPI device detected
paride: version 1.06 installed (parport)
pg: pg version 1.02, major 97
pg0: Autoprobe failed
pg: No ATAPI device detected
paride: version 1.06 installed (parport)
pg: pg version 1.02, major 97
pg0: Autoprobe failed
pg: No ATAPI device detected
paride: version 1.06 installed (parport)
pg: pg version 1.02, major 97
pg0: Autoprobe failed
pg: No ATAPI device detected
paride: version 1.06 installed (parport)
pg: pg version 1.02, major 97
pg0: Autoprobe failed
pg: No ATAPI device detected
paride: version 1.06 installed (parport)
pg: pg version 1.02, major 97
pg0: Autoprobe failed
pg: No ATAPI device detected
 
Old 09-18-2005, 02:20 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 79
Since it is a 2.4.x kernel and you are using an ide cdrewriter you will need to pass an "ide-scsi=/dev/hdd" argument to the kernel.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mouse recorder? Marade Mandriva 4 06-09-2005 08:43 AM
A recorder that works?? BajaNick Linux - Software 7 12-08-2003 11:42 PM
CD-Recorder problems atwah Linux - Newbie 3 09-15-2003 03:25 AM
Sound Recorder PionexUser Linux - General 1 09-12-2003 12:46 AM
Output recorder alitrix Linux - Software 1 06-13-2003 04:21 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 09:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration