-   Linux - Hardware (
-   -   slackware 9 realtek ethernet (

cowboy_ein 04-15-2003 04:42 PM

slackware 9 realtek ethernet
I just installed Slackware 9 onto my machine and the install seemed to go very well. While configuring my network, the probe detected my ethernet card and said all was well. When I booted into GNOME, and opened Mozilla to test the internet, I was rewarded with a "page unable to be opened" message. I ran
/sbin/netconfig again, and when it got to the part where it probed for my ethernet card, it said "No ethernet card has been found on your system."

I looked at my /etc/rc.d/rc.netdevice file and it told me this :

#Load module for network device.
#This script generated during the installation.

/sbin/modprobe 8139too

So I ran /sbin/modprobe 8139too and gave me this message:

modprobe: Can't open dependencies file /lib/modules/2.4.20-gentoo-r2/modulesdep (No such file or directory).

I am kind of confused as to why the gentoo part of "2.4.20-gentoo-r2" was mentioned. I recently tried to install gentoo on my system but the downloads were ridiculously slow, so I reformatted and repartitioned that hard disk, so I'm not too sure why gentoo didnt get erased (I chose "Install kernel from Slackware CD" during installation.

So now I'm a little frustrated about this issue, but I know I can get the help I need from the people here.

thanks in advance


griffin 04-16-2003 04:12 PM

You're right in that you're using the gentoo modules instead of the slackware ones, which is a bit odd. Try looking in /lib/modules for something that does not say gentoo in the name. If you don't see anything, a reformat of that partition and a re-install are in order.

If you do see a directory called 2.4.20, then all you need to do is edit your /etc/lilo.conf and make sure that you're booting the slackware kernel instead of the gentoo kernel (the image at the bottom should be set to something like /vmlinuz)

All times are GMT -5. The time now is 11:40 AM.