LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Hardware (http://www.linuxquestions.org/questions/forumdisplay.php?f=18)
-   -   Skype not working - internal microphone problems (http://www.linuxquestions.org/questions/showthread.php?t=4175436739)

CentOS6.3User 11-12-2012 02:43 AM

Skype not working - internal microphone problems
 
Hi,

I have CentOS 6.3 on a Lenovo E520 thinkpad. I have installed Skype but couldn't make the internal microphone work. I have played around with alsamixer, pavucontrol to no avail. Can someone tell me, a linux system administration novice, how to fix this and get the microphone working. The relevant output (lspci, uname -r) requested in the instruction thread is:

[root@es520 modprobe.d]# /sbin/lspci
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b4)
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b4)
00:1c.2 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 3 (rev b4)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b4)
00:1c.7 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 8 (rev b4)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM65 Express Chipset Family LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 04)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)
03:00.0 System peripheral: Ricoh Co Ltd Device e823 (rev 07)
08:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)
[root@es520 modprobe.d]#

[root@es520 modprobe.d]# uname -r
2.6.32-279.14.1.el6.x86_64

Can someone please help me? Is there any other forum that this question is more relevant to?

kakaka 11-13-2012 04:36 AM

Please post a screen snapshot of what the Sound Devices panel looks like in your Skype software.

Have you tried checking the box labeled "Allow Skype to adjust your mixer levels" ?

CentOS6.3User 11-13-2012 02:31 PM

I managed to solve this problem by downloading pavucontrol, and then following the instructions here.


All times are GMT -5. The time now is 10:42 AM.