-   Linux - Hardware (
-   -   sis graphics card driver issue (

shinsplints 08-08-2004 02:12 PM

sis graphics card driver issue
I recently installed Slackware 10.0 on my laptop (Dell Inspiron 1000) which has an integrated sis graphics card. The display is really odd though. I am using the primary laptop display alongside an LCD monitor, and eventually I hope to run an extended desktop, but for now I'm just trying to get each one working separately. When I run xorgcfg or just start X up with the sis driver, the external monitor displays alright, but the laptop display freezes and won't display anything correctly. If I unplug the lcd and change the driver to a standard VESA driver, the laptop monitor works just fine. However, if I then plug the lcd back in and try to start X with a VESA driver, the computer freezes. I can't even get back to a console or ctrl-alt-del, it just freezes completely and I have to do a hard shutdown. Anyone know what could be the problem? I'm going to try to get a good log to post for more help.

darin3200 08-08-2004 05:26 PM

What sis driver? I know there is a generic sis driver as well as quite a few specific ones. Have you tried any of the other sis drivers. Even though they may not be the right card number the architecture may be similar enough that it will run.

shinsplints 08-08-2004 05:43 PM

I'm not sure what version of the driver I had, but I went to:
and downloaded a new one and everything works correctly now.

dns21 09-29-2004 09:53 PM

I attempted to install Fedora Core 2 on the same laptop "dell inspiron 1000" and wasn't able to go through the graphical install. I went through the text installs and when I booted up I had the same problem when it started up as i did when i attempted to go through the graphical install. The screen displays garbage. Does SIS require XFree86? Doesn't this come with most distros? After 2 days now, I am still in the dark as to how to go about fixing this problem. I have never had any major issues with any Linux install but I have never had a chance to venture into the craziness of linux on a laptop. Furthermore, after looking at a few websites including (or i forgot) I have not been able to find the Inspiron 1000. One post here mentioned that it was working (with problems but never mentioned my current issue) with Mandrake and I found another that seemed to get Slackware 10 on it OK but it seems there is not very much support for fedora. I just formatted my mbr (to get the boot-loader off after mistakingly trying another distro first - how do you uninstall linux?) and now have to reinstall windows (sadly I am going to use windows again - I figure it might be handy for a few things - 'i really tried to get away for good - maybe i will soon though') on a 4GB partition and am going to attempt to install College after this. Suffice to say, i will choose to install the bootloader on the first sector of the partition should linux try to get fresh again. Can anybody point me in the right direction, i still don't know what I am doing and can't seem to find the proper support anywhere else on the net?

rscorpio64 11-05-2004 08:08 PM

display solution
for those of you who are having an annoying time with the display (i.e. garbage after login) i found that hitting the function key and F3 will solve the problem. why it does this, I'm not sure.. if anyone has a solution for that it would be great. other than that, i've had linux on my INSPIRON/1000 for quite some time and works flawlessly (Mandrake v10). It just has an issue when attempting to play games, the screen goes crazy again, but unfortunately the function key does not correct this. One of the logs I found says something about the video card unable to "RENDER" the graphics. anyone have any clues....

hope this tip helps


All times are GMT -5. The time now is 05:50 PM.