LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 11-01-2005, 06:09 AM   #1
Liefmans
LQ Newbie
 
Registered: Oct 2005
Location: Germany & Belgium
Distribution: debian
Posts: 24

Rep: Reputation: 15
Question setting up home network, ethernet card installed?


Hi,

I'm trying to make a home network but can't start a dhcp server. I have 3 ethernet cards in my computer: 2 LAN and 1 WLAN. They are on my motherboard: ASUS A7N8X-E deluxe.

When I run netcardconfig, I can see eth0, eth1, eth2, so it looks like I have the 3 cards installed, but I played around with dmesg and lspci and I'm not so sure anymore of that. (see below some copy pastes of that).

To setup my home network, I think I have to answer following questions:
  • Are my ethernet cards installed and if not, why do I have than an eth0, -1 and -2. To which devices are they referring?
  • If not installed (what I think), how do I install them
  • How do I set up my home network, but this might be easy when I have ethernet cards installed.

Can anyone help me please? I always hear that setting up a home network is easy in linux but I never succeeded.

Some information about my computer:
dmesg | grep eth:
Code:
eth1: Yukon Gigabit Ethernet 10/100/1000Base-T Adapter
forcedeth.c: Reverse Engineered nForce ethernet driver. Version 0.32.
eth2: forcedeth.c: subsystem: 01043:80a7 bound to 0000:00:04.0
eth1394: $Rev: 1247 $ Ben Collins <bcollins@debian.org>
eth1394: eth3: IEEE-1394 IPv4 over 1394 Ethernet (fw-host0)
eth2: no IPv6 routers present
eth0: no IPv6 routers present
eth1: network connection up using port A
eth1: no IPv6 routers present
lspci:
Code:
0000:00:00.0 Host bridge: nVidia Corporation nForce2 AGP (different version?) (rev c1)
0000:00:00.1 RAM memory: nVidia Corporation nForce2 Memory Controller 1 (rev c1)
0000:00:00.2 RAM memory: nVidia Corporation nForce2 Memory Controller 4 (rev c1)
0000:00:00.3 RAM memory: nVidia Corporation nForce2 Memory Controller 3 (rev c1)
0000:00:00.4 RAM memory: nVidia Corporation nForce2 Memory Controller 2 (rev c1)
0000:00:00.5 RAM memory: nVidia Corporation nForce2 Memory Controller 5 (rev c1)
0000:00:01.0 ISA bridge: nVidia Corporation nForce2 ISA Bridge (rev a4)
0000:00:01.1 SMBus: nVidia Corporation nForce2 SMBus (MCP) (rev a2)
0000:00:02.0 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4)
0000:00:02.1 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4)
0000:00:02.2 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4)
0000:00:04.0 Ethernet controller: nVidia Corporation nForce2 Ethernet Controller (rev a1)
0000:00:05.0 Multimedia audio controller: nVidia Corporation nForce Audio Processing Unit (rev a2)
0000:00:06.0 Multimedia audio controller: nVidia Corporation nForce2 AC97 Audio Controler (MCP) (rev a1)
0000:00:08.0 PCI bridge: nVidia Corporation nForce2 External PCI Bridge (rev a3)
0000:00:09.0 IDE interface: nVidia Corporation nForce2 IDE (rev a2)
0000:00:0d.0 FireWire (IEEE 1394): nVidia Corporation nForce2 FireWire (IEEE 1394) Controller (rev a3)
0000:00:1e.0 PCI bridge: nVidia Corporation nForce2 AGP (rev c1)
0000:01:04.0 Ethernet controller: Marvell Technology Group Ltd. 88E8001 Gigabit Ethernet Controller (rev 13)
0000:01:05.0 Network controller: RaLink Wireless PCI Adpator RT2400 / RT2460
0000:03:00.0 VGA compatible controller: nVidia Corporation NV36.2 [GeForce FX 5700] (rev a1)
lspci -v and filtered on all what is ethernet:
Code:
0000:00:04.0 Ethernet controller: nVidia Corporation nForce2 Ethernet Controller (rev a1)
        Subsystem: ASUSTeK Computer Inc. A7N8X Mainboard onboard nForce2 Ethernet
        Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 22
        Memory at ed086000 (32-bit, non-prefetchable) [size=4K]
        I/O ports at c400 [size=8]
        Capabilities: [44] Power Management version 2

0000:01:04.0 Ethernet controller: Marvell Technology Group Ltd. 88E8001 Gigabit Ethernet Controller (rev 13)
        Subsystem: ASUSTeK Computer Inc. Marvell 88E8001 Gigabit Ethernet Controller (Asus)
        Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 17
        Memory at ec000000 (32-bit, non-prefetchable) [size=16K]
        I/O ports at 9000 [size=256]
        Capabilities: [48] Power Management version 2
        Capabilities: [50] Vital Product Data

0000:01:05.0 Network controller: RaLink Wireless PCI Adpator RT2400 / RT2460
        Subsystem: ASUSTeK Computer Inc. WiFi-b add-on Card
        Flags: bus master, slow devsel, latency 32, IRQ 16
        Memory at ec004000 (32-bit, non-prefetchable) [size=8K]
        Capabilities: [40] Power Management version 2
 
Old 11-01-2005, 06:40 AM   #2
cigarstub
Member
 
Registered: Sep 2005
Posts: 145

Rep: Reputation: 15
Never try to setup a lan w/out pro help, one device on the net fail and your lan not work. Try to have plenty of switch so you can test each one, if you have a straigh cable, you can cut it and rearrange so it become a cross. The setup should be auto, so just do the connecting work,
 
Old 11-01-2005, 05:47 PM   #3
dd12
LQ Newbie
 
Registered: Sep 2005
Posts: 28

Rep: Reputation: 15
How many computers are you trying to setup?
What error messages are you getting?
 
Old 11-01-2005, 06:24 PM   #4
Liefmans
LQ Newbie
 
Registered: Oct 2005
Location: Germany & Belgium
Distribution: debian
Posts: 24

Original Poster
Rep: Reputation: 15
Just 2 computers.

I don't get a real failure message. It is just that my "slave" computer doesn't find a DHCP server and the "master" computer can't start a DHCP server.

I have tried with fixed IP adresses but that didn't work neither.
 
Old 11-01-2005, 06:30 PM   #5
filfish
LQ Newbie
 
Registered: Oct 2005
Location: newquay - wales - uk
Distribution: RH9
Posts: 29

Rep: Reputation: 15
whats your dhcpd.conf file look like?
$gedit /etc/dhcpd.conf
 
Old 11-01-2005, 06:39 PM   #6
dd12
LQ Newbie
 
Registered: Sep 2005
Posts: 28

Rep: Reputation: 15
okay...it sounds like you are a novice. We first need to get fixed IP's working before we move into a DHCP configuration.

Can both computers ping a gateway or the internet? Do you have a wireless router that supplies DHCP? On each computer do an 'ifconfig -a' and 'netstat -rn' and paste the results.
 
Old 11-01-2005, 06:42 PM   #7
Liefmans
LQ Newbie
 
Registered: Oct 2005
Location: Germany & Belgium
Distribution: debian
Posts: 24

Original Poster
Rep: Reputation: 15
Please find below my dhcpd.conf.

I rebooted my computer and when starting the dhcp server, I got a failure message with a reference to the syslog. Where can I find that?

Code:
#
# Sample configuration file for ISC dhcpd for Debian
#
# $Id: dhcpd.conf,v 1.4.2.2 2002/07/10 03:50:33 peloy Exp $
#

# option definitions common to all supported networks...
option domain-name "fugue.com";
option domain-name-servers 217.237.150.97, 217.237.149.161;

option subnet-mask 255.255.255.224;
default-lease-time 600;
max-lease-time 7200;
}
 
Old 11-01-2005, 06:59 PM   #8
filfish
LQ Newbie
 
Registered: Oct 2005
Location: newquay - wales - uk
Distribution: RH9
Posts: 29

Rep: Reputation: 15
if you've got your ipaddress and gateway etc setup on the server and your device is active you need to set up you dhcpd.conf file similar to this one here:

ddns-update-style interim;nm
ignore client-updates;

subnet 192.168.0.0 netmask 255.255.255.0 {
option domain-name "yourdomain.com";
range dynamic-bootp 192.168.0.50 192.168.0.100;
default-lease-time 21600;
max-lease-time 43200;
}


this really is a very basic version but should get you started, change the subnet 192.168.0.0 netmask 255.255.255.0 { line to your desired ip scope you can leave the netmask bit alone for now, and change your range dynamic-bootp 192.168.0.50 192.168.0.100; line to coincide with your subnet.

restart your network

from the terminal
$service network restart

then try your dhcp again
$service dhcpd start
 
Old 11-01-2005, 07:03 PM   #9
Liefmans
LQ Newbie
 
Registered: Oct 2005
Location: Germany & Belgium
Distribution: debian
Posts: 24

Original Poster
Rep: Reputation: 15
I'm trying already a (very) long time to get linux running (as it should) but i never got really started...

on my master computer:

ifconfig -a

Code:
eth0      Link encap:Ethernet  HWaddr 00:0E:A6:A1:60:37
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:16 Base address:0x4000

eth1      Link encap:Ethernet  HWaddr 00:0E:A6:A3:39:9A
          inet6 addr: fe80::20e:a6ff:fea3:399a/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4491 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4944 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1517610 (1.4 MiB)  TX bytes:727273 (710.2 KiB)
          Interrupt:17 Memory:ec000000-0

eth2      Link encap:UNSPEC  HWaddr 6E-56-69-64-69-61-00-00-00-00-00-00-00-00-00-00
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

eth3      Link encap:Ethernet  HWaddr 00:00:6C:DC:0E:2A
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:22 Base address:0xe000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:319 errors:0 dropped:0 overruns:0 frame:0
          TX packets:319 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:47538 (46.4 KiB)  TX bytes:47538 (46.4 KiB)

ppp0      Link encap:Point-to-Point Protocol
          inet addr:80.131.15.35  P-t-P:217.0.116.159  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
          RX packets:4391 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4853 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3
          RX bytes:1414880 (1.3 MiB)  TX bytes:595186 (581.2 KiB)

sit0      Link encap:IPv6-in-IPv4
          NOARP  MTU:1480  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
netstat -rn
Code:
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
217.0.116.159   0.0.0.0         255.255.255.255 UH        0 0          0 ppp0
0.0.0.0         217.0.116.159   0.0.0.0         UG        0 0          0 ppp0
Do you need the data on the 'slave' computer too? That one is working because I can work normally when I use the WinXP router. Now it is a little bit difficult. (I must reboot and start WinXP).
 
Old 11-01-2005, 07:10 PM   #10
filfish
LQ Newbie
 
Registered: Oct 2005
Location: newquay - wales - uk
Distribution: RH9
Posts: 29

Rep: Reputation: 15
you need to set an ipaddress for one of the ethx cards, system tools > internet configuration, set up an ethernet connection with an ipaddress on the same range that you want to set in the dhcpd.conf file.

example if the range you have in you conf file is 192.168.0.10 192.168.0.20
then setup your ipaddress for the ethernet connection as something like 192.168.0.254
netmask 255.255.255.0
gateway 'whatever your router or gateway address is' but not essential to get your dhcp running so you can leave it blank for the moment, but if you want the machines to connect to internet you'll need to set it later
 
Old 11-01-2005, 07:25 PM   #11
Liefmans
LQ Newbie
 
Registered: Oct 2005
Location: Germany & Belgium
Distribution: debian
Posts: 24

Original Poster
Rep: Reputation: 15
Hi Filfish,

before I posted the question, I tried manually .
Code:
ifconfig eth0 10.0.0.1 netmask 255.0.0.0 up  #on master and
ifconfig eth0 10.0.0.2 netmask 255.0.0.0 up  #on slave
No success

That is why I think that I just have one ethernet card installed and that there the problem lies. This is also why I posted the question in the hardware forum.

I tried your script:
Code:
oot@Lorentz:f# /etc/init.d/networking restart
* /etc/network/options is deprecated.
Setting up IP spoofing protection...done (rp_filter).
Reconfiguring network interfaces...ifup: interface lo already configured
Plugin rp-pppoe.so loaded.
done.
root@Lorentz:f# /etc/init.d/dhcp restart
Stopping DHCP server: dhcp.
Starting DHCP server: dhcpd failed to start - check syslog for diagnostics.

Last edited by Liefmans; 11-01-2005 at 07:31 PM.
 
Old 11-01-2005, 07:32 PM   #12
filfish
LQ Newbie
 
Registered: Oct 2005
Location: newquay - wales - uk
Distribution: RH9
Posts: 29

Rep: Reputation: 15
what distro are you on?

dhcp wont start if you haven't set up one of the ethernet cards

eth0 Link encap:Ethernet HWaddr 00:11:09:2E:F2:93
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

eth1 Link encap:Ethernet HWaddr 00:11:09:2E:F2:92
inet addr:192.168.11.26 Bcast:192.168.11.255 Mask:255.255.255.0
inet6 addr: fe80::211:9ff:fe2e:f292/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:14263 errors:0 dropped:0 overruns:0 frame:0
TX packets:11755 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:15310888 (14.6 MiB) TX bytes:1405947 (1.3 MiB)
Interrupt:169

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:57 errors:0 dropped:0 overruns:0 frame:0
TX packets:57 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:4166 (4.0 KiB) TX bytes:4166 (4.0 KiB)

if you look at that eth0 has not been set and eth1 has, you can tell if its set by looking at the second line -
inet addr:192.168.11.26 Bcast:192.168.11.255 Mask:255.255.255.0

without a fixed ipaddress on one of the ethernet cards you'll get nowhere
 
Old 11-01-2005, 07:33 PM   #13
filfish
LQ Newbie
 
Registered: Oct 2005
Location: newquay - wales - uk
Distribution: RH9
Posts: 29

Rep: Reputation: 15
oh, thats from one of mine as an example!
 
Old 11-01-2005, 07:40 PM   #14
Liefmans
LQ Newbie
 
Registered: Oct 2005
Location: Germany & Belgium
Distribution: debian
Posts: 24

Original Poster
Rep: Reputation: 15
I'm on Knoppix.
 
Old 11-01-2005, 07:46 PM   #15
Liefmans
LQ Newbie
 
Registered: Oct 2005
Location: Germany & Belgium
Distribution: debian
Posts: 24

Original Poster
Rep: Reputation: 15
I tried already much to get the network before I posted the question (I am desperate).
I tried already:
- fixed IP adresses
-all kind of scripts
- but because they didn't work, the GUI tool firestarter

nothing worked. That's why I'm wondering now if my ethernet card on my master is installed. One is installed, that is for sure because I'm using that one know.

Last edited by Liefmans; 11-01-2005 at 07:50 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Setting Up Ethernet Card Drakkath Slackware 6 05-17-2005 07:44 PM
Need help setting up a home network. joe83 Linux - Networking 7 08-09-2004 03:58 PM
Ethernet card on laptop: I installed my D-Link ethernet card into Redhat 9, not detec brighamr Linux - Hardware 0 05-18-2004 01:33 AM
Help with setting up home network plehman Linux - Networking 1 02-14-2004 01:15 PM
Setting up a home network gi13s Linux - Networking 1 08-06-2001 09:37 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 02:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration