Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Hardware
User Name
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?


  Search this Thread
Old 09-06-2004, 05:28 PM   #1
Pi Man
LQ Newbie
Registered: Sep 2004
Distribution: Gentoo
Posts: 16

Rep: Reputation: 0
Setting permissions on an external USB hard drive so that all users can read from it?

Greetings. I'm new, both to the forums, and to Linux itself.

I'm having trouble getting an external USB drive working correctly. Any user can mount it, but I can't figure out how to make the contents accessible to any user. Chmod won't change the directory permissions, and I can't find anything in the man pages, info pages, or the SuSE help-center that partains to this problem.

If it's of any relavence, I'm on SuSE 8.2 (haven't gotten around to upgrading to 9.1) and the external drive is actually an internal 40GB drive in a drive converter case, and the drive is formatted as NTFS.

I can read from it as the root user, but not as a normal user. I don't really have to be able to write to it, yet. I'm going to move all the data to my internal hard drive, reformat it, and put it all back after it's in ReiserFS.

Thanks for any help you guys can give me.
Pi Man.

P.S. Output of /sbin/lsusb

Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 002 Device 002: ID 0680:0002 Realtek Semiconductor Corp., CPP Div. (Avance L ogic)
Bus 001 Device 001: ID 0000:0000
Bus 001 Device 002: ID 0402:5621 ALi Corp.

Last edited by Pi Man; 09-06-2004 at 05:36 PM.
Old 09-07-2004, 12:30 AM   #2
Registered: Oct 2003
Posts: 568

Rep: Reputation: 30
Alright - you have to edit /etc/fstab to allow your users to read/write the device. Here is what you do:

From a console:
pico /etc/fstab

You'll get a text file that looks something like this:

/dev/hda2  	/  	ext2  	defaults  	1 1
/dev/hdb1 	/home 	ext2 	defaults 	1 2
/dev/cdrom 	/media/cdrom 	auto 	ro,noauto,user,exec 	0 0
/dev/fd0 	/media/floppy 	auto 	rw,noauto,user,sync 	0 0
proc 	/proc 	proc 	defaults 	0 0
/dev/hda1 	swap 	swap 	pri=42 	0 0

Now, I'm going to make this up, plug in your own values as necc.:

/dev/hdd1	/usbdrive 	auto 	defaults 	0 0

 Change that line, the line that pertains to your USB drive, to read like this:

/dev/hdd1	/usbdrive 	auto 	rw,users 	0 0
Save, and reboot - you should be good to go - with read/write access.

This may also be helpful:

Last edited by PenguinPwrdBox; 09-07-2004 at 12:33 AM.
Old 09-07-2004, 09:50 PM   #3
Pi Man
LQ Newbie
Registered: Sep 2004
Distribution: Gentoo
Posts: 16

Original Poster
Rep: Reputation: 0
I already edited my fstab file to include the user and ro options, but that didn't help.

I found a solution, though. I added "uid=" and "gid=" options to fstab.

Is there a way to make it accessible to all users, though?


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing grub to external USB hard drive for later use as internal hard drive dhave Linux From Scratch 2 12-10-2005 08:48 AM
Can't read external hard drive alrymala Linux - Security 1 10-23-2005 01:42 PM
Write permissions for external hard drive kg4ysy Linux - Hardware 1 05-19-2005 05:36 AM
external hard drive permissions djljjm Linux - Hardware 12 04-06-2005 01:23 PM
read external hard drive mccclxxxv Linux - Hardware 4 04-21-2004 06:15 PM > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 09:43 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration