LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Serious Serial port issues... (https://www.linuxquestions.org/questions/linux-hardware-18/serious-serial-port-issues-611930/)

ramesh6056 01-08-2008 03:21 AM

Serious Serial port issues...
 
Hi all,

I am really very urgent to get a solution to serial port issue..
Anyone who has faced this problem, please don't fail to read my post..

Problem--

My serial port is dumping garbage or some rubbish value on the minicom when i connect my serial port(usbtoserial) to the board. I checked the following to resolve the problem..

1) I connected a serial cable and then shorted the 2nd and 3rd pin (RXr and TXr).. I am able to get what i type on my minicom aswell as on the hyperterminal.

2) The above point indicated me that serial port(usbtoserial cable) is alright.. With the same set up when i connect my target board at baud rate of 38400 i am getting garbage!!!Whatever the baudrate may be, it always dumps garbage...

What may be the problem?? What steps i can take to resolve it..

If someone has faced this earlier and resolved it through some means please help me in sharing the solution...

michaelk 01-08-2008 08:12 PM

You have not provided any details and therefore it is impossible to provide any specific help.
What is this target board you speak of? Can you post a link or any information on its function.

In addition to the baud rate you must also configure the parity and stop bit(s) of the serial port. If they are not the same then you will get garbage. In addition are you positive that the output of the target board is ASCII text? If not then you will also see garbage being displayed.

Is this related to your other post and the PXA255 board?

ramesh6056 01-08-2008 11:19 PM

Quote:

Originally Posted by michaelk (Post 3016134)
You have not provided any details and therefore it is impossible to provide any specific help.
What is this target board you speak of? Can you post a link or any information on its function.

In addition to the baud rate you must also configure the parity and stop bit(s) of the serial port. If they are not the same then you will get garbage. In addition are you positive that the output of the target board is ASCII text? If not then you will also see garbage being displayed.

Is this related to your other post and the PXA255 board?

Hi,

thanks for your reply..

Yes this is related to my pxa255 board only. All the settings of the minicom are the same which was working earlier with my board, all of the sudden this has happened. Suddenly my minicom and hyperterminal on windows are dumping garbage. I checked with the other systems with the same settigs...it works perfectly..

But when i short my 2nd and 3rd pin on the systems serial port it is perfect.. What happens when it is connected to the board??

michaelk 01-11-2008 06:01 PM

What do you mean by other systems? I assume you are using the same serial cable between the other systems?

ramesh6056 01-15-2008 09:42 PM

Hi guys,

Thanks for your reply, I solved the problem...

The problem is with the serial port hardware. We used some faulty cable which supplied improper voltage level on the serial port hardware which has affected the chip it seems.

I tried the usb to serial cable adapter. It will work only for some extent and it is not a real serial port...Those types of adapters work for some extent and if that works exactly for your application than it is your luck...

So, atlast the solution was to buy an pci card with two serial ports and installed on my system... Now everything is going well on my system...

It was an hardware related issue and not problem on the software side..


All times are GMT -5. The time now is 06:08 PM.