-   Linux - Hardware (
-   -   seeking information on the iPod mini (

superbondbond 02-02-2004 05:31 PM

seeking information on the iPod mini
Well, the inevitable has come true. My wife has fallen in love with the mini iPod (pink of course), and wants to get one. And to my surprise she also asked if will work with Linux (I've taught her well ;)).
After doing a little reading, I've noticed that there are people out there that have been connecting and mounting the ipod as a SCSI block device. That sounds promising.

With the "mini" from what I've read is not only firewire, but USB 2.0 compatible. With my box at home, I would be choosing the latter. I've had great success in the past with a couple of "USB mass storage devices" (a flash card reader, and a digital camera), and my assumption is that the iPod would work the same way.

With this device being so new I'm hesitant to rush out and buy one. However, I do think that it could work.

Any thoughts on this would be welcome, and stay tuned, as if she wears me down and we do end up getting one (I'm trying to at least talk her into green), I'll let everybody know how it goes.

Thanks for any input.

witeshark 02-02-2004 11:30 PM

OK :) Being a Mac user I will set this into the Apple discussions and post the responses :study:

superbondbond 02-03-2004 12:09 AM

Many thanks Witeshark. I'm eager to see what they have to say.

superbondbond 03-22-2004 11:57 AM

--- Update ---
Here's an update for anyone interested in the topic.

I went ahead and bought the iPod mini a few weeks back. it arrived last week and here's what I've discovered.

I connected it to my Linux box via USB, the system identified the iPod and it found three partitions (sda1, sda2, sda3). When I tried to mount any one the partitions, it could not find any filesystem on any of them. The ipod itself said (on it's "about" screen) it was Windows formatted. I tried about every filesystem I could think of to mount it, but none worked. I even ran fdisk on each of them, which worked fine, but still no identifiable filesystem. I was hesitant to actually re-format any of the partitions, for fear of erasing the iPod's OS.
I then connected it to a Windows XP box, and ran through the iTunes installation, which involved some kind of "initialization" of the iPod. When that was all said and done, I went back to the Linux Box, and connected it again. Well, this time there were only two partitions, formatted VFAT, which can be mounted as a usb mass storage device.
I installed GtkPod and it works perfectly. Can transfer songs, playlist, blah blah blah, with no trouble.

Success! (I will submit an entry in the LQ Hardware compatibility list).

I am left wondering what exactly happens during the "initialization" that would take three unformatted partitions down to two. :scratch:

witeshark 03-22-2004 12:41 PM

Very interesting - BTW the Apple discussions never answered, and that forum server has been intermittently off for upgrades. But This forum may well want to see this. :)

davidschob 03-22-2004 04:42 PM

Hey I was just thinking about gettin gone of the full size ipods (not the mini) and was wondering if I had to go through the trouble of installing firewire to make it work... From what I understand, superbondbond, I can make this work with just my plain old usb (I have usb 1 on my home machine). Is that true? If it is I think I'm going to be heading to the bestbuy this weekend!

superbondbond 03-22-2004 04:57 PM

From what I read, the full size iPod's don't come with a USB connector in the box. The USB is an optional accessory. The mini comes with the USB cable. check the apple website to see what each model comes with.

As for using USB1, the computer I'm connecting it to is older and I'm sure it isn't USB2.0, and it seems to have no problems talking to the iPod.
I don't think that would be a problem

If you do end up getting one, I'd be very interested to hear if you go through something similar as I described above.

BTW, I'm very jealous of my wife's new mini iPod. She was smart in getting the pink one, or I'd be "borrowing" a lot. :D I might have to get one of my own sometime.......maybe if we get some money back from the government this year ;)

witeshark 03-22-2004 06:17 PM


Originally posted by davidschob
Hey I was just thinking about gettin gone of the full size ipods (not the mini) and was wondering if <snip>Is that true? If it is I think I'm going to be heading to the bestbuy this weekend!
iPods need USB2's or firewire

superbondbond 03-22-2004 09:25 PM


Originally posted by witeshark
iPods need USB2's or firewire
I saw that too. However, I know that my system does not have USB2.0, and I seem to have no trouble sending/receiving data from the ipod. You also have to consider that Apple doesn't mention Linux in it's minimum system requirements either. ;)

witeshark 03-22-2004 09:31 PM

Well if it's working that's great! And that's a good point that they didn't mention Linux, something I think they should. ;)

Aussie 03-23-2004 01:35 AM

USB2.0 is backwards compatable with USB1.1.

keleko 04-04-2004 04:09 PM

i did it like superbondbond and it works perfectly.

one more thing, i intialized the ipod mini with windows xp and usb1. so there's no need for usb2. on the linuxbox, i'm using firewire... but it should work just as well with usb2.

jml75 08-02-2004 03:51 PM


can you tell me what device am I supposed to mount to be able to read from my firewire cardreader? When I plug it in, I get a message saying :

ieee1394: sbp2: Logged into SBP-2 device
ieee1394: sbp2: Node 0-00:1023: Max speed [S400] - Max payload [2048]

Wich I think looks good. I verified in /proc/scsi and there is a sbp2_0 entry. But What device in /dev is supposed to be linked to that? I have a scsi adapter and 1 scsi drive wich is sda. But when I tried sdb for the flash reader I got, no valid block device.


All times are GMT -5. The time now is 06:34 PM.