LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   scsi cdrom problems (https://www.linuxquestions.org/questions/linux-hardware-18/scsi-cdrom-problems-234465/)

emilryge 09-23-2004 04:45 PM

scsi cdrom problems
 
Hi guys,

Im having trouble getting my cddrive to work on my brand, new Slack install (laptop)

The question is, if the comp knows the drive as scsi0 or sr0?

Code:

root@linuxlap:~# dmesg | grep scsi
Kernel command line: auto BOOT_IMAGE=Slackware ro root=304 hdc=ide-scsi
ide_setup: hdc=ide-scsi
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
hdc: attached ide-scsi driver.
scsi0 : SCSI host adapter emulation for IDE ATAPI devices
Attached scsi CD-ROM sr0 at scsi0, channel 0, id 0, lun 0
sr0: scsi3-mmc drive: 24x/24x writer cd/rw xa/form2 cdda tray
ide-scsi: hdc: unsupported command in request queue (0)

No of the options are working so far, so any help is appreciated.

Fstab looks like this right now

Code:

/dev/hda4        /                ext3        defaults        1  1
/dev/hda1        /win_c          ntfs        ro              1  0
/dev/hda2        /storage        ntfs        ro              1  0
/dev/sr0      /mnt/cdrom      iso9660    noauto,owner,ro  0  0
/dev/fd0        /mnt/floppy      auto        noauto,owner    0  0
devpts          /dev/pts        devpts      gid=5,mode=620  0  0
proc            /proc            proc        defaults        0  0

Thanks,

/ Emil

d0odman 09-24-2004 08:35 PM

Looks like it's working
 
It seems that Slack has recognized your drive fine.

The problem may be in your fstab file. If you're always logged in as root (not a good idea), then it's not a problem, look elsewhere. You can try to use scd0 instead of sr0 or sg0 if that doesn't work.

If you log in as a normal user for work, then you have to change your fstab file to say 'users' instead of 'owner' and add the cdrom group access to the account (usermod -G cdrom <user>)

One problem about using burners in linux. You MUST have root priviledges to burn to the device. That, or turn on the sticky bit for the program (chmod u+s /usr/bin/cdparanoia comes to mind) you're trying to use.

emilryge 09-25-2004 01:45 AM

Hi and thanks for your reply.

The problem is partially resolved. I can now mount data cds, but are having trouble with audio ones. I realize from reading posts in this forum, that audio cds can't be mounted, but I can't play them either.
My Gnome player gives me a Drive Error and the ripper returns a "CD ROM drive not found".

Any ideas?

- Emil

d0odman 09-25-2004 03:59 AM

Check /dev/cdrom
 
I assume you edited your fstab to get it to be able to mount data cds. Now, go check in /dev and see where cdrom is pointing at (it SHOULD be pointing somewhere). If it's not pointing to the same location you have set up in fstab, let's say it was scd0, then rm cdrom, and make a new symbolic link to scd0:

<root shell access>
cd /dev
ls -l cdrom
<is it pointing to what's in fstab? (e.g. /dev/scd0)>
<no? (most likely not)>
rm cdrom
ln -s /dev/scd0 cdrom
<check cdplayer>

HTH

mritch 09-25-2004 06:25 PM

the ripper will use the generic scsi interface to rip data off an audio cd. so the ripper has to be told that /dev/sgX is the cdrom. they are numbered from your firsts generic interface upwards. if you also have scsi in your pc the first sg0 will likely be your scsi-harddisk. if not and you use the ide-scsi emulation for cdrom only sg0 will point to the cdrom you'll like to rip data off.

sl mritch.


All times are GMT -5. The time now is 09:56 PM.