-   Linux - Hardware (
-   -   Scanner/xsane/vuescan nothing wants to work (

kak 08-26-2004 09:59 PM

Scanner/xsane/vuescan nothing wants to work
I am running Slack 10 with stock 2.4.26 kernel. This is what I have done so far:
1.removed original Slack Sane & Xsane packages
2 added modprobe scanner to rc.local
3. compiled from source sane-backends/frontends and xsane
4.downloaded VueScan & unpacked

Nothing wants to work. Xsane freezes at the looking for hardware screen. Even though if I run sane-find-scanner it does find my scanner. Vuescan pops up the splash sreen and that is all. I checked my scanner is supported by both sane and Vuescan.
I run /sbin/lsusb and get :

Bus 001 Device 001: ID 0000:0000
Bus 001 Device 003: ID 04b8:010f Seiko Epson Corp. Perfection 1250

dmesg log reads:

usb.c: registered new driver hiddev
usb.c: registered new driver hid
hid-core.c: v1.8.1 Andreas Gal, Vojtech Pavlik <>
hid-core.c: USB HID support drivers
mice: PS/2 mouse device common for all mice
usb.c: registered new driver usbscanner
scanner.c: 0.4.16:USB Scanner Driver

And my messege log reads:

Aug 26 20:28:15 slacker kernel: usb.c: USB disconnect on device 00:02.1-2 address 2
Aug 26 20:28:15 slacker kernel: uhci.c: USB Universal Host Controller Interface driver v1.1
Aug 26 20:28:15 slacker kernel: usb-uhci.c: $Revision: 1.275 $ time 17:55:05 Jun 13 2004
Aug 26 20:28:15 slacker kernel: usb-uhci.c: High bandwidth mode enabled
Aug 26 20:28:15 slacker kernel: usb-uhci.c: v1.275:USB Universal Host Controller Interface driver
Aug 26 20:28:17 slacker kernel: hub.c: new USB device 00:02.1-2, assigned address 3
Aug 26 20:28:17 slacker kernel: input: USB HID v1.00 Joystick [6666:0667] on usb2:3.0
Aug 26 20:28:17 slacker kernel: hub.c: new USB device 00:02.0-2, assigned address 3
Aug 26 20:28:17 slacker kernel: scanner.c: USB scanner device (0x04b8/0x010f) now attached to scanner0

Can anyone shed some light on how I can get any software to "see" my scanner?
I don't think its permissions, I have scanner0 set to 777.

mdg 08-27-2004 12:55 AM

What is the output of "lsmod"? You may not have module usbcore loaded.

kak 08-27-2004 07:07 AM

lsmod : looks like it is loading USB
it reads:
scanner 11040 0 (unused)
hid 21220 0 (unused)
usb-ohci 19240 0 (unused)
usbcore 59308 1 (ehci-hcd scanner hid usb-ohci)

mdg 08-27-2004 08:31 AM

Check /etc/sane.d/epson.conf. If you're using the scanner module it should look like this:

# epson.conf
# here are some examples for how to configure the EPSON backend
# SCSI scanner:
#scsi EPSON
# Parallel port scanner:
#pio 0x278
#pio 0x378
#pio 0x3BC
# USB scanner:
# There are two different methods of configuring a USB scanner: libusb and the kernel module
# For any system with libusb support (which is pretty much any recent Linux distribution) the
# following line is sufficient. This however assumes that the connected scanner (or to be more
# accurate, it's device ID) is known to the backend.
# For libusb support for unknown scanners use the following command
# usb <product ID> <device ID>
# e.g.:
# usb 0x4b8 0x110
# And for the scanner module, use the following configuration:
#usb /dev/usbscanner0
usb /dev/usb/scanner0

kak 08-27-2004 06:00 PM

According to I am to use the plustek back end which reads :

# Plustek-SANE Backend configuration file
# For use with LM9831/2/3 based USB scanners

# each device needs at least two lines:
# - [usb] vendor-ID and product-ID
# - device devicename
# i.e. for Plustek (0x07B3) UT12/16/24 (0x0017)
#[usb] 0x4b8 0x010f
device /dev/usb/scanner0
# or
# device libusb:bbb:ddd
# where bbb is the busnumber and ddd the device number
# make sure that your user has access to /proc/bus/usb/bbb/ddd
# additionally you can specify some options
# warmup, lOffOnEnd, lampOff
# For autodetection use
# [usb]
# device /dev/usbscanner
# or simply
# [usb]
# or if you want a specific device but you have no idea about the
# device node or you use libusb, simply set vendor- and product-ID
# [usb] 0x07B3 0x0017
# device auto
# NOTE: autodetection is safe, as it uses the info it got
# from the USB subsystem. If you're not using the
# autodetection, you MUST have attached that device
# at your USB-port, that you have specified...


# options for the previous USB entry
# switch lamp off after xxx secs, 0 disables the feature
option lampOff 300

# warmup period in seconds, 0 means no warmup
option warmup 15

# 0 means leave lamp-status untouched, not 0 means switch off
# on sane_close
option lOffOnEnd 1

# options to tweak the image start-position
# (WARNING: there's no internal range check!!!)
# for the normal scan area
option posOffX 0
option posOffY 0

# for transparencies
option tpaOffX 0
option tpaOffY 0

# for negatives
option negOffX 0
option negOffY 0

# for setting the calibration strip position
# (WARNING: there's no internal range check!!!)
# -1 means use built in
option posShadingY -1
option tpaShadingY -1
option negShadingY -1

# to invert the negatives, 0 disables the feature
option invertNegatives 0

# to save/restore coarse calibration data
option cacheCalData 0

# use alternate calibration routines
option altCalibration 0

# for skipping whole calibration step
option skipCalibration 0

# for skipping entire fine calibration step
# coarse calibration is done
option skipFine 0

# discard the result of the fine white calibration
option skipFineWhite 0

# for replacing the gain values found during
# calibration
option red_gain -1
option green_gain -1
option blue_gain -1

option red_lampoff -1
option green_lampoff -1
option blue_lampoff -1

# for adjusting the default gamma values
option redGamma 1.0
option greenGamma 1.0
option blueGamma 1.0
option grayGamma 1.0

# to enable TPA (non Plustek devices only)
# 0 means default behaviour as specified in the internal tables
# 1 means enable
option enableTPA 0

# model override functionality, currently only available for
# Mustek devices, using NSCs' vendor ID: 0x0400 and
# also their product ID: 0x1000 (LM9831) 0x1001 (LM9832)
# mov/PID | 0x1000 | 0x1001
# ---------------------------------------
# 0 (default)| BearPaw1200 | BearPaw 2400
# 1 | ignored | BearPaw 1200
option mov 0

# and of course the device-name
# device /dev/usbscanner
device auto

# to define a new device, start with a new section:
# [usb]

I am still lost, also can I delete the other backend .conf files? Could I have an issue in one of them?:confused:

mdg 08-28-2004 01:17 AM

Sorry, I assumed you would be using the Epson back-end. The Plustek back-end you posted looks OK, I don't think you need to change anything.

As for deleting all the other back-ends, all you need to do is make sure that the only file in /etc/sane.d that is executable is plustek.conf. All the others should be read-only.

You could also try editing /etc/sane.d/dll.conf and commenting out all the entries except plustek.

Another thing to do is check if you have multiple config files from various attempts to get sane to work. In a terminal type:

find /usr /etc -name dll.conf -print
Make sure you only have one dll.conf file in any sane.d directory found. For example, the result of that command on my system brings up


so I don't have a problem (one file for each dir)
I'm using the /etc/sane.d conf, so every backend in /usr/local/etc/sane.d is read-only (disabled)

Give all that a try and see how you come out

kak 08-28-2004 10:53 AM

I made the same guess that I would use the epson backend untill it wouldn't work. But after doing the prescribed. xsane fires up and it WORKS!!!:D
Thanks alot!!!

I would of never gotten Slack up and runnig with out these forums! Thanks All!

mdg 08-28-2004 12:09 PM

Glad to see you got it going :cool:

J.W. 08-28-2004 04:10 PM

Agreed -- congrats on getting it sorted out, and if no one has mentioned it before, Welcome to LQ -- J.W.

All times are GMT -5. The time now is 07:27 AM.