-   Linux - Hardware (
-   -   SBLive 5.1 In Gentoo - tried to setup ALSA now KDE Sound doesn't even work (

kierl 04-19-2004 08:22 PM

SBLive 5.1 In Gentoo - tried to setup ALSA now KDE Sound doesn't even work
I just installed Gentoo from the 2004.0 minimal CD
I am using kernel 2.4.25-gentoo-r2
nvidia drivers(work)
KDE(works,except sound) just did 'emerge kde' so everything that installs with that
Enlightenment(works as far as I can tell)
ALSA drivers for emu10k1(SBLIVE)(DOESN'T WORK)

when I boot I get multiple errors saying that it can't load the emu10k1 module
I did everything the ALSA Gentoo setup guide said to do and I'm totally lost
This is my first time using Gentoo or ALSA

spuzzzzzzz 04-20-2004 01:32 AM

What does it say if you try "modprobe snd-emu10k1"?

hw-tph 04-20-2004 01:42 AM

Or, if that fails, try alsaconf (provided by the alsa-utils package I believe).


kierl 04-20-2004 02:04 AM

'modprobe snd-emu10k1' gave me no output. When I typed 'alsaconf' into my console and hit enter I got:
/usr/sbin/alsaconf: line 33: [: too many arguments
/usr/sbin/alsaconf: line 35: [: too many arguments
which: no dialog in (/usr/kde/3.2/bin:/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/opt/bin:/usr/i686-pc-linux-gnu/gcc-bin/3.3:/usr/X11R6/bin:/usr/qt/3/bin:/usr/kde/3.2/sbin:/usr/kde/3.2/bin)
which: no whiptail in (/usr/kde/3.2/bin:/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/opt/bin:/usr/i686-pc-linux-gnu/gcc-bin/3.3:/usr/X11R6/bin:/usr/qt/3/bin:/usr/kde/3.2/sbin:/usr/kde/3.2/bin)
Error, dialog or whiptail not found.

spuzzzzzzz 04-20-2004 02:10 AM

if modprobe runs with no output, it means the modules has loaded successfully. Try using alsamixer to unmute everything, then try to play something with aplay. (they should be in either the alsa-utils package or the alsa-tools package)

kierl 04-20-2004 12:17 PM

Sound works again. Sorta KMix is now reporting that I have a 'SigmaTel STAC9708/11'. And I don't have OGain anymore which controlled the rear audio. In alsamixer I can't do anything to 'Headphone LFE 1', 'Headphone Center 1', 'Tone', or '3D Control - Switch' except mute and unmute. So... Basically I have Stereo Sound only on a Dolby Digital 5.1 System... Oh yeah, alsamixer tells me I have an SBLive with that SigmaTel Chipset...

spuzzzzzzz 04-20-2004 05:59 PM

A couple more things you could check:
1) look at the lsmod output to make sure you don't have multiple sound card modules inserted.
2) look at the lspci output to make sure your sound card has an emu10k1 chip. There are a few SBLive! cards out there with different chipsets.

kierl 04-20-2004 06:19 PM

Chipset IS EMU10K1
lsmod output:
Module Size Used by Tainted: P
agpgart 36408 3 (autoclean)
parport_pc 25704 0
parport 23752 0 [parport_pc]
uhci 26204 0 (unused)
tulip 41056 1
emu10k1-gp 1352 0 (unused)
gameport 1388 0 [emu10k1-gp]
snd-pcm-oss 36932 0
snd-mixer-oss 12088 1 [snd-pcm-oss]
snd-seq-midi 3488 0 (autoclean) (unused)
snd-emu10k1-synth 3964 0 (autoclean) (unused)
snd-emux-synth 27324 0 (autoclean) [snd-emu10k1-synth]
snd-seq-midi-emul 4528 0 (autoclean) [snd-emux-synth]
snd-seq-virmidi 2888 0 (autoclean) [snd-emux-synth]
snd-emu10k1 64900 1 (autoclean) [snd-emu10k1-synth]
snd-pcm 56516 0 (autoclean) [snd-pcm-oss snd-emu10k1]
snd-hwdep 4736 0 (autoclean) [snd-emux-synth snd-emu10k1]
snd-util-mem 1168 0 (autoclean) [snd-emux-synth snd-emu10k1]
snd-page-alloc 5972 0 (autoclean) [snd-emu10k1 snd-pcm]
snd-ac97-codec 43676 0 (autoclean) [snd-emu10k1]
snd-rawmidi 13312 0 (autoclean) [snd-seq-midi snd-seq-virmidi snd-emu10k1]
snd-seq-oss 25824 0 (unused)
snd-seq-midi-event 3456 0 [snd-seq-midi snd-seq-virmidi snd-seq-oss]
snd-seq 34960 2 [snd-seq-midi snd-emux-synth snd-seq-midi-emul snd-seq-virmidi snd-seq-oss snd-seq-midi-event]
snd-timer 14436 0 [snd-pcm snd-seq]
snd-seq-device 3792 0 [snd-seq-midi snd-emu10k1-synth snd-emux-synth snd-emu10k1 snd-rawmidi snd-seq-oss snd-seq]
snd 31076 0 [snd-pcm-oss snd-mixer-oss snd-seq-midi snd-emux-synth snd-seq-virmidi snd-emu10k1 snd-pcm snd-hwdep snd-util-mem snd-ac97-codec snd-rawmidi snd-seq-oss snd-seq-midi-event snd-seq snd-timer snd-seq-device]
soundcore 3652 8 [snd]
usbcore 60460 1 [uhci]
nvidia 1631424 11

doesn't look like I have multiple soundcard modules but truthfully I don't really know.
Also, KDE and XMMS say that they are using OSS. I'm guessing this is the ALSA OSS deal. but Point2Play(the WINEX GUI) can't access my sound card. I read through the readme and stuff. It said to disable ARTs and close any programs that are using the OSS driver. When I checked ARTs was already suspended.

kierl 04-20-2004 06:35 PM

Running Warcraft3 installer through Point2Play. Got Sound... Will check on actual game when it gets done.

spuzzzzzzz 04-20-2004 06:58 PM

Your sound card appears to be configured correctly. Maybe the ALSA emu10k1 drivers don't support surround sound? I wouldn't know because I have never had a 5.1 sound card.

kierl 04-20-2004 08:25 PM

That's really odd... cuz according to everything I've seen at ALSA is supposed to give better EMU10K1 Support than the official drivers... F.I. The official EMU10K1 driver doesn't provide MIDI support ALSA supposedly does(although it doesn't work on mine). BTW: Sound does work in WC3 running through WINEX But even when I enable Dolby Surrond(Creative EAX2 doesn't work) I don't get surround sound... just stereo... Center and Rear channels are silent unless I press the 'matrix' button on my speakers.

spuzzzzzzz 04-20-2004 10:23 PM

Do you know that ALSA supports surround? Just because its better than Creative's drivers doesn't mean its fully featured.

kierl 04-21-2004 03:20 AM

True. I'll have to look at that a little more. But here's something odd... running 'emerge gaim' right now and the compiler just spat out this message:

configure: WARNING: Broken OSS API workaround enabled. See README for details.

Make any sense out of that?

spuzzzzzzz 04-21-2004 03:36 AM

I remember that I had to change the sound output in gaim to an external program in order to get gaim to play sound. Maybe that's the meaning of the error message: because you're not using true OSS, gaim's built-in sound player won't work. If that's the case, no big deal. Just change the sound player from built-in to something like aplay.

All times are GMT -5. The time now is 06:53 AM.