LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 02-02-2004, 10:31 AM   #1
SamothB
LQ Newbie
 
Registered: Oct 2003
Location: McKinney, Texas
Distribution: MDK 10 Community
Posts: 27

Rep: Reputation: 15
Question SB live digital out MORE INFO


Why is it that the digital out seems to only work with MDK 9.1? I have tried many distros and can't get digital out, now my head set works with other distros. and why does digital out work with live Knoppix, but when I do a HDD install it won't. I know these are silly rants, and have been asked countless times, but how about another go.

More info: MDK 9.2, analog only,no digital. I get digital out with MDK 9.1 using the exact same harddware (same box), except different HDD.


[samuel@kenny2 samuel]$ lspcidrake -v | fgrep AUDIO
snd-emu10k1 : Creative Labs|SB Live! (audio) [MULTIMEDIA_AUDIO] (vendor:1102 device:0002 subv:1102 subd:8064)
[samuel@kenny2 samuel]$ grep sound-slot /etc/modules.conf
alias sound-slot-0 snd-emu10k1
[samuel@kenny2 samuel]$ /sbin/lsmod
Module Size Used by Not tainted
isofs 28148 1 (autoclean)
nls_iso8859-1 3484 1 (autoclean)
udf 88736 0 (autoclean)
radeon 108512 13
agpgart 48292 3 (autoclean)
snd-seq-midi 5056 0 (autoclean) (unused)
snd-emu10k1-synth 5276 0 (autoclean) (unused)
snd-emux-synth 31900 0 (autoclean) [snd-emu10k1-synth]
snd-seq-midi-emul 6924 0 (autoclean) [snd-emux-synth]
snd-seq-virmidi 4588 0 (autoclean) [snd-emux-synth]
snd-seq-oss 32000 0 (unused)
snd-seq-midi-event 6080 0 [snd-seq-midi snd-seq-virmidi snd-seq-oss]
snd-seq 42544 2 [snd-seq-midi snd-emux-synth snd-seq-midi-emul snd-seq-virmidi snd-seq-oss snd-seq-midi-event]
snd-pcm-oss 43652 0
snd-mixer-oss 14200 0 [snd-pcm-oss]
snd-emu10k1 70948 2 [snd-emu10k1-synth]
snd-pcm 79588 0 [snd-pcm-oss snd-emu10k1]
snd-timer 18436 0 [snd-seq snd-pcm]
snd-page-alloc 9044 0 [snd-emu10k1 snd-pcm]
snd-rawmidi 17760 0 [snd-seq-midi snd-seq-virmidi snd-emu10k1]
snd-util-mem 3040 0 [snd-emux-synth snd-emu10k1]
snd-seq-device 5832 0 [snd-seq-midi snd-emu10k1-synth snd-emux-synth snd-seq-oss snd-seq snd-emu10k1 snd-rawmidi]
snd-hwdep 6304 0 [snd-emu10k1]
snd-ac97-codec 45720 0 [snd-emu10k1]
snd 41380 2 [snd-seq-midi snd-emux-synth snd-seq-virmidi snd-seq-oss snd-seq-midi-event snd-seq snd-pcm-oss snd-mixer-oss snd-emu10k1 snd-pcm snd-timer snd-rawmidi snd-util-mem snd-seq-device snd-hwdep snd-ac97-codec]
soundcore 6340 0 [snd]
af_packet 14856 1 (autoclean)
sr_mod 19384 0 (autoclean)
floppy 55932 0
sis900 15244 1 (autoclean)
supermount 84032 3 (autoclean)
ide-cd 33956 1
cdrom 32608 0 [sr_mod ide-cd]
ide-scsi 11376 0
scsi_mod 106176 2 [sr_mod ide-scsi]
mod_quickcam 102912 1
videodev 7936 2 [mod_quickcam]
usb-ohci 21080 0 (unused)
usbcore 74988 1 [mod_quickcam usb-ohci]
rtc 9004 0 (autoclean)
ext3 60048 2
jbd 39264 2 [ext3]
[samuel@kenny2 samuel]$ /sbin/chkconfig --list sound
sound 0: off 1: off 2: on 3: on 4: on 5: on 6: off
[samuel@kenny2 samuel]$ /sbin/chkconfig --list alsa
alsa 0: off 1: off 2: on 3: on 4: on 5: on 6: off
[samuel@kenny2 samuel]$ aumix -q
bash: aumix: command not found

[samuel@kenny2 samuel]$ /sbin/fuser -v /dev/dsp
[samuel@kenny2 samuel]$ /sbin/fuser -v/dev/dsp
usage: fuser [ -a | -s ] [ -n space ] [ -signal ] [ -kimuv ] name ...
[ - ] [ -n space ] [ -signal ] [ -kimuv ] name ...
fuser -l
fuser -V

-a display unused files too
-k kill processes accessing that file
-i ask before killing (ignored without -k)
-l list signal names
-m mounted FS
-n space search in the specified name space (file, udp, or tcp)
-s silent operation
-signal send signal instead of SIGKILL
-u display user ids
-v verbose output
-V display version information
-4 search IPv4 sockets only
-6 search IPv6 sockets only
- reset options

udp/tcp names: [local_port][,[rmt_host][,[rmt_port]]]

Last edited by SamothB; 02-02-2004 at 02:47 PM.
 
Old 02-02-2004, 08:12 PM   #2
SamothB
LQ Newbie
 
Registered: Oct 2003
Location: McKinney, Texas
Distribution: MDK 10 Community
Posts: 27

Original Poster
Rep: Reputation: 15
Thumbs up Digital out Working Follow up readout

After some adjustments to kmix it started working, here is the troubleshooting readout.

[samuel@kenny2 samuel]$ lspcidrake -v
unknown : Silicon Integrated Systems [SiS]|735 Host [BRIDGE_HOST] (vendor:1039 device:0735)
unknown : Silicon Integrated Systems [SiS]|5591/5592 AGP [BRIDGE_PCI] (vendor:1039 device:0001)
unknown : Silicon Integrated Systems [SiS]|85C503/5513 [BRIDGE_ISA] (vendor:1039 device:0008)
usb-ohci : Silicon Integrated Systems [SiS]|7001 USB [SERIAL_USB] (vendor:1039 device:7001)
usb-ohci : Silicon Integrated Systems [SiS]|7001 USB [SERIAL_USB] (vendor:1039 device:7001)
unknown : Silicon Integrated Systems [SiS]|5513 [IDE] [STORAGE_IDE] (vendor:1039 device:5513)
sis900 : Silicon Integrated Systems [SiS]|SiS900 10/100 Ethernet [NETWORK_ETHERNET] (vendor:1039 device:0900)
snd-emu10k1 : Creative Labs|SB Live! (audio) [MULTIMEDIA_AUDIO] (vendor:1102 device:0002 subv:1102 subd:8064)
emu10k1-gp : Creative Labs|SB Live! (joystick) [INPUT_OTHER] (vendor:1102 device:7002 subv:1102 subd:0020)
Bad:www.linmodems.org: Modem Silicon Operation|MD563X Host Accelerated Modem [COMMUNICATION_OTHER] (vendor:1813 device:4000 subv:144f subd:1033)
Card:ATI Radeon (fglrx): ATI Technologies Inc|Radeon R200 QM [Radeon 9100] [DISPLAY_VGA] (vendor:1002 device:514d subv:174b subd:7149)
unknown : Unknown|USB OHCI Root Hub [Hub|Root Hub] (vendor:0000 device:0000)
unknown : Alcor Micro, Inc.|Hub [Hub|Root Hub] (vendor:058f device:9254)
Flag:TV : Logitech Inc.|QuickCam Express [Vendor Specific Class|Vendor Specific Subclass|Vendor Specific Protocol] (vendor:046d device:0840)
unknown : Unknown|USB OHCI Root Hub [Hub|Root Hub] (vendor:0000 device:0000)
[samuel@kenny2 samuel]$ lspcidrake -v | fgrep AUDIO
snd-emu10k1 : Creative Labs|SB Live! (audio) [MULTIMEDIA_AUDIO] (vendor:1102 device:0002 subv:1102 subd:8064)
[samuel@kenny2 samuel]$ grep sound-slot /etc/modules.conf
alias sound-slot-0 snd-emu10k1
[samuel@kenny2 samuel]$ /sbin/lsmod
Module Size Used by Not tainted
isofs 28148 1 (autoclean)
nls_iso8859-1 3484 1 (autoclean)
udf 88736 0 (autoclean)
sg 35068 0 (autoclean)
radeon 108512 15
agpgart 48292 3 (autoclean)
snd-seq-midi 5056 0 (autoclean) (unused)
snd-emu10k1-synth 5276 0 (autoclean) (unused)
snd-emux-synth 31900 0 (autoclean) [snd-emu10k1-synth]
snd-seq-midi-emul 6924 0 (autoclean) [snd-emux-synth]
snd-seq-virmidi 4588 0 (autoclean) [snd-emux-synth]
snd-seq-oss 32000 0 (unused)
snd-seq-midi-event 6080 0 [snd-seq-midi snd-seq-virmidi snd-seq-oss]
snd-seq 42544 2 [snd-seq-midi snd-emux-synth snd-seq-midi-emul snd-seq-virmidi snd-seq-oss snd-seq-midi-event]
snd-pcm-oss 43652 0
snd-mixer-oss 14200 0 [snd-pcm-oss]
snd-emu10k1 70948 2 [snd-emu10k1-synth]
snd-pcm 79588 0 [snd-pcm-oss snd-emu10k1]
snd-timer 18436 0 [snd-seq snd-pcm]
snd-page-alloc 9044 0 [snd-emu10k1 snd-pcm]
snd-rawmidi 17760 0 [snd-seq-midi snd-seq-virmidi snd-emu10k1]
snd-util-mem 3040 0 [snd-emux-synth snd-emu10k1]
snd-seq-device 5832 0 [snd-seq-midi snd-emu10k1-synth snd-emux-synth snd-seq-oss snd-seq snd-emu10k1 snd-rawmidi]
snd-hwdep 6304 0 [snd-emu10k1]
snd-ac97-codec 45720 0 [snd-emu10k1]
snd 41380 2 [snd-seq-midi snd-emux-synth snd-seq-virmidi snd-seq-oss snd-seq-midi-event snd-seq snd-pcm-oss snd-mixer-oss snd-emu10k1 snd-pcm snd-timer snd-rawmidi snd-util-mem snd-seq-device snd-hwdep snd-ac97-codec]
soundcore 6340 0 [snd]
af_packet 14856 1 (autoclean)
sr_mod 19384 0 (autoclean)
floppy 55932 0
sis900 15244 1 (autoclean)
supermount 84032 3 (autoclean)
ide-cd 33956 1
cdrom 32608 0 [sr_mod ide-cd]
ide-scsi 11376 0
scsi_mod 106176 3 [sg sr_mod ide-scsi]
mod_quickcam 102912 1
videodev 7936 2 [mod_quickcam]
usb-ohci 21080 0 (unused)
usbcore 74988 1 [mod_quickcam usb-ohci]
rtc 9004 0 (autoclean)
ext3 60048 2
jbd 39264 2 [ext3]
[samuel@kenny2 samuel]$ /sbin/chkconfig --list sound
sound 0: off 1: off 2: on 3: on 4: on 5: on 6: off
[samuel@kenny2 samuel]$ /sbin/chkconfig --list alsa
alsa 0 ff 1: off 2: on 3: on 4: on 5: on 6: off
[samuel@kenny2 samuel]$ aumix -q
bash: aumix: command not found
[samuel@kenny2 samuel]$ /sbin/fuser -v/dev/dsp
usage: fuser [ -a | -s ] [ -n space ] [ -signal ] [ -kimuv ] name ...
[ - ] [ -n space ] [ -signal ] [ -kimuv ] name ...
fuser -l
fuser -V

-a display unused files too
-k kill processes accessing that file
-i ask before killing (ignored without -k)
-l list signal names
-m mounted FS
-n space search in the specified name space (file, udp, or tcp)
-s silent operation
-signal send signal instead of SIGKILL
-u display user ids
-v verbose output
-V display version information
-4 search IPv4 sockets only
-6 search IPv6 sockets only
- reset options

udp/tcp names: [local_port][,[rmt_host][,[rmt_port]]]

[samuel@kenny2 samuel]$
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sb live digital output sdrambo Mandriva 1 07-26-2005 01:36 AM
SB Live - Digital Out Not Working Dana Linux - Hardware 2 06-16-2005 11:58 AM
Can't get digital out to work on a SB live 5.1 grizzl3 Linux - Hardware 1 02-21-2005 03:51 PM
SB live 5.1 digital out Veteq Linux - Hardware 4 03-30-2004 04:49 PM
Using Digital output on a SB Live Stephanie Linux - General 5 08-06-2002 02:13 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 11:31 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration