-   Linux - Hardware (
-   -   Sb Live 24 bit refuses to work on OpenSuse 10.2 x64 (

physix 02-02-2007 08:48 AM

Sb Live 24 bit refuses to work on OpenSuse 10.2 x64
Hello everyone,

I am rather new to the Linux community and still quite clueless. After my first installation of OpenSuse 10.2 I have overcome quite some problems at last, but one still remains: my sound does not work. Right after the installation in its initial configuration I had sound, bur very very messed up. Yast (cough) had the proper driver installed, but half of the programs I tested claimed there was no sound card installed. Some programs managed to access the soundcard, for example banshee (media player) and even wine emulation of World of Warcraft ^^ . But then the sound was very choppy and distorted, and volume settings were a complete mess.

Yesterday I decided to download the newest stable version of the alsa driver and compiled it on my system:

I downloaded and compiled everything needed for the 1.0.13 driver, basically following the Alsa Quick Install Guide (Sorry for not supplying links, but this forum doesn't let me do so on my first post...). There have been no problems. Before doing this I deactivated/removed my soundcard in Yast.

The first problem I encountered was when I did
>modprobe snd-seq-oss
FATAL: Error inserting snd_seq_oss (/lib/modules/ Device or resource busy
Everything else went fine. I ran alsaconf, it found my soundcard and told me it was able to activate the sound driver for it (and I heard glitch out of my speakers like you get when the soundsystem starts).

When I try to execute alsamixer though, I get the following error message:
>alsamixer: function snd_ctl_open failed for default: No such device
Since this looks like a common problem I went though the whole troubleshooting document on the alsa site

/proc/ssound/version says:
>Advanced Linux Sound Architecture Driver Version 1.0.13.
>Compiled on Feb 1 2007 for kernel (SMP).
which looks right.
/proc/asound/cards says
--- no soundcards ---
, which is not good I suppose. But I find that very strange, since alsaconfig finds my card.

I tried Yast then, which lists my card as "not configured". when I try to do so, it tells me:
An error occurred during the installation of SB0410 SBLive! 24 bit. The kernel module snd-ca0106 could not be loaded. This could be caused by incorrect module parameters, including invalid IO or IRQ paramaters.
Here is my lsmod output:

>lsmod | grep snd

>snd_ca0106 56324 0
>snd_rawmidi 46592 1 snd_ca0106
>snd_seq_device 26388 1 snd_rawmidi
>snd_ac97_codec 133592 1 snd_ca0106
>snd_pcm 113672 2 snd_ca0106,snd_ac97_codec
>snd_timer 44168 1 snd_pcm
>snd_ac97_bus 19584 1 snd_ac97_codec
>snd 90664 6 >snd_ca0106,snd_rawmidi,snd_seq_device,snd_ac97_codec,snd_pcm,snd_timer
>snd_page_alloc 28176 2 snd_ca0106,snd_pcm
>soundcore 28192 2 snd,sound
The last paragraph of the troubleshooting guide describes my problem, but does not apply to my kernel version... any Ideas?

physix 02-02-2007 10:58 AM

let me just add the two links that were missing in the initial post:

Alsa Quick Install Guide

Alsa Troubleshooting Document

All times are GMT -5. The time now is 05:33 PM.