-   Linux - Hardware (
-   -   sb hard drive wont mount (input/output error) (

edzillion 04-01-2009 05:30 PM

sb hard drive wont mount (input/output error)
usb hard drive wont mount
As usual I went ahead like a blunderbus and did lots of things I had no idea what I was doing.
Anyway I had a problem accessing the internal drive on my laptop and was getting this error;

Unable to mount device
Error org.freedesktop.Hal.Device.Volume.UnknownFailure

So tried to mount it various ways and then used the bash command:

mount -t ntfs-3g /dev/sda1 /media/sda1 -o force

which worked fine.

Step 2:

Tried to get the USB hard drive to be recognised so I could copy the data off the drive, so again:

mount -t ntfs-3g /dev/sdb /media/sdb -o force

which worked. Copied all the information off the internal drive and then put the usb drive into my windows machine (didnt dismount!). When added it recognises a usb mass storage device but doesnt appear in 'my computer' - no drive letter. Also I tried remounting it but I get the error 'NTFS is either inconsistent, or you have hardware faults......'

any ideas?

monsm 04-02-2009 10:34 AM

Could be just a damaged file system. Did you try to run "fix disk" from inside Windows?


edzillion 04-02-2009 10:48 AM

yeah it sounds as if the partition table is screwed (or something similar) so I went into disk management in administrative tools, and tried to 'initialise' (yet more ignorant blundering) and selected MBR.

I got an error message, I suppose that it wouldn't help posting windows error msgs on here, but I will if you think it'll help.

Is this what you mean by "fix disk" coz since windows isnt assigning a drive letter I can't do a whole lot.

cheers for the help btw. totally at sea with this one.

monsm 04-02-2009 02:07 PM

I haven't been using these things in windows for a while. Isn't it a tool in the Control Panel/Admin tools?
Disk manager or something. You might be able to launch some repair function from there.


All times are GMT -5. The time now is 01:03 AM.