LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   SATA Hard disk - Cannot install Linux (https://www.linuxquestions.org/questions/linux-hardware-18/sata-hard-disk-cannot-install-linux-219181/)

Beavis 08-18-2004 07:03 AM

SATA Hard disk - Cannot install Linux
 
I recently installed an SATA (samsung spinpoint 80GB) hard disk, this is mostly likely causing the problem that I cannot even start the installation of Fedora Core 2 or SUSE 9.1 Pro. What happens after i boot from the installation cd is that it gives me the first few normal messages and when it's about to launch the installer the computer restarts itself. So is there anyway to get it to install apart from using an ATA hard disk in installation?

The hardware
Asus P4p800 (springdale chipset)
Intel Pentium 4 2.4ghz
512MB DDR Ram
Samsung 52/24/52 CDRW
Samsung spinpoint 80GB
Hercules Fortissimo soundcard
D-link 530TX+ NIC

SUSE 9.1 pro worked completely fine on this computer before i installed an SATA hard disk (now i can't install any distro of linux).
please help :scratch:

kilgoretrout 08-18-2004 10:35 AM

I assume your not using raid, just a single sata hard drive. The board appears to be intel based and problably uses intel's ICH5 sata controller. This is pretty much the setup I have and mandrake 10.1-beta installed on the sata drive OK. I also have mandrake 10 on another ide drive and installed the sata drive after installing mdk10. Mdk10 recognized the drive I can access the drive fine in mdk10 but there is something weird going on. Mdk10 identifies the drive as hde but mdk10.1-beta identifies the drive as sda. Mdk10 uses the 2.6.3 kernel and mdk10.1-beta uses a 2.6.8 kernel.
I can't imagine suse 9.1 not also working with your setup. Where does it hang up and what error messages do you get. You might want to give mdk10 a try. I'm fairly certain mdk10.1-beta will work for you but it is beta and pretty rough around the edges. Kanontix, a knopix based live cd, works with and properly identifies the sata drive so you might want to take a look at that as well. Kanontix can be installed to your hard drive if you like it and gives you debian when installed to the hard drive.
It's a fact of life that sata is still relatively new and sata support is still evolving in the 2.6 kernels from what I can see. I wouldn't even try using any 2.4 based distros on your sata drive; sata support for ICH5 was just added to 2.4.28-pre which was released last week and the 2.4.27 kernels don't work with ICH5 unless the kernel has been patched.

Beavis 08-18-2004 11:09 AM

ok thanks, i'll download mandrake 10.1 beta 1, i want to programme some parts of KDE during the summer - pretty annoying when i suddenly can't even install linux, lol

mrwabam 08-18-2004 12:46 PM

I have the same problem
 
Just installed suse 9.1 on my new machine last week. I ran into the same problem. It turns out, its not that suse won't boot it just takes literally 5 to 10 minutes for it to start.

Once I finally get in the OS i get an error message that my Raid is a software raid and that continueing will wipe all data from it....

Anyone have any ideas on how I can get Suse to not hate my computer? I have tried some other builds (mandrake included) and Suse is my fav....

Tom

gerry 08-19-2004 01:20 PM

I have SATA (Maxtor) on an ASUS A7N8X Deluxe. Similar problems,

Have you checked your bios? During bootstrap sequence there may be an opportunity to check your RAID config file.

I thought SUSE 9.1 wasn't booting, tried again, wandered off, came back it was installing. I have about a 2 minute wait every time I boot. (I've also got a non-existent drive identifier hdg that it seems to spend some time looking for. I'd be interested in sharing dmesg with other SATA users

r0b0 08-20-2004 03:35 AM

You will need an installation media, that uses 2.6 kernel. For example the new debian installer http://www.debian.org/devel/debian-installer/ can use 2.6 kernel when booted with "linux26" option.
I believe mdk or suse install CDs support a 2.6 kernel, too. Check their startup help.
R.


All times are GMT -5. The time now is 08:37 PM.