-   Linux - Hardware (
-   -   SanDisk Cruzer mini 256 mb (

greendusk 10-01-2003 03:53 AM

SanDisk Cruzer mini 256 mb
Ok I put it in to the usb port linux does not found it then it looks up. I start the computer up with it in it locks up when it is booting. It works fine with XP on the same pc. I am using Mandrake 9.1

michaelk 10-01-2003 06:48 AM

Post your hardware ie. motherboard, chipset etc.

greendusk 10-02-2003 04:02 AM

Sorry but i found the info that i need and go it up and runing. But I now for some reason root can only acess it. I am running mandrake 9.1 on a a22m

greendusk 10-02-2003 05:09 AM

here is what I get
[root@xxxxxx mnt]# chmod 777 sandiskmini/
[root@xxxxxx mnt]# ls -l
:confused: drwxr--r-- 3 root root 2048 Dec 31 1969 sandiskmini/

here is my /etc/fstab for it
:confused: /dev/sda1 /mnt/zicestick vfat noauto,user,fat=12 0 0
it still only comes up readonly for user

michaelk 10-02-2003 06:41 AM


here is my /etc/fstab for it
/dev/sda1 /mnt/zicestick vfat noauto,user,fat=12 0 0
Change to:
dev/sda1 /mnt/zicestick vfat noauto,user,fat=12,umask=000 0 0

Check out man pages for mount and fstab for additional info.

Usually don't need the fat=12 option.

Marq 12-15-2003 05:16 PM

I'd like to know what you did to stop it from locking up, i'm having the exact same problem

doofsmack 12-27-2003 01:48 AM

I'm having the lockups too. Won't boot with it in, and if I plug it in after it's booted, it locks up hard on both systems I've tried.

xeaxes 12-29-2003 02:35 PM

I am having the same issues as doofsmack and Marq. Any help would be much appreciated as I can't find a working solution on google.

I'm using mdk9.1 and have the same mini cruzer 256 MB pen drive. Thanks!

greendusk 12-29-2003 05:55 PM

When i turn my laptop on i make sure the drive is not pluged it. It seems to only happan when the drive is pluged in on start up. Thats the one thing i could find that works.

sorry about slow reply hoildays been keeping me busy.

Marq 12-29-2003 05:57 PM

So yours doesn't lock up when you try to map the drive?

greendusk 12-29-2003 11:08 PM

Nope, When i tried it in slackware it loads up a bit slow but mandrake it comes right up.

xeaxes 12-30-2003 09:01 AM

Well, my system will try to mount the cruzer, and it will try for a couple of minutes. Then the computer will flash the caps lock and scroll lock and I have to hard reset.

I've tried adding various lines to my fstab, but they haven't worked at all. I was thinking supermount is screwing it up.

I'm using MDK9.1 on an Athlon Thunderbird 1.4 Ghz, 512 MB RAM, MSI K7T266 Pro motherboard.

jeffrobins 12-31-2003 05:21 PM

I have a gateway solo 9500 and it crashes with Mandrake 9.2. The computer will not boot all the way with the drive connected. When I connect it after boot and manually try to mount it, the computer hangs and stops accepting input from the built in keyboard. The conputer becomes responsive when the cruzer mini is removed.

--update: Okay, if I plug in the drive and run "fdisk /dev/sda" the computer will eventually hang and crash hard. If I try to stop the process, the computer is non-responsive. However, if I pull the drive,. the computer becomes responsive again and I can quit the process. Now, if I plug the drive back in and run "fdisk /dev/sda" the menu comes up almost immediately and the program works. I still cannot mount the drive withut the computer crashing.

xeaxes 01-01-2004 06:39 PM

I found my solution: I returned the sandisk cruzer to best buy and exchanged it for the PNY one. It was $10 more, but came with an extension cable (nice b/c my USB is in the back). It works perfectly, everytime.

It did seem somewhat slower then the sandisk one on my win 2k box. But, I'm happy. I suggest everybody else do the same.

jeffrobins 01-01-2004 08:32 PM

I got a FujiFilm drive. Works much better under linux.

All times are GMT -5. The time now is 07:37 PM.