LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   samba printer stops working until printer reinstall (https://www.linuxquestions.org/questions/linux-hardware-18/samba-printer-stops-working-until-printer-reinstall-617371/)

mphill 01-30-2008 04:46 AM

samba printer stops working until printer reinstall
 
Well, here is problem.
I installed HP 4250 on windows computer and it worked fine. After that I installed it like smb printer on two Fedora 6 computers and it worked fine for some time (few days). After few days it stops working at all (but works on other linux computer in the same network). I restarted cups (/etc/init.d/cups restart) and it printed one job from queue and stops working. Every time I restart cups it prints one job and stops working. I removed it (administration->printing) and installed it again. After that Printer worked OK for some time but the problem is occurring again and again.

I am totally lost, what can I try ?

Thanks in advance.

maroonbaboon 01-30-2008 07:20 AM

If it always works printing linux -> linux it sounds like a samba problem. Does restarting samba have any effect? Log files in /var/log/cups or /var/log samba might give some clues.

mphill 01-31-2008 03:55 AM

Unfortunately it is not me who is deciding printer server, it has to be windows. I also prefer Linux.
Nothing useful in log files, everything seems OK.
What puzzle me is that the other Linux computer is working fine.


All times are GMT -5. The time now is 03:03 PM.