Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Hardware
User Name
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?


  Search this Thread
Old 05-21-2005, 11:08 AM   #1
Registered: Oct 2004
Location: Belgium / Antwerp
Distribution: Debian
Posts: 287

Rep: Reputation: 33
running 1280MB RAM 333mhz @ 400mhz problem with knoppix

Originally I had 768MB RAM

512@333Mhz and 256@333Mhz. I have bought a 512@333 to get up to 1280MB RAM.

I want to run knoppix 3.8 (Cebit edition) from ram. So I wanted to overclock the ram (to 400Mhz) to get the most speed possible. The problem is that when I put the 3 RAM modules on the motherboard at the same time and let them run @400Mhz, I only can specify the cheat codes for knoppix but it doesn't boot further. But when I try 512+512@400Mhz or 256+512@400Mhz it just works fine.

So the RAM-modules are all working fine @400Mhz but not when I combine the 3 of them. At boot time I don't get any error message and I tried the memtest a few times (no problem)

The question is, is this knoppix not working fine or my computer (no errors in rom bios :s )


Old 05-22-2005, 04:15 AM   #2
Senior Member
Registered: Mar 2005
Location: Las Vegas, NV
Distribution: Mandriva Slackware FreeBSD
Posts: 1,468

Rep: Reputation: 48
I tried running 3.7 from ram and it was painfully slow. You would think it would run much faster but running the .iso image from the HD (poormans install) is much quicker. Using the RAM for the image and programs is just un-needed and just slows everything down.

If you don't want to install Linux/Knoppix on your HD I would suggest at least using the "tohd" option not the "toram" option.

Old 05-22-2005, 02:23 PM   #3
LQ Guru
Registered: Sep 2001
Location: Montreal, Canada
Distribution: Slackware; Debian; Gentoo...
Posts: 2,163

Rep: Reputation: 46
You need a special option in kernel (high memory support) to be able to use > 1GB of RAM. Just a guess, but is knoppix have this enabled?
Old 05-23-2005, 06:07 AM   #4
Registered: Oct 2004
Location: Belgium / Antwerp
Distribution: Debian
Posts: 287

Original Poster
Rep: Reputation: 33
high memory

I don't think you need to do that because it recognises 1280MB at 333mhz so it can detect more than 1GB. I also tried to overclock my pc further and I went up to 446MHZ for the rambus, normally it should run at 333Mhz so my RAM is really fine I think .

Well, the toram option really fastened my computer. So I don't see why I should use the tohd option Now my pc is also completely silent (except my nearly silent power supply) I don't use a HD anymore

So anybody can tell me what is wrong?



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with fedora after running knoppix ToofDogger Linux - Newbie 4 08-27-2005 10:59 PM
Problem running live cd of Knoppix 3.7 scurver Linux - Newbie 4 07-11-2005 09:13 AM
Knoppix on Compaq 1690 RAM? rawlow Linux - Newbie 4 06-02-2005 01:17 AM
PII 400MHz, 64MB RAM yevot Linux - Newbie 5 12-15-2004 07:22 PM
any linux distro can running in RAM , not need CD_ROM reading when running. wangcity Linux - General 3 09-18-2003 06:45 AM > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 09:37 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration