LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 11-17-2007, 09:56 PM   #1
keithk2
LQ Newbie
 
Registered: Sep 2005
Posts: 27

Rep: Reputation: 15
rt73 driver nor found by modprobe after compile


Hi All!

I've been beating my head against the wireless networking wall for over a week trying to get my Linksys wusb54gc wireless NIC running.

I'm using Mandriva 2007 under the 2.6.17 kernel. I tried using Ndiswrapper to no avail. Despite following the ndiswrapper instructions to the letter, no joy.

I went to the Serial Monkey site to try using their version of the Ralink RT73 module. It compiled without incident and the the modules all appeared in the subfolder where I was working as planned. The Readme instructions said to install the module with the command 'modprobe rt73'. I did just that and received the reply, "module rt73 not found" despite my being in the same directory as the module and running under root. No matter what I try, the dang module just won't get picked up by modprobe and installed. It doesn't appear in the listing from lsmod, iwconfig says the device wlan0 doesn't exist and I'm still off-line. Anyone out there have any suggestions? Any help would be greatly appreciated

Keithk2
 
Old 11-17-2007, 10:11 PM   #2
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 19,778

Rep: Reputation: 3572Reputation: 3572Reputation: 3572Reputation: 3572Reputation: 3572Reputation: 3572Reputation: 3572Reputation: 3572Reputation: 3572Reputation: 3572Reputation: 3572
Doesn't sound right - the module should normally be moved to /lib/modules/..
Was there a "make install" or somesuch you missed ???.
Try insmod instead of modprobe,and see if that works.

Post a link to the readme.
 
Old 11-18-2007, 06:49 PM   #3
keithk2
LQ Newbie
 
Registered: Sep 2005
Posts: 27

Original Poster
Rep: Reputation: 15
The module was installed in the folder /lib/modules/2.6.17-5mdvcustom/extra/ which, apparently, isn't where the kernel looks for it. Not sure where it's supposed to go to get itself found.
No luck using insmod. tried it twice as root to no avail. I used the command 'insmod rt73' while in the directory containing all of the modules (rt73-cvs-2007111718/Modules file)without receiving an error message but my usb stick is still dead after a reboot and there is no listing of rt73 (or any other member of the rt2x00 family for that matter) listed under lsmod. perhaps I need to add something to that command to be more specific. I'm still relatively new to the command line but I'm learning.

copy of the Readme follows:

Installation instructions for the Legacy rt73 module
[http://rt2x00.serialmonkey.com]


==================
Build Instructions
==================

1. Unpack the driver sources and go to the Module directory:
$ tar -xvzf rt73-cvs-daily.tar.gz
$ cd ./rt73-cvs-YYYYMMDDHH/Module

2. Compile the driver sources:
$ make

3. Install the driver (as root):
# make install


====================
INVOCATION
====================
Load the driver:

$ modprobe rt73 [ifname=<name>] [debug=<mask>] [firmName=<file>]

<name> is the name of the device and defaults to "wlan%d". If more
than one adapter is installed, successive devices will be named
wlan0, wlan1, etc. If you wish to use a different scheme - say
eth*, and there are already wired ethernet devices named eth0 and
eth1, then specifying <name> as "eth%d" gives the adapter the name
"eth2".

<mask> is a decimal or hex number. See TESTING file. Ignored if
driver compiled without debug support.

<file> is the name of a firmware file and defaults to "rt73.bin"
if omitted. Only the basename - not the full path - may be
specified.

Start it up:

$ ifup wlan0 # If using Debian - or
$ ifconfig wlan0 up
$ iwlist wlan0 scan

If everything is ok, you should see a list of surrounding Access
Points. It means you can jump to the configuration section. Otherwise,
check out the following install notes...

_________
NOTES:

* Firmware file (rt73.bin)

The rt73 chipset uses a firmware file which is loaded in device
memory using the kernel firmware_class facility. 'make install'
copy the firmware file to the standard firmwares location:
/lib/firmware.

However some linux distributions divert from the standard and e.g.
use /lib/firmware/<KERNEL_VERSION>. If this is your case, you will
have to manually move the firmware file to the right location.
If you have problems with firmware loading, please ask on your
distro's support media (forum, etc).

* Driver alias

rt73 uses wlan* as its modprobe alias. This means you can have
several devices and they will be named wlan0, wlan1, etc.

If for some reason you want this interface number 'static' (e.g.
if you have several wlan devices and their numbers change on
reboot) you can change the rt73 alias in /etc/modprobe.conf back
to wlan0 (or wlan1, etc).

However the proper way to achieve this purpose is to use a udev
rule based on the wlan MAC address, for example:
KERNEL=="wlan*", SYSFS{address}=="00:de:ad:be:ef:00", NAME="wlan0"
(See:
http://www.reactivated.net/writing_u...#example-netif)

* Module parameters

You can load the rt73 module with two optional parameters:
firmName=<FILE_NAME> Use another firmware file.
debug=<DEBUG_MASK> Set debug verbosity (see below).


==============================
Wireless Station Configuration
==============================

The wlan interface should be configured using standard wireless
extension tools.

GUI CONFIG:

If you're looking for a GUI config tool we provide RutilT on our
download page
[http://rt2x00.serialmonkey.com/wiki/...php/Downloads].

MANUAL CONFIG:

1. Set the interface mode and bring it up
# iwconfig wlan0 mode managed
# ifconfig wlan0 up

2. Set your target network / Access Point
If you just want to join a wireless network, set its ESSID:
# iwconfig wlan0 essid <ESSID>
If you want to associate with a specific AP, set its MAC
address:
# iwconfig wlan0 ap <BSSID>

3. Set encryption if needed

a) WEP (802.11b)
Choose the authentication mode (open/restricted):
# iwconfig wlan0 key open
Or:
# iwconfig wlan0 key restricted
Set the encryption key:
# iwconfig wlan0 key <KEY>

b) WPA (802.11g)
Set the authentication mode:
# iwpriv wlan0 set AuthMode=WPAPSK
Set the encryption key:
# iwpriv wlan0 set WPAPSK=<KEY>
Set the encryption type:
# iwpriv wlan0 set EncrypType=TKIP

c) WPA2 (802.11i)
Set the authentication mode:
# iwpriv wlan0 set AuthMode=WPA2PSK
Set the encryption key:
# iwpriv wlan0 set WPAPSK=<KEY>
Set the encryption type:
# iwpriv wlan0 set EncrypType=AES

4. Check that you're associated with an AP
# iwconfig wlan0

If everything's ok, you can now configure the wlan0 interface
statically or dynamically (DHCP). If you need more wireless config
details and examples (Adhoc mode e.g.), see iwpriv_usage.txt (included
in driver sources). Otherwise, read the following config notes...

_________
NOTES:

* Auto-load on boot

If you want your device to come up on boot the best is to use your
specific linux distribution's tools (boot scripts, etc).
If you need support doing so, ask on your distro's support media.

* wpa_supplicant

wpa_supplicant is a userland WPA/WPA2/802.1X layer. This driver is
not compatible with it. As most wpa_supplicant features are
embedded into our driver, you should not need it though.
If you need to use a feature that only wpa_supplicant provides:
- either use our next-generation rt2x00 driver which
is compatible with wpa_supplicant
- or patch wpa_supplicant to make it work with rt73 (more info:
http://mjh.name/Ralink_rt73_wpa_supplicant_rt2x00_wpa2)


==================
Misc. information
==================

* hostapd

hostapd allows your wlan device to act like an Access Point. Legacy
drivers are _not_ compatible with it, but our next-generation
rt2x00 drivers are.

* Network auditing

Our drivers allow you to peform in-depth wireless network auditing.
Most of the following settings require that you bring the
interface down beforehand.

You can set a custom MAC address as you would do for any other
ethernet interface:
# ifconfig wlan0 hw ether <MAC_ADDRESS>

You can put your wlan interface in promiscuous mode as you would
do for any other interface:
# ifconfig wlan0 promisc

You can put your interface in monitor mode and have it listen to all
802.11 frames around:
# iwconfig wlan0 mode monitor

You can also inject 802.11 frames on the fly. To enable injection,
run:
# iwpriv wlan0 rfmontx 1

* Testing / debugging

If you experience any driver related problem you can ask for
support on our mailing list or our legacy driver forum.
Before asking for help, read the TESTING file and follow its
advice. Do *not* post messages like: "wlan does not work. please
help!".

********************end copy of readme***************************88

Thanks for all your time
Keith
 
Old 11-18-2007, 07:09 PM   #4
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 19,778

Rep: Reputation: 3572Reputation: 3572Reputation: 3572Reputation: 3572Reputation: 3572Reputation: 3572Reputation: 3572Reputation: 3572Reputation: 3572Reputation: 3572Reputation: 3572
For the insmod you'll probably need "insmod ./rt73.ko"
For modprobe, make sure that directory agrees with the running kernel - "uname -r"
 
Old 11-20-2007, 02:16 PM   #5
keithk2
LQ Newbie
 
Registered: Sep 2005
Posts: 27

Original Poster
Rep: Reputation: 15
Found the driver module rt73.ko in the /lib/modules/2.6.17-5mdvcustom/extra/ folder. However, the response to the query uname -r comes back as 2.6.17-5mdv. There is a folder named /lib/modules/2.6.17-5mdv/ but it does not contain a copy of the rt73.ko module nor a subfolder named 'extra'.

I suspect that this may be the problem but have no idea where to place a copy of the module in order for it to be recognized. Any suggestions? or am I on the wrong track?

Thanks again for all your help.
Keith
 
Old 11-20-2007, 11:28 PM   #6
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 19,778

Rep: Reputation: 3572Reputation: 3572Reputation: 3572Reputation: 3572Reputation: 3572Reputation: 3572Reputation: 3572Reputation: 3572Reputation: 3572Reputation: 3572Reputation: 3572
Just make the dir, and copy the module.
Add it to whatever means Mandriva uses to load modules at boot
 
Old 11-23-2007, 08:27 PM   #7
keithk2
LQ Newbie
 
Registered: Sep 2005
Posts: 27

Original Poster
Rep: Reputation: 15
Finally! A connection!

I actually gave up on trying to put a module into the kernel of Mandriva 2007. I went back to Mandriva One and tried using the rt73 module native to the kernel. No joy. After trying to use wicd with no success (couldn't find a way to uninstall knetwork-manager nor could I get the files I installed to execute no matter what I tried) I gave up, re-instaled Mandriva One as a completely new install, configured the network using ndiswrapper and for some reason, it worked this time. Didn't before but, by thunder it's connecting now.

Thanks for all the help here. You've been great

All Success
Keith
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[Request] RT73.ini RT73.sys Muchalipski Linux - Wireless Networking 1 08-29-2007 12:05 PM
problems with rt73 driver installation on ubuntu 7.04 arielsegal Linux - Wireless Networking 0 08-06-2007 05:25 AM
RT73 WLAN rt2x00.serialmonkey driver stumpedguy_frustrate Fedora 0 04-03-2007 05:45 PM
Compiling and installing RT73 driver on Slackware 10.2 txr13 Linux - Wireless Networking 7 12-31-2006 05:38 AM
Problem compiling RT73 driver maxmike83 Fedora 1 11-29-2006 09:20 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 10:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration