LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 08-28-2006, 07:28 PM   #16
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 4,170

Rep: Reputation: 244Reputation: 244Reputation: 244

Quote:
Originally Posted by LonelyTraveler
Code:
conradtheart@Conrad:~$ apt-cache search nvidia
nvidia-cg-toolkit - NVIDIA Cg Toolkit installer
nvtv - tool to control TV chips on NVidia cards under Linux
nvidia-settings - Tool of configuring the NVIDIA graphics driver
nvidia-kernel-common - NVIDIA binary kernel module common files
Thanks. The above is the return I get.
Should be more than that do you have non-free in your souces.list line similar to this.

Code:
## Testing sources
deb http://ftp2.de.debian.org/debian/ testing main contrib non-free
deb-src http://ftp2.de.debian.org/debian/ testing main contrib non-free
Once you put it in update again and search one more time.
 
Old 08-28-2006, 07:37 PM   #17
CrownAmbassador
Member
 
Registered: Mar 2005
Location: Cape Town, South Africa
Distribution: Ubuntu 8.10
Posts: 374

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by HappyTux
Code:
## Testing sources
deb http://ftp2.de.debian.org/debian/ testing main contrib non-free
deb-src http://ftp2.de.debian.org/debian/ testing main contrib non-free
Just want to make sure. Must I add this to the sources.list file that currently displays my repositories?
 
Old 08-28-2006, 07:53 PM   #18
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 4,170

Rep: Reputation: 244Reputation: 244Reputation: 244
Quote:
Originally Posted by LonelyTraveler
Just want to make sure. Must I add this to the sources.list file that currently displays my repositories?
No that is just showing you what the line can look like with non-free in it you need non-free for the nvidia driver.
 
Old 08-29-2006, 06:50 PM   #19
CrownAmbassador
Member
 
Registered: Mar 2005
Location: Cape Town, South Africa
Distribution: Ubuntu 8.10
Posts: 374

Original Poster
Rep: Reputation: 30
How do I add it though?
 
Old 08-29-2006, 06:52 PM   #20
CrownAmbassador
Member
 
Registered: Mar 2005
Location: Cape Town, South Africa
Distribution: Ubuntu 8.10
Posts: 374

Original Poster
Rep: Reputation: 30
By the way... Even though I'm registered here since March 2005, I have not been using Linux since then. I tried it out for like a week then and only started it again about a week ago.
 
Old 08-29-2006, 07:16 PM   #21
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 4,170

Rep: Reputation: 244Reputation: 244Reputation: 244
Do you know how to use an editor at all in Linux? The easiest is probably doing something like this as root nano /etc/apt/sources.list this will open the file for editing go down to the line that is similar to the one I post above and add the non-free to it then write the file with the CTRL + o keys hit enter when it shows you the file name to quit CTRL + x. Post the sources.list here if you need to and I will show you which line to edit. After editing you need to apt-get update to read the new addition and get it packages list file.
 
Old 08-30-2006, 05:27 PM   #22
CrownAmbassador
Member
 
Registered: Mar 2005
Location: Cape Town, South Africa
Distribution: Ubuntu 8.10
Posts: 374

Original Poster
Rep: Reputation: 30
No I don't. The following is what I get when running nano /etc/apt/sources.list


d
Code:
eb cdrom:[Debian GNU/Linux 3.1 r2 _Sarge_ - Official i386 Binary-14 (20060419)$deb cdrom:[Debian GNU/Linux 3.1 r2 _Sarge_ - Official i386 Binary-13 (20060419)$deb cdrom:[Debian GNU/Linux 3.1 r2 _Sarge_ - Official i386 Binary-12 (20060419)$deb cdrom:[Debian GNU/Linux 3.1 r2 _Sarge_ - Official i386 Binary-11 (20060419)$deb cdrom:[Debian GNU/Linux 3.1 r2 _Sarge_ - Official i386 Binary-10 (20060419)$deb cdrom:[Debian GNU/Linux 3.1 r2 _Sarge_ - Official i386 Binary-9 (20060419)]$deb cdrom:[Debian GNU/Linux 3.1 r2 _Sarge_ - Official i386 Binary-8 (20060419)]$deb cdrom:[Debian GNU/Linux 3.1 r2 _Sarge_ - Official i386 Binary-7 (20060419)]$deb cdrom:[Debian GNU/Linux 3.1 r2 _Sarge_ - Official i386 Binary-6 (20060419)]$deb cdrom:[Debian GNU/Linux 3.1 r2 _Sarge_ - Official i386 Binary-5 (20060419)]$deb cdrom:[Debian GNU/Linux 3.1 r2 _Sarge_ - Official i386 Binary-4 (20060419)]$deb cdrom:[Debian GNU/Linux 3.1 r2 _Sarge_ - Official i386 Binary-3 (20060419)]$deb cdrom:[Debian GNU/Linux 3.1 r2 _Sarge_ - Official i386 Binary-2 (20060419)]$deb cdrom:[Debian GNU/Linux 3.1 r2 _Sarge_ - Official i386 Binary-1 (20060419)]
What is non-free?
 
Old 08-30-2006, 05:45 PM   #23
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 4,170

Rep: Reputation: 244Reputation: 244Reputation: 244
Quote:
Originally Posted by LonelyTraveler
No I don't. The following is what I get when running nano /etc/apt/sources.list


What is non-free?
Non-free is a section in the Debian archives that contain software for which their is no source code available under one of the licenses that Debian considers to be "free" according to the Debian Free Software Guidelines (DFSG for short). As long as the software is allowed to be re-distributed but is not licensed under the DFSG ones it goes into non-free. It looks like you have no other sources but the cdrom ones in your sources.list soyou wouldneed to add an entire new line try my line above but put stable in the place of testing then apt-get update and do the search again to see which packages are available to you there can be already pre-built packages you would be able to install these woud probably be best to start with as they are the easiest to install and get going quickly. When editing the sources.list file the quickest way would be to open a terminal/console window under X use su to become root open the file then copy and paste the line into the file changing the testing to stable in it. And boy do I hate when these weird line wraps happen in some thread and you have to scroll back and forth to see what your doing.
 
Old 08-30-2006, 06:05 PM   #24
CrownAmbassador
Member
 
Registered: Mar 2005
Location: Cape Town, South Africa
Distribution: Ubuntu 8.10
Posts: 374

Original Poster
Rep: Reputation: 30
Great. Looks like I'm finally doing something right. This is the output I get when i apt-cache search nvidia now:
Code:
Conrad:/home/conradtheart# apt-cache search nvidia
nvtv - tool to control TV chips on NVidia cards under Linux
nvidia-cg-toolkit - NVIDIA Cg Toolkit installer
nvidia-kernel-common - NVIDIA binary kernel module common files
nvidia-settings - Tool of configuring the NVIDIA graphics driver
nvidia-glx - NVIDIA binary XFree86 4.x driver
nvidia-glx-dev - NVIDIA binary XFree86 4.x driver development files
nvidia-kernel-2.4.27-2-386 - NVIDIA binary kernel module for Linux 2.4.27-2-386
nvidia-kernel-2.4.27-2-586tsc - NVIDIA binary kernel module for Linux 2.4.27-2-5 86tsc
nvidia-kernel-2.4.27-2-686 - NVIDIA binary kernel module for Linux 2.4.27-2-686
nvidia-kernel-2.4.27-2-686-smp - NVIDIA binary kernel module for Linux 2.4.27-2- 686-smp
nvidia-kernel-2.4.27-2-k6 - NVIDIA binary kernel module for Linux 2.4.27-2-k6
nvidia-kernel-2.4.27-2-k7 - NVIDIA binary kernel module for Linux 2.4.27-2-k7
nvidia-kernel-2.4.27-2-k7-smp - NVIDIA binary kernel module for Linux 2.4.27-2-k 7-smp
nvidia-kernel-source - NVIDIA binary kernel module source
I'm also getting nvidia packages in my package manager now. What do I do next?
 
Old 08-30-2006, 06:41 PM   #25
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 4,170

Rep: Reputation: 244Reputation: 244Reputation: 244
Good that is what you want I believe you had the the 2.4.27-2-686 kernel right if so you need to install nvidia-kernel-2.4.27-2-686 which should also bring in nvidia-kernel-common, nvidia-glx and nvidia-glx-dev if not then install these after the kernel installs and if not running that kernel -686 use the package that matches the uname -r output. Now you will need to change the /etc/X11/XF86Config-4 file as well us the same method as when editing the sources.list to be root then look for these.

Code:
Section "Module"
        Load    "bitmap"
        Load    "dbe"
        Load    "ddc"
#       Load    "dri"
        Load    "extmod"
        Load    "freetype"
        Load    "glx"
        Load    "int10"
        Load    "record"
        Load    "type1"
        Load    "vbe"
        Load    "xtrap"
EndSection
See the # in front of the Load "dri" put that there and if there is a GLcore put it in front of that as well and add the Load "glx" if not there now down in the Section Device.

Code:
Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "SWcursor"                  # [<bool>]
        #Option     "HWcursor"                  # [<bool>]
        #Option     "NoAccel"                   # [<bool>]
        #Option     "ShowCache"                 # [<bool>]
        #Option     "ShadowFB"                  # [<bool>]
        #Option     "UseFBDev"                  # [<bool>]
        #Option     "Rotate"                    # [<str>]
        #Option     "VideoKey"                  # <i>
        #Option     "FlatPanel"                 # [<bool>]
        #Option     "FPDither"                  # [<bool>]
        #Option     "CrtcNumber"                # <i>
        Identifier  "Card0"
        Driver      "nvidia"
        Option      "NoLogo" "on"
        Option      "NvAgp"  "3"
        Option      "RenderAccel" "true"
        Option      "BackingStore" "On"
        Option      "DPI" "100x100"
#       Option      "IgnoreEDID"  "on"
        Option      "IgnoreDisplayDevices"  "TV"
#       Option      "NoBandWidthTest" "1"
#       Option      "AllowGLXWithComposite" "true"
        Screen       0
        VendorName  "PNY"
        BoardName   "Verto 5900SE NV35 [GeForce FX 5900SE]"
        BusID       "PCI:1:0:0"
EndSection
Now it will not be like mine but you want the Driver "nvidia" to be there instead of nv or vesa. Once the changes are made logout and use the CTRL + ALT + Backspace keys at the same time to kill off and respawn the X server with the new settings you should see the Nvidia logo telling you that you are using the driver, you can get rid of that if you use the NoLogo "on" like I have above for the future if you want.
 
Old 08-30-2006, 07:36 PM   #26
CrownAmbassador
Member
 
Registered: Mar 2005
Location: Cape Town, South Africa
Distribution: Ubuntu 8.10
Posts: 374

Original Poster
Rep: Reputation: 30
Great! Thank you so much. I see the logo and everything. Just want to check. The glx is already there. Do I need to put a # infront of that too?
 
Old 08-30-2006, 07:53 PM   #27
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 4,170

Rep: Reputation: 244Reputation: 244Reputation: 244
No # in front that is what you had to add if not there, good to see you got it working.
 
Old 08-30-2006, 09:44 PM   #28
ciotog
Member
 
Registered: Mar 2004
Location: Canada
Distribution: Slackware current
Posts: 728
Blog Entries: 2

Rep: Reputation: 43
To do a final test to see if everything is running good, run the following commands in a terminal:
Code:
glxinfo
A bunch of stuff should fly by, telling you all the GLX extensions available to whatever software wants to make use of it.
Code:
glxinfo | grep "direct rendering"
This should return a line that says simply "direct rendering: yes".
Code:
glxgears
A window should open up with some rotating gears. Don't resize the window! Every 5 seconds in the terminal window a line will appear telling you the number of frames per second. If after letting glxgears run for 20 seconds or so, you should stabalize at a number better than 1000. If it's lower, then something's probably not quite right. You can stop glxgears by pressing ctrl-c in the terminal.
 
Old 08-31-2006, 04:00 AM   #29
CrownAmbassador
Member
 
Registered: Mar 2005
Location: Cape Town, South Africa
Distribution: Ubuntu 8.10
Posts: 374

Original Poster
Rep: Reputation: 30
Thanks. It is better than 1000.
 
Old 09-02-2006, 05:22 PM   #30
CrownAmbassador
Member
 
Registered: Mar 2005
Location: Cape Town, South Africa
Distribution: Ubuntu 8.10
Posts: 374

Original Poster
Rep: Reputation: 30
Now that I upgrade my kernel my x didn't want to start. I fixed it temporarily by going back to the nv driver. On the debain website I see a nvidia-kernel-2.6.16-2-686 but when I apt-cache search nvidia-kernel-2.6.16-2-686 it does not find anything. And this is after I apt-get update. What to do?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
distro suggestion that supports nvidia geforce fx5200 snip128 Linux - Newbie 19 10-18-2006 01:58 PM
which x server to use with nvidia geforce fx5200 on debian new install? aerostarlegacy Linux - Hardware 4 07-25-2006 01:29 PM
Using S-Video output on nVidia GeForce FX5200 in FC5 Icy Linux - Hardware 2 06-04-2006 04:20 PM
mandrake 10.2LE nvidia geforce fx5200 krnl2.6.111-12mdk r0ssar00 Linux - Software 3 08-30-2005 02:54 PM
Nvidia GeForce FX5200 Xserver not starting pinkyponky Linux - Hardware 3 03-17-2005 05:20 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 11:12 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration