LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Resolution Issue (https://www.linuxquestions.org/questions/linux-hardware-18/resolution-issue-609469/)

dirtmaster88 12-27-2007 03:16 PM

Resolution Issue
 
My goal is to get 1440x900 resolution on my new suse install. I've been through alot with editing the xorg.conf file before with ubuntu installations but this one has me hanging. I've tried all the configurations within yast, sax, etc. I did some manual editing and I can now at least get to a 1152x864 resolution which is better than when I was stuck on a worse one. Anyhow, the resolution will not change from 1152x864 anymore. Here is my xorg.conf file:

# /.../
# SaX generated X11 config file
# Created on: 2007-12-27T14:58:07-0600.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
FontPath "/usr/share/fonts/misc:unscaled"
FontPath "/usr/share/fonts/local"
FontPath "/usr/share/fonts/75dpi:unscaled"
FontPath "/usr/share/fonts/100dpi:unscaled"
FontPath "/usr/share/fonts/Type1"
FontPath "/usr/share/fonts/URW"
FontPath "/usr/share/fonts/Speedo"
FontPath "/usr/share/fonts/PEX"
FontPath "/usr/share/fonts/cyrillic"
FontPath "/usr/share/fonts/latin2/misc:unscaled"
FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
FontPath "/usr/share/fonts/latin2/Type1"
FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
FontPath "/usr/share/fonts/baekmuk:unscaled"
FontPath "/usr/share/fonts/japanese:unscaled"
FontPath "/usr/share/fonts/kwintv"
FontPath "/usr/share/fonts/truetype"
FontPath "/usr/share/fonts/uni:unscaled"
FontPath "/usr/share/fonts/CID"
FontPath "/usr/share/fonts/ucs/misc:unscaled"
FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/misc:unscaled"
FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/Type1"
FontPath "/usr/share/fonts/misc/sgi:unscaled"
FontPath "/usr/share/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
InputDevices "/dev/gpmdata"
InputDevices "/dev/input/mice"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "on"
EndSection

Section "Module"
Load "freetype"
Load "type1"
Load "dbe"
Load "glx"
Load "extmod"
EndSection

Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "us"
Option "XkbModel" "microsoftpro"
Option "XkbRules" "xfree86"
EndSection


Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Buttons" "6"
Option "Device" "/dev/input/mice"
Option "Name" "ImPS/2 Logitech Wheel Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
Option "CalcAlgorithm" "XServerPool"
DisplaySize 366 229
HorizSync 30-70
Identifier "Monitor[0]"
ModelName "1440X900@70HZ"
VendorName "--> LCD"
VertRefresh 50-75
UseModes "Modes[0]"
EndSection


Section "Modes"
Identifier "Modes[0]"
EndSection


Section "Screen"
DefaultDepth 16
SubSection "Display"
Depth 15
Modes "1440x900" "1366x768" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1440x900" "1366x768" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1440x900" "1366x768" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1440x900" "1366x768" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection


Section "Device"
BoardName "GeForce2 MX/MX 400"
BusID "5:4:0"
Driver "nv"
Identifier "Device[0]"
Screen 0
VendorName "NVidia"
EndSection



Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection


Section "DRI"
Group "video"
Mode 0660
EndSection

Section "Extensions"
EndSection

Lenard 12-27-2007 04:10 PM

Suggestion visit the Nvidia site to get Linux drivers for your graphics interface:

http://www.nvidia.com/Download/index.aspx?lang=en-us

Be sure and read the instructions for SuSE before starting.

dirtmaster88 12-28-2007 07:41 AM

Quote:

Originally Posted by Lenard (Post 3003282)
Suggestion visit the Nvidia site to get Linux drivers for your graphics interface:

http://www.nvidia.com/Download/index.aspx?lang=en-us

Be sure and read the instructions for SuSE before starting.

I've used the envy utility before for my ubuntu drivers. It auto detected my graphics card and downloaded/installed the correct driver. Is this something I could also use for SuSe?

Lenard 12-28-2007 08:53 AM

The instructions are on nVidia's site, they even have directions for SuSe!! I have no idea about using the envy utility with SuSe.

http://www.suse.de/~sndirsch/nvidia-...ler-HOWTO.html


All times are GMT -5. The time now is 05:33 PM.