LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Repairing the MBR (https://www.linuxquestions.org/questions/linux-hardware-18/repairing-the-mbr-198085/)

artistikone 06-26-2004 05:38 PM

Repairing the MBR
 
I have a WD30100 10GB Hardrive that I've been trying to repair. The MBR of the drive seems to be hosed and everything I've tried to repair it has failed. Here are some details:

Upon boot, my BIOS states that the drive fails. This happens if it's either mounted as a master,slave or single. If I mount it as a slave, hit F1 to get past the BIOS message, I'm able to boot off my good drive in the OS. Once in the OS, I can format/read/write the the drive in question without error.

I've tried the following common MBR repairs so far:

XP Repair Console:

fixboot - Says it worked fine
fixmbr - Says it worked fine
diskpart - Drive partitions without error
chkdsk - Reports that there are unrepairable sectors

Slackware 10 Boot disk:

fdisk /mbr - Unable to read /mbr
fdisk /dev/hda - Works fine, partitioning works without error.
fdisk -d - When showing the rata data of the drive, all zero's are returned.

Windows 95/95b/98/98SE/ME Boot Disk
DOS 5.0/6.0 Boot Disk

Western Digital Data Diagnostics Tool:

Wrote Zeros to the drive, no errors. Upon reboot (which it requests), drive fails.

I'm able to get through the full install of Slackware 10 until the end when it's time to install LILO, which is where it fails.

I would be more then happy to just use the drive as a slave, however the problem is that the BIOS will not boot into the OS without hitting F1, which makes remote reboots impossible. There isn't a way to bypass this option in the BIOS. I've tried auto-detect and manual settings, both return the same results.


I found something about using debug.exe on the Win95 boot disk to manually repair it, however the walkthrough listed differs from what my drive reports so I skipped that. I've found DBAN and MBRWizard which I am going to try tonight, but they all seem to just write zero's. I'm wondering if I'm going about this the wrong way?

2damncommon 06-26-2004 05:47 PM

Quote:

Western Digital Data Diagnostics Tool:
Wrote Zeros to the drive, no errors. Upon reboot (which it requests), drive fails.
Did you run the full diagnostic checks on the drive?

artistikone 06-26-2004 05:58 PM

Yes, all 3 tools within the program (Quick, Full, Write Zeros) work without error and all come back saying everything is ok.

2damncommon 06-26-2004 06:13 PM

Setting your BIOS to ignore the problem drive as slave should allow you to boot and Linux should still be able to use the drive.
Passing the diagnostics would seem to say the drive is okay. Jumpers and drive cable are a couple more places to check.
The only times I have had drives fail boot is when the jumpers are wrong or the drive is failing.
If Slackware is partitioning and formatting during install, and the drive is good and configured correctly there should be no problem, in theory. :)


All times are GMT -5. The time now is 06:48 AM.