-   Linux - Hardware (
-   -   Removing second hard drive (

undershepherd 05-16-2003 09:23 AM

Removing second hard drive
I presently have two hard drivesm on one computer . The first, master, has MDK 9.1 on it. I was using the second one to play around, but everytime I try to put another linux distro on it, something goes wrong. Anyway, I would like to remove the second hard drive from the computer and use it in another computer.
I can mount this second one in MDK9.1, and everything is fine there. I have mdk 9.1 on it as well, and this is reflected in lilo. I know how to edit lilo to remove the entry for the second linux os on that drive. What steps do I need to take to remove this second drive from the computer, physically as well as with reference to MDK on the main drivet? Will it mess up the boot if it's gone? When booting, MDK recognizes it and mounts it "clean."


michaelk 05-16-2003 09:51 AM

Remove any reference to the second drive in /etc/fstab.

Remove any reference to the second drive in /etc/lilo.conf and rerun /sbin/lilo.

No other changes are required unless your motherboard BIOS is not setup for hard drive auto detect. For most mobo it is the default setting.

undershepherd 05-16-2003 10:53 AM

Thanks for the quick response. Should I remove the references before or after I physically remove the HD?

acid_kewpie 05-16-2003 11:23 AM

before would be safer, but it won't cause a problem either way.

undershepherd 05-16-2003 11:43 AM

Thanks again. One more question: should i run /sbin/lilo (which I am assuming you run in a terminal, and type just that), before or after physical removal?
The reason I ask: I removed a CDRW from a Windows ME machine, without removing it in control panel first, and tried to reboot the computer and it froze up. Ended up, I had to detach the bios battery for 10 seconds, put it back in, and reboot, and everything was fine.

acid_kewpie 05-16-2003 11:49 AM

doesn't matter, all the could happen would be that you remove the drive and there is still an entry in the lilo menu for an os on that drive. run that command and it will fail... no biggy...

All times are GMT -5. The time now is 01:37 AM.