-   Linux - Hardware (
-   -   relatively low sound volume with ALC662 HDA(Realtek) onboard Sound card (

deepclutch 05-16-2010 06:23 AM

relatively low sound volume with ALC662 HDA(Realtek) onboard Sound card
there is relatively less(Low Volume) sound output with ASUS P5GC-MX/1333 motherboard with ALC662 Realtek HDA Sound card.
I'm on Ubuntu 10.04 with Alsa 1.0.23 and Kernel 2.6.32-22 on a Intel 64-bit system.I use 2 speakers only.

root@linbox: lspci -vvnn
00:1b.0 Audio device [0403]: Intel Corporation N10/ICH 7 Family High Definition Audio Controller [8086:27d8] (rev 01)
        Subsystem: ASUSTeK Computer Inc. P5KPL-VM Motherboard [1043:8290]

        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 16 bytes
        Interrupt: pin A routed to IRQ 27
        Region 0: Memory at dddf8000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable+
                Address: 00000000fee0200c  Data: 4199
        Capabilities: [70] Express (v1) Root Complex Integrated Endpoint, MSI 00
                DevCap:        MaxPayload 128 bytes, PhantFunc 0, Latency L0s <64ns, L1 <1us
                        ExtTag- RBE- FLReset-
                DevCtl:        Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
                        RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop+
                        MaxPayload 128 bytes, MaxReadReq 128 bytes
                DevSta:        CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr+ TransPend-
                LnkCap:        Port #0, Speed unknown, Width x0, ASPM unknown, Latency L0 <64ns, L1 <1us
                        ClockPM- Suprise- LLActRep- BwNot-
                LnkCtl:        ASPM Disabled; Disabled- Retrain- CommClk-
                        ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
                LnkSta:        Speed unknown, Width x0, TrErr- Train- SlotClk- DLActive- BWMgmt- ABWMgmt-
        Capabilities: [100] Virtual Channel <?>
        Capabilities: [130] Root Complex Link <?>
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel

There are "quirks" provided by ALSA Team for particular Models.
I tried Most of them including 3stack-6ch,asus-mode1,2,3,4,5,6 on /etc/modprobe.d/alsa-base.conf in the format:

options-snd-hda-intel model=3stack-6ch
^and for almost all models(value) I tried ,I get this message in /var/log/boot.log:

WARNING: /etc/modprobe.d/alsa-base.conf line 45: ignoring bad line starting with 'options-snd-hda-intel'
WARNING: /etc/modprobe.d/alsa-base.conf line 45: ignoring bad line starting with 'options-snd-hda-intel'
WARNING: /etc/modprobe.d/alsa-base.conf line 45: ignoring bad line starting with 'options-snd-hda-intel'
WARNING: /etc/modprobe.d/alsa-base.conf line 45: ignoring bad line starting with 'options-snd-hda-intel'

Even used hda-analyzer(tool provided by ALSA) to increase Volume and it increased the sound quiet a bit.
Is there any solution to have the Volume to be increased to the level of normal output?


Here the HDA-Audio-Models.txt for ALC662 :

  3stack-dig    3-stack (2-channel) with SPDIF
  3stack-6ch    3-stack (6-channel)
  3stack-6ch-dig 3-stack (6-channel) with SPDIF
  6stack-dig    6-stack with SPDIF
  lenovo-101e    Lenovo laptop
  eeepc-p701    ASUS Eeepc P701
  eeepc-ep20    ASUS Eeepc EP20
  ecs        ECS/Foxconn mobo
  m51va        ASUS M51VA
  g71v        ASUS G71V
  h13        ASUS H13
  g50v        ASUS G50V
  asus-mode1    ASUS
  asus-mode2    ASUS
  asus-mode3    ASUS
  asus-mode4    ASUS
  asus-mode5    ASUS
  asus-mode6    ASUS
  dell        Dell with ALC272
  dell-zm1    Dell ZM1 with ALC272
  samsung-nc10    Samsung NC10 mini notebook
  auto        auto-config reading BIOS (default)

Changes 05-17-2010 05:23 PM

First open alsamixer in shell and see if you have something relevant set at less than maximum (typically "master" is at maximum, but PCM, or the speakers, might be at a lower setting). Crank them up.

If that doesn't help, or if everything is already where it should be, save a text file as /etc/asound.conf with the following lines:


pcm.!default {
      type plug
      slave.pcm "softvol"

  pcm.softvol {
      type softvol
      slave {
          pcm "dmix"
      control {
          name "Pre-Amp"
          card 0
      min_dB -5.0
      max_dB 20.0
      resolution 10

It may require more than one reboot, for some reason, but it'll result in alsamixer having an additional "pre-amp" slider. Slide it up and you can boost the output. Be aware that if you overdo it you'll get distortion.

At least, this is the way I do it in Debian with my EeePC, which natively has a very low volume; I followed a Ubuntu guide, though, so it should work with that too.

deepclutch 05-20-2010 12:44 AM

I think without Pulseaudio ,Sound Output is good.@changes:I will try your /etc/asound.conf and reply back.currently /etc/asound.conf is set for pulse output:

pcm.pulse {
    type pulse
ctl.pulse {
    type pulse
pcm.!default {
    type pulse
ctl.!default {
    type pulse

Thank You

mel_newbie 09-29-2010 02:54 PM

I know this post is a little old but I wanted to share my solution to the sound problem. I had the same problem with my d510mo motherboard. It uses ALC662. Rather than retyping all of the steps take a look at my blog home page. It contains the steps I used to resolve the problem.

All times are GMT -5. The time now is 12:35 PM.