LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   reinstall hardware ? (https://www.linuxquestions.org/questions/linux-hardware-18/reinstall-hardware-508727/)

dannyk1 12-08-2006 10:29 PM

reinstall hardware ?
 
Hi. Is there a way to manually uninstall a piece of hardware on Fedora core 6?

on older versions (like fc3) if I had a driver or hardware problem, I would pull out the card, boot up and kudzu would ask if i wanted to uninstall it. After saying yes, shutdown, stick card back in and reboot, kudzu would ask to reinstall it. Problem solved.

Now with FC6, it doesnt do that. My soundcard is up the sh*t and I cant figure out how to uninstall it.

Ps. I know the card works cause I can boot up a live cd like DSL and it still works fine. Just not in FC6

GrueMaster 12-09-2006 02:57 PM

What sound card do you have? It may just need an option added to the modprobe.conf file or a newer version of alsa-driver.

dannyk1 12-13-2006 05:35 AM

The card is a Creative Vibra 128 card

The output of lscpi is

00:0f.0 Multimedia audio controller: Creative Labs Ectiva EV1938
Subsystem: Creative Labs Unknown device 5938
Flags: bus master, slow devsel, latency 64, IRQ 9
I/O ports at e800 [size=64]
I/O ports at ec00 [size=32]
Capabilities: <access denied>

This card works fine in this machine because I can get it working with FC4 on a seperate HD. Will I have to recompile the kernel to get it to work or something like that?

GrueMaster 12-13-2006 10:11 AM

First, check to see if the modules are loaded. Open a console window, type "su" to login as root, then "lsmod |fgrep snd" to see if any sound modules are being loaded. If not, try running alsaconf to configure your system.

dannyk1 12-14-2006 10:21 PM

It said the modules were loaded and alsaconf wouldnt run.

I got it going thou.
I compiled a new kernel with isa support in it and tried an old soundblaster isa card I had.

The interesting thing is it only works if both isa and pci cards are installed.
remove one of the cards and no sound.

The isa card by itself, the system says there is no card at all. But when the pci card is there, sound works on the isa card but not the pci...

Strange....


All times are GMT -5. The time now is 05:36 PM.