LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Hardware (http://www.linuxquestions.org/questions/forumdisplay.php?f=18)
-   -   Reduced To Puddle Of Goo :) (http://www.linuxquestions.org/questions/showthread.php?t=4175458911)

BobTheSlackUser 04-20-2013 12:03 PM

Reduced To Puddle Of Goo :)
 
Hey Folks,

I hope someone can give me a hand. I've used Linux off and on for several years. But I need a server in my house so I thought I'd install Linux on it because I really like it.

I've built this computer myself just yesterday (16 Gig ram, AMD FX 4 GigHz CPU, 2 terabyte HD).

So here is the problem: after I boot past the bios AND some initial choice screens on any install, Linux will NOT recognize my Keyboard or Mouse.

I've tried adjusting my bios for all the legacy USB settings every which way. So far, no luck.

Here are the distributions I've tried (Please look at the funny thing at the end).

Slackware 14.0 - gets past where you hit the return key to boot, or enter boot options, but by the time I get to the screen where you choose your keyboard, my keyboard is no longer recognized, so I can't ever hit the return key to go on.

Linux Mint 14.0 - boots up and loads the GUI screen to begin the Mint install, but do to the Keyboard/Mouse problem I can't select the option to proceed.

Similar results were found with . . .
Knoppix 7.0.5
Kubuntu 11.10
Kubuntu 12.10
Kubuntu 13 beta2 (Started getting desperate here with all the Kubuntu installs)

Here's the funny part I tried Knoppix 6.1 32-bit - works perfectly! Obviously I don't want to run a 32-bit 2+ year old OS on my new server off the Bluray disk. But it DOES work.

Any of you fine folks have any idea what is going on?
I sure do appreciate the help.
Thanks,
Bob

goumba 04-20-2013 12:29 PM

Never experienced this, but:

- Check kernel versions. Maybe Knoppix has a newer kernel which supports your hardware.
- See if Knoppix passes any hardware kernel options, and try booting the other distros with the same options.

BobTheSlackUser 04-20-2013 01:16 PM

Thanks goumba,

On the Knoppix version that works the Kernel version is pretty old, (I'm trying another Slackware install write now, so the knoppix disk is not in my machine), but I downloaded that version of knoppix in early 2010, so say version 2.6.20s something probably. The newer install versions I've tried are Slack = 3.1; kubuntubeta = 3.8 and the rest (various kubuntus, mint and the new knoppix) all have kernels between 3.1 and 3.8.

I don't know the knoppix boot options, but I'll find out. My wife wants me to help her clean the house right now though, hold on . . .

BobTheSlackUser 04-20-2013 04:33 PM

Alas, I can't see that the old Knoppix boots with any special boot options. So I'm b basically stuck again.
Bob

273 04-20-2013 05:47 PM

Apologies if this is too obvious, but have you tried disabling the legacy USB options as well? Have you looked for things like over-zealous power-save turning off ports?
Oh, and have you tried your mouse and keyboard in all the USB ports too?
Also, is your motherboard one that can accept a BIOS update on a USB stick and do you have a USB stick?

BobTheSlackUser 04-20-2013 08:37 PM

273, yes I've tried those things, but thanks for the suggestion.

BUT, I have found a partial solution.

All the distros I've tried are all 64 bit. I simply tried a 32 bit Mint and everything worked fine. Now, this is not the operating address length I want, but it will do while I search more in depth for an answer. At one time I went through the whole Linux From Scratch thing, and I think I'll do that this time again. You can build your system slowly and check everything as you go. In the mean time I can get this server on it's feet with Mint 32 bit and doing the things I need it to.

Anyway, goumba and 273, thank you for your kind suggestions and time, it's folks like you that make Linux work.

Bob

goumba 04-21-2013 05:14 AM

One more thing... is this an EFI based mobo? If so, try enabling CSM, disabling Fast Boot, or both. While I myself have those enabled and it works for me, others have stated they had to do so. If you enable CSM, you do lose the ability to use GPT partitioning; but that's not such a big deal if you're not going for more than 4 primaries. I don't know how CSM may affect you, but worth a shot. Fast Boot supposedly only loads a minimum of modules to get the system to boot, and maybe that's affecting the hardware Linux sees.

BobTheSlackUser 04-21-2013 11:10 PM

goumba,
Thanks for those suggestions. I tried them this mourning -- alas, still no luck. This one has me stumped, but I'll keep plugging away until the solution is found.

Thanks again,
Bob

sanseriff 04-21-2013 11:52 PM

Does your motherboard have a legacy PS/2 port if it does and if you have an old PS/2 keyboard you could try installing with it.
If installation completes you can retry USB keyboard and see if its recognized.

cynwulf 04-22-2013 09:44 AM

Quote:

Originally Posted by BobTheSlackUser (Post 4935389)
So here is the problem: after I boot past the bios AND some initial choice screens on any install, Linux will NOT recognize my Keyboard or Mouse.

This would indicate that the USB legacy options are not the cause as the keyboard works for a start and in the initial menus. It seems likely that it's at the point where the kernel modules for your USB devices are loaded that the keyboard and mouse go dead.

Have you tried simply unplugging and re-plugging in the keyboard and mouse at this point? If so and that hasn't worked, have you looked at console/dmesg output?

BobTheSlackUser 04-22-2013 11:22 AM

Thanks for trying to help me.

sanseriff: My mother board does indeed have one PS/2 output, but I have no keyboad that uses one. I'll try to scratch one up though.

caravel: NO I have not tried that (Unplugging the keyboard etc.)! I feel silly for not having thought of it! I'm at work right now, so I'll have to wait until tonight to give that a shot. Also, I'll try a

dmesg | grep -i usb

From a console slack install tonight and see what it says.

Again, I must say, thank you all again for trying to help.

Bob

TobiSGD 04-22-2013 01:32 PM

Do you by any chance use USB 3.0 ports to connect the mouse and keyboard?
It may be possible that those installer disks do not come with support for USB 3.0.

Tip for the future: Use descriptive title for your threads, this will increase the chance that someone knowledgeable about the problem will look at your thread and it will make it easier for people with the same problem to find your thread.

BobTheSlackUser 04-23-2013 10:32 AM

Well, I think this is mostly solved -- mostly. I tried unplugging/plugging my usb keyboard/mouse in yesterday after a 64-bit install have ceased recognizing them. I noticed that whenever I plugged my mouse back in that the red optical light would come on for just a moment before it went out again.

So this means that the systems "sees" the usb hardware when it's plugged in, but for some reason the 64bit Linux drivers don't like what they do "see" and shut down communication to the usb device.

Now, I had tried switching usb connections to most of the usb2 outlets on my motherboard before, all to no avail. But I thought maybe I should try the usb3 ports. The red light on my mouse going on and off told me that at least the circuitry was probably good. And I had not done so yet because I didn't want to cumber up the usb3 ports with a simple mouse and keyboard. But sanseriff/caravel/TobiSGD recent suggestions finally drove this idea into my head.

Well I tried this (plugging the keyboard/mouse into usb3 ports) and everything worked. Wahoo!

I can say that my motherboard claims that it can output 3 times the power to usb (but I can't change this in the bios as far as I can see). Maybe this has something to do with it. Maybe Linux 64bit drivers are sophisticated enough to see this increased power (and don't like it) vs. the 32 bit that cannot. I don't know.

But whatever it is, I have been able to get a 64 bit OS to install now. I think that for now, I'll just finish getting more home brewed software installed and working - which is why a got the server like machine in the first place. I need to start getting some real work done, not just installing operating systems. I'll deal with the used usb3 slots later. Like I've said before, I'd like to piece together a Linux From Scratch system as I have time, after I get this server doing real work. Maybe I'll find out what the deal is with these usb2 divers during that LFS process.

Thanks to all of you for your support, I really do appreciate it.
Bob

rcbpage 04-25-2013 04:00 AM

I had the same problem with Ubuntu, and a Logitech bluetooth dongle, I just used an old ps/2 KB and mouse to get installed, then switched back to the Logitech dongle after it was up and running. It seems that most distros don't load the necessary drivers into their install kernels :(

BobTheSlackUser 04-25-2013 05:50 PM

rcbpage,

Actually, I'm glad I'm not the only one to have experianced this. And things do seem to work well if you can get past the install. I wonder what the driver difference is with the installs . . .

Ah well, thanks for the info.

Bob


All times are GMT -5. The time now is 09:41 AM.