LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Redhat9 Usb Printer Set Up (https://www.linuxquestions.org/questions/linux-hardware-18/redhat9-usb-printer-set-up-60251/)

anwar_lpk 05-17-2003 02:33 AM

Redhat9 Usb Printer Set Up
 
I have my canon i320 and its using USB printerport, my system was redhat 9 distro, can i configure it and use it as well as in windows system, cause i have try many times and it always failed, should i download the driver for linux system, see at my cd package there is only windows appears, not linux.

activematrix 05-17-2003 07:17 AM

Does RH auto-detect it? CUPS and RH auto-detected my USB printer and suggested a driver (that works just fine). In Mandrake, it wouldn't detect it until I told it to search /dev/usb/lp0. Might give those a shot and see if RH knows what it is.

anwar_lpk 05-17-2003 09:08 AM

seems appears, but
 
yes indeed its appears on my system, my RH9 detect my printer, known well as canon i320, but its always ask me to enter the device driver which i dont know what the driver is, see after RH detect the printer and the printer list is shown, its continuous with a dialog box asking for the device driver, what should i do? generic printer or to specify the device which its doesnt appear in the list?

activematrix 05-18-2003 10:01 AM

Give this a try:

http://www.turboprint.de/english.html
Quote from site: .8-May-2003: TurboPrint 1.81 with new Canon i320, i950 and S200 drivers

Appears to be a printing driver and I supposedly gives support for the Canon i320. There's a free edition and a pro edition; however, I'm not sure if your driver is supported under the free edition--it's worth a shot though!

Good luck!

-David

anwar_lpk 05-19-2003 01:10 AM

i've been downloaded that turboprint software rpms, and i've installed onto my system, its seem works for the first time, but still my system wont detect my USB port, see i've installed CUPS on my redhat9.

activematrix 05-22-2003 02:16 PM

Does it not detect the USB ports or just the USB printer? Do other USB devices work?

anwar_lpk 05-22-2003 08:54 PM

its doesnt print any test page, my USB port was detected, but when i perform to do a test page, there is message appears lpr: service couldnt do the test page, or something like that, sorry cause i use my windows system here to reply this. i 've downloaded turboprint, i've CUPS installed on my linux system, but...

anwar_lpk 05-22-2003 08:57 PM

additional, seems my usb's port are all work fine, and linux detected it well, cause when i order to detect my printer, its appears canon i320 with usb port supported, but when i perform the test page appears above message

activematrix 05-24-2003 05:04 PM

Does the printer support LPT printing? That'll let you know if there's a problem with lpr or lpd.

Perhaps see if the driver works and then attack the USB problem from a different angle. Do you have any other USB devices you can test.

anwar_lpk 05-25-2003 11:19 AM

i'll try that, thanks

activematrix 05-28-2003 12:40 PM

Any luck?

anwar_lpk 05-29-2003 03:46 AM

nothing, its still appears lpr:service couldnt do the order, i've try my other usb port and the error still the same

anwar_lpk 05-29-2003 03:49 AM

well see, maybe its because i use the free edition, s then the printer i have, got no support anything

activematrix 05-30-2003 08:27 AM

Did it work when you tried it via LPT or does other USB devices work?

anwar_lpk 05-30-2003 10:13 PM

replying
 
i dont have any other usb device, its my only one, i've sole my lpt printer, but its seems working using LPT, cause my friend on my neighbor already used redhat9 and using LPT printing, i've seen that, and its work, but it doesnt work on my system, ofcourse using my usb port as i have only this one with my canon i320. sorry im just a fool, and very2 newbie on linux. but see my other device is working, such my modem, network card, graphic card, soundcard too, only my printer seems to be the only trouble i have:Pengy:


All times are GMT -5. The time now is 09:51 PM.