LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   REDHAT with GPU (https://www.linuxquestions.org/questions/linux-hardware-18/redhat-with-gpu-841822/)

divyashree 11-02-2010 12:26 AM

REDHAT with GPU
 
I have CentOS5 installed with a Geforce 9800GT GPU. After installing the driver of GPU, I returned to GUI mode and alwayas the monitor goes blank saying change to otimized mode 1366x768 with 60 Hz.

The same result returns with system-config-display, init 5,startx ,nvidia-setting . Now I have uninstalled the GPU driver and using 640x480 screen which is by default with big font all big.

How will I resolve this issue ?

mlangdn 11-02-2010 06:26 AM

Multiple postings won't help. This is the third time I saw this issue.

mesiol 11-02-2010 07:02 AM

Hi,

could you please extend you vary rare information.

1. post your xorg.conf
2. define exactly what hardware you have
3. does xorg nv driver work?
4. did you setup the display configuration manually or are you trying to autodetect your display?
5. post the file /var/log/Xorg.0.log

Thanks

Drakeo 11-11-2010 10:57 PM

This guide will help you configure the proprietary nvidia module under CentOS and Red Hat Enterprise Linux 5. For those that don't know, CentOS 5 and Red Hat Enterprise Linux 5 are basically the same thing just with a different name so this guide applies to both. I will not be covering the open source nv module included with Xorg because its configuration is normally handled automatically by most Linux distributions.
Licensing Issues

NVIDIA provide their own license for their driver. You will need to read and accept this license before proceeding. You can read this license here.
Notes

We will be using 'nano' as our text editor of choice but you can use whatever you wish.

While this guide is mainly focused to laptop users there isn't any difference for desktop users.
Prerequisites

You should run a full update for your installation to ensure you have all the latest packages installed.
Installing the NVIDIA driver

The nvidia driver is not included with CentOS/RHEL 5 so we will need to use a 3rd party repository. Here we will be using the ATrpms repository.


1. Load up a terminal window if you are in the graphic interface.

2. Switch to the root user by entering the command “su -” (without the quotes) and typing in your root password

3. Edit the file /etc/yum.conf. Using nano we type the command “nano -w /etc/yum.conf”

4. If you have already configured yum to use the ATrpms repository then append “*nvidia-graphics*” to the end of the “includepkgs” line and skip the next setup. Otherwise continue on.

5. Add the following to the bottom of this file:

[atrpms]
name=EL $releasever - $basearch - ATrpms
baseurl=http://dl.atrpms.net/el$releasever-$basearch/atrpms/stable
gpgkey=http://ATrpms.net/RPM-GPG-KEY.atrpms
gpgcheck=1
enabled=1
exclude=*kmdl*i586*
includepkgs=*nvidia-graphics*

6. Save the file. In nano you press Ctrl-X, answer yes to the “Save modified buffer” question and then press enter on the file name to write.

7. If you have not previously setup ATrpms execute the following command:

rpm --import http://ATrpms.net/RPM-GPG-KEY.atrpms

8. Now execute the following command:

yum install nvidia-graphics169.07 nvidia-graphics169.07-kmdl-`uname -r`

9. Reboot your system and you will be using the nvidia driver.
Troubleshooting

Normally after installing the nvidia driver with the steps above your xorg.conf file should have automatically been updates to use the newer driver. If this did not happen or for some reason it has reverted then, as root, enter the following command:

nvidia-xconfig


This will switch you back to the nvidia driver.
you think after all that it would work well only if you blacklist nouveau in the /etc/modprobe.d/blacklist file when you installed from there repository.
so now when you google your monitor info for it's screen resilution we will be able to help you.
did you read all that just to installs a driver. know wonder I use slackware and trouble shoot everything else. Thanks Pat


All times are GMT -5. The time now is 10:34 AM.