-   Linux - Hardware (
-   -   RedHat freezes mounting/or trying to write to CDRW (

SPMcRuube 11-30-2002 08:41 PM

RedHat freezes mounting/or trying to write to CDRW
Just to clear the air.
I'm running Redhat 8.0 probably kernel 2.4.18-14 and
I'm not using a boot loader. I'm using a boot floppy.

When I insert a data cd and try to mount it. in KDE the drive spins up and then Linux freezes. the CAPS lock and Scroll Lock lights on the Keyboard flash and that's about it. Can't do anything other than a hard reboot. When I place a Blank CD-R in the drive and try using the basic KonCd the same thing happens (spins up then locks)

On the boot floppy in the syslinux.cfg file appears the following.
default linux
prompt 1
display boot.msg
timeout 100
label linux
kernel vmlinuz
append initrd=initrd.img hdc=ide-scsi root=/dev/hda3

I tried before to remove the "-scsi" line in hdc=ide-scsi and that allowed me to mount cd again but I couldn't write with the cd writer.

So what do I do now. I replaced the "-scsi" line and the writing software can see the burner. but it still locks up. What needs to be done. I read something about changing the etc/fstab or something. Please let me know. I would like to be able to use my cdrw drive.

Thanks for any help

finegan 11-30-2002 08:58 PM

This is friggin weird, you can try obliterating the /etc/fstab line that deals with your cdr at all, reboot, and then manually mount the drive from the command line, that'll at least rule out any of RH's funky fstab options from being the issue. Before that check "dmesg" for the SCSI emulation line about the CDR, it should stand out a bit and be near the end. There might be a hint in there.



SPMcRuube 11-30-2002 09:14 PM

dmesg info
Well I don't like the Idea of removing the line about the cdrom from etc/fstab

this is what the line says:
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,kudzu,ro 0 0

Like I said there was something I read but didn't understand. Something about replacing that line I read it here.

I ran dmesg it's a little long cause I don't know the more specific thing uh yeah. you know what i mean. anyway these are a few lines I found that may be relevent. These of course are pulled form the dmesg not in sequential order

Kernel command line: initrd=initrd.img hdc=ide-scsi root=/dev/hda3 BOOT_IMAGE=vmlinuz
ide_setup: hdc=ide-scsi


SCSI subsystem driver Revision: 1.00
scsi0 : SCSI host adapter emulation for IDE ATAPI devices
Vendor: YAMAHA Model: CRW2200E Rev: 1.0D
Type: CD-ROM ANSI SCSI revision: 02

Attached scsi CD-ROM sr0 at scsi0, channel 0, id 0, lun 0
sr0: scsi3-mmc drive: 40x/40x writer cd/rw xa/form2 cdda tray
Uniform CD-ROM driver Revision: 3.12

So I dunno if any of that is helpful. Let me know if that URL means anything. And if so How do I do that for Red Hat 8.0 is it tricky remember I'm a newbie

SPMcRuube 12-01-2002 12:27 AM

editing etc/fstab no good
I tried the following commands

# rm /dev/cdrom
# ln -s /dev/scd0 /dev/cdrom

and I didn't get an error
I had to log in as root to mount the Cd but
the same thing happened. it spun up for a little longer than before and then boom fozen. manual hard re-boot.

is there something I am missing?
Can anyone please help.

SPMcRuube 12-01-2002 01:28 AM

Oh yeah,
I also changed in the etc/fstab /dev/cdrom to /dev/scd0

if that is of any use to the mighty troubleshooters.


would I be able to write cd's if I remove all refrence to /dev/cdrom or /dev/scd0 as it is now from etc/fstab? or is that going to cause more trouble. And if I do does that mean removing that entire line or just the line dev/scd0?

Aussie 12-03-2002 12:00 AM

Your cdrw is /dev/sr0
Attached scsi CD-ROM sr0 at scsi0, channel 0, id 0, lun 0
sr0: scsi3-mmc drive: 40x/40x writer cd/rw xa/form2 cdda tray
Uniform CD-ROM driver Revision: 3.12
You need to adjust your fstab and symlink to the correct device, then make a new group called 'cdwrite' change the ownership of all devices and cdwriting apps to group cdwrite and add your user to group cdwrite.

SPMcRuube 12-07-2002 04:00 PM

Thank you, sorry about the late response.
Ok Thank you for your reply. Sorry about my late reply I've been out of town.

However, I don't think I follow you. I understand now that the cdrom is dev/sr0 but I'm not sure how to do all of what you suggested.
perhaps you could point me in the direction of some documentation that could assist me in completing the task.

Thank you again for your response.

All times are GMT -5. The time now is 11:34 AM.