-   Linux - Hardware (
-   -   redhat 8 and ATI Radeon agp 320m (aka Radeon Mobility U1) (

nelsonnery 09-20-2003 07:25 AM

redhat 8 and ATI Radeon agp 320m (aka Radeon Mobility U1)
I have a Compaq Presario 920US which comes equipped with a graphic card ATI Radeon agp320m, which is also called Radeon Mobility U1. This a configurable card that goes up to 64MB of shared RAM memory.

My problem is that the only driver that works is that generic driver VESA which does not use all the graphic card potential and, in fact, in the X-windows environment everything runs really slowly (moving windows, scrolling netscape windows, etc).

I did a lot of google searching but, even with the latest version of xfree86 I still didn't have any luck. Apparently ATI did not provide enough information to make this card work with an appropriate linux driver.

Nevertheless I found some people on the Internet, who apparently could make this card work, although I was unsuccessful when trying their methods.

I was wondering if someone has any help/information that could provide me.

Thanks a lot for any help!


Goeland86 09-24-2003 07:08 PM

I run Redhat 9 on a pavilion ze4400 and I have the same problem.
You have to update the kernel or patch it to include the latest driver for the ATI *chipsets*, not the graphics cards, and then recompile and it *should* work. Only the problem I have is that I can't or don't know how to install a brand new kernel from The driver for the chipset is already included in the 2.6.0test5 release, but I can't install it properly, I need to find help with that first. If I find how to do it, I'll let you know about it.
There should also be a patch for the 2.4.22 release as well, but I couldn't find it.
If anyone has some other piece of help to give, I'd be delighted too. Thanks

Goeland86 09-30-2003 07:37 PM

Actually, I found a website that describes the process quite thoroughly, I'll keep you posted on how it comes... I've had no luck until now with the XFree86 patches or kernel patches... they all seem to screw up the kernel source files when applied, it always makes compilation errors up to now. Check the website if you want :
The problem seems to be compiling the 2.6 kernel, otherwise it looks like it would work ok.

Goeland86 09-30-2003 09:37 PM

Hi, me again
I just wanted to say that I finally got the 2.6.0test6 kernel to work.
I applied the latest CVS patch from the website, and loading the default redhat configuration for the kernel, it worked. It did all the things it should have normally. The only thing is that when it says it can't boot the filesystem, make sure you specify in grub to have root=/dev/hdaX where X is the partition you have your kernel on. Once booted with the brand new kernel, in text mode run redhat-config-xfree86, and it should enable the hardware acceleration support, provided you enabled all the proper options in the configuration. Also, make sure you enable or set as modules all the options that the redhat config file doesn't load on its own. That includes the USB and Sound modules. For the config file to load, go into /boot/ and write down the name of the config-2.4.xx-x.x where x is a number you have in the directory. Hope you can make it... For additional help, contact me via MSN at or email, at the same address. Good Luck and don't despair, it took me a while to find out how it works too!

nelsonnery 10-07-2003 01:19 PM

Thanks Geoland

I just upgraded to redhat 9, so now I have the latest XFree86.

The system now recognizes my graphic card but I does not start the X server unless I set it up with the VESA generic driver.

How do you configure your kernel?

The only way I know is to use "make menuconfig" in the /usr/srs/linux directory

I will try to install the same kernel as yours and give it a go.

My msn messenger e-mail is

I will probably ask you for some help there.

Thanks a lot for everything.


Goeland86 10-07-2003 05:14 PM

It also works with a 2.4.20, you just need a patch...
Hey, you can use a 2.6 kernel, but I later found out a patch for the 2.4 kernel, and I forgot to post about it... here's where to find the patch :

Scroll down until you find the 2.4.20 patch...
it might appear directly in the bowser as text, in which case you'll want to save the page with the name of the patch.
Then go into the /usr/src/linux-2.4.20 from the redhat kernel-source rpm, or from another source, just make sure it's a 2.4.20, it won't work with a 2.4.19 or 2.4.22 for instance.
Once in there, type without the quotes
"patch -p1 < [path to where you saved the patch]", I suggest you move the patch file to /usr/src before attempting the command, this way it will be something like "patch -p1 < ../igp_[....]" and make your life easier to see what patches are available to what kernel source...
Still, I don't get 3D hardware acceleration due to an XFree version that's too old, but I'm too afraid at the moment of using anything else than the default version provided... I already almost lost my data twice by trying to install an rpm upgrade for it, and I figured we'd be better off staying on the safe side for now... We'll just have to wait until Red Hat upgrades it's beta rpms for the XFree server, and then give it a try.
I might be able to help you out with that too, when it's out.
Cheers, Goeland86

nelsonnery 10-07-2003 06:38 PM

Hi again!

It is now working, but I didn't have to patch the kernel. I just installed the latest radeon drivers and it worked!

How do I know if I have 2D or 3D acceleration?

When I type "glxinfo" I get

name of display: :0.0
Xlib: extension "XFree86-DRI" missing on display ":0.0".
display: :0 screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
client glx vendor string: SGI
client glx version string: 1.2
client glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
GLX extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
OpenGL vendor string: Mesa project:
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.3 Mesa 4.0.4
OpenGL extensions:
GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp,
GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color,
GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add,
GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
0x23 24 tc 1 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 0 0 None
0x24 24 tc 1 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 0 0 None
0x25 24 tc 1 24 0 r y . 8 8 8 8 0 16 8 16 16 16 16 0 0 None
0x26 24 tc 1 24 0 r . . 8 8 8 8 0 16 8 16 16 16 16 0 0 None
0x27 24 dc 1 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 0 0 None
0x28 24 dc 1 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 0 0 None
0x29 24 dc 1 24 0 r y . 8 8 8 8 0 16 8 16 16 16 16 0 0 None
0x2a 24 dc 1 24 0 r . . 8 8 8 8 0 16 8 16 16 16 16 0 0 None

I call your attention for this line

Xlib: extension "XFree86-DRI" missing on display ":0.0".

Do you have any idea of what this means? From what I read, it can be related with the fact that I don't have 3D accel.

From a forum I got the following solution:

"Download XFree CVS, compile it and patch the kernel with the last
dri and you'll get 2D and 3D hardware acceleration"

Unfortunately, I don't know how to do this.

Any further help would be most welcome!


Goeland86 10-07-2003 07:23 PM

I don't know either...
Exactly, the fact that it says DRI missing means Direct Rendering I[something] is missing, therefore no 3d accel... Although I am not sure that doesn't mean 2d accel is enabled... You'd have to ask someone else, as I am not really sure.
And the Xfree CVS versions are not given in rpms, but in tarballs, and to be honest, that's what I meant when I said I'd rather stay on the safe side... I'll just wait until it's in a stable version, even if the XFree Current Version Snapshot(s) are usually stable, because it's complicated to install... so I'll just wait until I can find an updated rpm for XFree that will install properly on top of the one I have, since the CVS version is the source code, and that means compiling XFree yourself... I am not looking for trouble with that right now... As a high school senior, I have enough other things to do with linux for my linux class, although I am tempted to ask my teacher how to do it... I'll see if I find time for it, and if I can get the information I need on how to do it properly so that it will work the first time.
Of course, I will keep you posted on this, unless you find the time and will to do it before me... in which case I am sure you will post your success! ;-)

nelsonnery 10-08-2003 03:17 AM

Thanks Geoland.

I'll keep trying a few more things and if I am any luck, I will post it, of course! :D

Thank you for all the help.


nelsonnery 10-09-2003 05:31 AM


I was trying to install a brand new kernel (for the very first time) and I messed everything up!

I have an rpm for the latest kernel available from redhat and the latest stable kernel from, which is a tar file.

The problem is that I can't make any of these work.

The rpm I tried it with the options rpm -ivh --force and it tells me that there some "grubby error".

The tar file, I follow the instructions from the README file but it doesn't work either.

And I'm afraid that my old kernel is not recoverable (stupidly deleted it!).

Can you give me any help with this?

If I could star the X-environment maybe I could go to the redhat up2date and, somehow, get a new kernel. I should add that this is the only way I updated kernels before, so I don't know much about kernel installation.

Any help would be REALLY welcome!



Goeland86 10-09-2003 09:48 AM

Okay, well, I woulld love to help, but since you have a different laptop than mine, it's going to be messy if I send you my kernel. What I would suggest is that you reboot on the redhat 9 cd and try doing a rescue, make sure you select the kernel packages, and before it starts installing any package, do a <Ctrl>+<Alt>+<F2> and go into /mnt/sysimage/etc/X11/ and backup your XF86Config file to something like XF86Config-backup in the same directory... once the update (or rather downdate!) is complete and before rebooting, copy it back to the original name.
Hope this works

again708 11-06-2003 07:24 AM

Me too....what can i do? i'm a newbie.....

Originally posted by Goeland86
I run Redhat 9 on a pavilion ze4400 and I have the same problem.

All times are GMT -5. The time now is 11:01 PM.