-   Linux - Hardware (
-   -   recovering data from hard disk (

planctus 10-07-2005 10:06 AM

recovering data from hard disk
i've a great problem, my hard disk partition with /root and /home seems to be unreachable, my system doesn't boot anymore and it tells me about problems with some inodes and blocks.
I've tried starting with a live cd but the partition could not be mounted because of problems with the superblock. I've also tried with fsck but it had the same problem, i've changed the number of the superblock but nothing changed.
I need to recover data that the partition contains, i didn't do a backup and it's the first time i encontered an hard problem with the disk...
Does someone help me?

camorri 10-07-2005 10:19 AM

Two suggestions. FIrst, it looks like your drive may be toast, if that is your conclusion also, could you mount a second drive and do an install to that dirve? If it is a desktop machine, that will get you going.

Second, post the complete text of the "bad superblock" message. We may be able to help more then.

You didn't say what live CD you tried. I have used Knoppix for this type of failure with a lot of success. Let us know what live CD it was.

planctus 10-07-2005 11:14 AM

ok, this is what i get with the fsck command: Group descriptors look bad... trying backup blocks...
fsck.ext2: Bad magic number in super-block while trying to open /dev/hda2

The superblock could not be read or does not describe a correct ext2
filesystem. If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193 <device>

I've tried with another superblock as suggested by bash but didn't work
This is the output of the command mount:
mount: wrong fs type, bad option, bad superblock on /dev/hda2,
or too many mounted file systems

The pc is for desktop use, but it is the brain of a multimedia-lab in my bar, in Rome and i have so many datas that i've to access....

I used these live cd; mepis, ubuntu and now i'm using Knoppix, 3.8 i mean....

Amon80 10-09-2005 08:30 AM

I had the same problem. Don't worry, it's probable that you'll recover all your data.
The first thing to try is:
e2fsck -b 32768 /dev/hda2

then, answer "yes" to all the questions. e2fsck will try to repair your file system.

Let us know if it works.


P.S. I live in Rome too :)

slarver 10-10-2005 04:02 PM

You just saved my night Amon80. After filling my system disk to 101% it just crashed and I ended up with the same problem as "planctus"'. I couldn't run fsck with the -b option until I tried it "your way". I got my system up and running now, thank you very much Amon80!


All times are GMT -5. The time now is 04:15 PM.