-   Linux - Hardware (
-   -   realtek alc883 record sound wont work (

vo1pwf 11-05-2007 01:45 PM

realtek alc883 record sound wont work
mp3's wavs etc all play as well as system sounds, but nothing will record audio from either the mic or the line in

if it helps to find the source of the trouble, when I plug a mic into the mic port I hear everything I say into the mic come out of the speakers but the sound recorder app nor any other listening program can hear or detect anything is there

running ubuntu 7.10 on a acer aspire 5100 laptop I have tried installing alsa drivers from source, uninstalling alsa completly and reinstalling them.. I did a restore from the factory cd and everythign works fine in vista and xp, this is a major hurdle for me I really really really need to get recording happening

oh linux guru's what say you

Vultaire 11-14-2007 08:58 PM

I also have an Acer laptop (Aspire 3103WLMi), and I've been having issues with the mic ever since I got it. It uses the ALC883 as well, which seems to resolve to the snd_hda_intel alsa driver. I think this codec has been working for some machines, but it has settings for working with several different configurations, and I have yet to find one which will work to record anything properly on my system.

This problem appears to also be present in the latest kernel source (git clone from Linus's tree last night). So I think I'm going to start a thread on one of the alsa mailing lists to see what I can find out.

Could you do me a favor? Could you run this script ( and pass me the pastebin address it gives you? That way maybe I can have more than one example of an Acer system having problems with this device?


Vultaire 11-16-2007 01:19 AM

I found a solution!

The snd_hda_intel module needs to be started with one of the Acer options, like so:


modprobe snd_hda_intel model=acer-aspire
modprobe snd_hda_intel model=acer

(I had to use the acer-aspire code.)

Since you're running a Debian-based distro, if you want this to be a startup option, try adding this to your /etc/modprobe.d/alsa-base:


options snd-hda-intel model=acer-aspire
In addition, make sure that your mic boost is set up in addition to your normal capture volume.

Paul Goins

vo1pwf 11-17-2007 10:55 AM

where to put it
where inside the alsa-base file do you insert the code??

vo1pwf 11-17-2007 11:19 AM

partially working
I now get sound to come in perfectly. but afer soo many seconds it stops
if I restart sound by....
rmmod snd-hda-intel
modprobe snd-hda-intel model=acer-aspire same thign happens, works for a bit then dies, but I cant get hardly a minute of recording time out of it

vo1pwf 11-17-2007 08:08 PM

uploaded from the script file
the url is

Vultaire 11-17-2007 10:04 PM

Well, I'll try to do some more extensive testing come Monday (it's the machine I use at my work). I've noticed that on a fresh bootup the sound gets cut off after like a second or two, then I have to unload/reload the driver, then it starts working perfect. The testing I did involved running audacity, which was having problems recording multiple tracks in the same file among other things. With the new settings it seemed to be working fine... but I didn't test for over 60 seconds, I'm pretty sure. I'll see if I can reproduce what you're experiencing - and if not, then maybe we'll need to contact the alsa devs.

While you're still having this problem, I would suggest getting on the alsa-user mailing list, which is what I've done as well. Here's the link:

- Paul

Vultaire 11-18-2007 06:03 PM

I tested again this morning using Audacity. I recorded 3 segments in a row, from a fresh boot without restarting the driver or Alsa. First segment was about 5-10 seconds, next was 3, and the next was a little over a minute. Everything went flawlessly... I do know that Debian testing had a few more alsa updates that came in, and it's possible some of that might have resolved my issues. Unless it's an intermittent thing that hasn't popped back up yet, my problem is completely solved with the "model=acer-aspire" fix.

Only bit of advice I can give you now is what I gave in the last message. There is ongoing discussion about this issue on the mailing list, so please join in.

And for reference, I'm running Debian's stock 2.6.22-2-k7 kernel, and my installed alsa-related packages are as follows:

alsa-base: 1.0.15-2
alsa-firmware-loaders: 1.0.14-2
alsa-headers: (none)
alsa-oss: 1.0.15-1
alsa-source: (none)
alsa-tools: (none)
alsa-tools-gui: (none)
alsa-utils: 1.0.15-1
libasound2: 1.0.15-1

All times are GMT -5. The time now is 11:40 AM.