-   Linux - Hardware (
-   -   Realtek 8139 not working on debian (

Ben136 12-15-2004 09:28 PM

Realtek 8139 not working on debian

I have been using Linux for just under two days, and any help getting it up would be immensely appreciated! Using Debian 3.0r3 stable release, i386.

I have a standard HP computer with one PCI network card, RealTek RTL-8139. When I boot my Windows 2000 partition, it correctly shows the network card, gets an IP address from the router and I can surf the internet fine using the auto detected settings. So the card itself works.

During Debian's installation, it asks me to configure the network. DHCP fails as do manual settings. It can not get the network working. During boot-up it looks like it is loading the driver RTL8139.

modprobe -d eth0 says nothing.

If I type "ifconfig eth0 up" it says "SIOCSIOFFLAGS: Resource temporarily unavailable"

"ifconfig -a" does list an "eth0" with a hardware address and base address.

Any ideas on how to fix this?

I have been trying to get it to use 8139too. I have added it to the list of drivers to load during startup. "lsmod" shows it as loaded, and that it is used by "0".

In /etc/modules I have added a line that read:


In /etc/modutils/aliases I have added the line:

alias eth0 8139too

and ran update-modules

lspci also identifies the Ethernet controller as "Realtec Semiconductor Co. Ltd. RTL-8139 (rev 10)".

With this, if I type "ifconfig" it just lists information for lo.

If I type "ifconfig -a" then it list eth0, eth0 and lo. eth0 and eth1 are both shown as ethernet with the same hardware addresses. The base address for eth0 is 0x2400 and for eth1 it is 0x7000.
So I tried "ifconfig eth0 up", and it says "SIOCSIOFFLAGS: Resource temporarily unavailable"
So I tried "ifconfig eth0 down", no error.
If I type "ifconfig eth1 up" then I get "Device or resource busy".
I also tried "modprobe 8139too" which give no message.

Any thoughts?
How do I change 8139 to 8139too? 8139 does not appear to be listed anywhere and must be built in the kernal somehow? Or should I just see if I can get a more generic network card?

acker 12-16-2004 04:04 AM


i am using debian too, but sarge. When i've installed Debian, I've instaled stable too. I do not quite remebmer if I had to install the module in install menu from the debian installer, but the network card worked for me.


modprobe -d
modprobe: invalid option -- d

you could take a look here


I was seeing this error message with an eepro100, however > I was never able to ever get eth0 to come up. > > The problem was with an IRQ conflict, which was scrolling > by in the kernel initialisation - took me a while to spot that :)
also check this:

I've got the pretty much same output for lspci:
0000:00:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)


Hey, i got it ! :)
It was really an IRQ problem, which coudn't be solved within Linux.- It was a wrong setting in the bios, which assigned IRQs automatically. Changing this options to manually and setting the irq with the tool that is coming with the ethernet-card worked.

The card is now recognized - there are no errors in dmesg.
losmod lists the driver rtl8139 as used=1
cat /proc/interrupts shows eth0 with IRQ3 (like assigned wth the tool), ifconfig lists eth0 and i'm able to ping the network and the internet.
Try to see what `dmesg` has to say about this too. Do you have 2 drivers for one card? I don't know why you have eth0 and eth1 if you've got one card...

I'll hope you'll understand something from the above links and quotes. If not, post again with dmesg output (related to network card)


shoekstr 12-16-2004 07:24 AM

the 8139too module works for the Realtek 8139 cards what you have to do is assign a ip address to your card all you have to do is edit the config file /etc/network/interfaces file and have it look something like this for a static ip

auto eth0
iface eth0 inet static

and put your isp's dns server in the /etc/resolv.conf so they look like the following


or if you on dhcp all you need in you /etc/network/interfaces file is

auto eth0
iface eth0 inet dhcp

once that is done you just restart the network by running the command /etc/init.d/networking restart

and you network should work

Ben136 12-16-2004 06:07 PM

Do PIC network cards have IRQ's? I looked in my BIOS setupt and it does not appear that you can change or assign the IRQ. The Windows driver also does not show an IRQ. That is only for ISA cards, no?

I did not see anything during the boot, but it scrolls by so fast. Doesw it get captures anywhere? I googled about that, but no luck.

Ben136 12-16-2004 06:28 PM

Ok, most likely the problem is with the IRQ. Sounds like if the network card is in the first slot (and mine is) then it will share the IRQ with the graphics card. Interesting, since Linux is not happy with both of those.

So maybe I just need to move the network card to a different PCI slot. Hmmmm... Will try first and let you know.

Thank you for all the great suggestions. I was surprized by how many serious replies I got and how quickly.

Maybe they will make a Linux convert out of me...!

acker 12-16-2004 07:22 PM


Originally posted by Ben136
Do PIC network cards have IRQ's? I looked in my BIOS setupt and it does not appear that you can change or assign the IRQ. The Windows driver also does not show an IRQ. That is only for ISA cards, no?

I did not see anything during the boot, but it scrolls by so fast. Doesw it get captures anywhere? I googled about that, but no luck.

Yes, PCI cards have IRQ, but most of the cards are PnP (Plug and Work ;) ). I don't think that switching from one slot to another would help, but you can give it a try.
To see messages during boot you can use:


dmesg | less
If it complains about less you could use "more" instead of "less". But you should definetly install less too.

What kernel do you use? 2.2, 2.4 ?
Keep us posted...


Ben136 12-16-2004 08:57 PM

Ok, moving the network card to a different slow makes no difference. Still works on Windows, Debian install can't get the network to work. Tried a different network card from a friend, but it was not recognized at all.

Typing cat /proc/interrupts does not show anything ethernet related.

ifconfig eth0 up still says the resource is temporarily unavailable.

dmesg says that it rtl8139.c. It list eth0, at 0x2400, IRQ 0, 00:40:f4:51:63:a2

Is that IRQ0 a problem?

/etc/network/interfaces had the typical static onfig info in it, so I changed it to DHCP.

Typing "/etc/init.d/networking restart" just says the resource is temporarily unavailable.

Any thoughts?

shoekstr 12-16-2004 10:36 PM

Which kernel are you using use uname -a and you should get a kernel version mine is 2.6.8-1-386 I have no problem with the realtek drivers on any of my cards

What is the auctual make of your network card like dlink or 3com?

McCloud 12-17-2004 06:28 AM

First of all, remove the 8139too line from your '/etc/modules' file. Specifying the 'alias eth0 8139too' in /etc/modutils/aliases' is sufficient for the kernel to load the module.

Second, do you have 1 or 2 network cards. I think you have one card, so why do you have an eth0 AND eth1 listed??? Check your '/etc/network/interfaces' file.

Third, can you post the output of dmesg, lspci and ifconfig (so, the complete output, not telling us what 'some' lines say), this will make it easier to debug.

I have an onboard Realtek 8139 myself (using Debian Sarge, kernel 2.4.27) and it works perfectly, no problems at all.

Good luck.

daYz 12-17-2004 07:00 AM

It seems to me the right module was not loaded. Are you sure this card needs the 8139 or the 8139too module? You can use to quickly see if this is true. I think I had a 8139 card and needed to load the ne module, but I am not sure.
Or maybe load the 8139cp module.

Google is the first best help for linux questions. Most questions already have been asked and solved before, so you can quickly find a solution this way.

Ben136 12-17-2004 07:05 PM

i am using Debain 3.0r3 (the latest stable release). But perhaps it is too old? I could always torrent the latest version and test that.

Yes, the network card is definitely Realtek 8139, says so in the booklet and is also how Windows identifies it.

However, I found an old 3COM 10MBit card. Maybe I shall try that tonight...

This is very frustrating. If eth0 tells you the resource is temporarily unavailable, it should at least say why... What good is that?

McCloud 12-17-2004 08:13 PM

I don't mean to be a pain in the ass, but did you read my post????

I asked for information (dmesg, lspci and other things). I've got a Realtek 8139 integrated on my MB and it works perfectly (Debian Sarge, netinstall. I installed it using a Woody net-install, so my NIC works in Woody).

These Realtek cards do work in Debian (actually it has nothing to do with the distribution, but with the kernel).

I'd like to help you to work this out, so please post some relevant information so I can try to see what's wrong. I've got almost the same setup as you, so I think we can fix this problem.

Ben136 12-17-2004 09:04 PM

I would like to thank you all for your posts! Being new to Linux, I hot the latest stable Debian release and just installed the "safe" Debian option. However, after reading your emails again, I thought, ok, I would try the bf24 install option. (I should have tried it earlier, but the original one did pick up the network card etc. so I thought it ought to have worked.)

And now its happy! Auto detected and auto configured the RealTek 8139 card all by itself (says so during the boot). The install is right now happily running on my other PC and is currently auto downloading updates.

Happy happy joy joy joy!
Happy happy joy joy joy!
Happy happy joy joy joy!

THANK YOU ALL SO VERY MUCH!! The amount of sincere serious help in the posts above is really very encouraging.

One question, being new to Linux, I chose Debian because it comes bundles with lots of goodies and has high ease of use. But I could still switch to another one (Red Hat?) if that would be better?

Also, should I consider torrenting the latest Debian build, even if not stable? I guess you can update from Linux itself now, so I can play with that at some point.

Again, thank you for all your help and kind indulgence.

McCloud 12-17-2004 09:14 PM

Well, I have been a Linux user for over 3 years (on and off). I started with Mandrake (I didn't like it, too much GUI configuration stuff which conflicted with my own settings. This was Mandrake 8 I think), switched to Red Hat (which I liked better then Mandrake). Then my colleagues at work were all using Debian, and they were saying how cool 'apt-get' and Debian packages were. I figured "What the hell!" and installed Debian in March of this year. I'm really glad I did, the package management is superb, there's a lot of info on the net about Debian. I'm really happy with this distribution. I completely switched to Linux because of this distribution. I only use Windows for games and audio-cd copying (unfortunately, Exact Audio Copy doesn't wokl that well on Linux, and I haven't found a Linux program yet that matches EAC).

I use the 'Testing' (Sarge) version of Debian. It's really stable and you get all the new applications. If you want to upgrade to Sarge, just adjust your '/etc/apt/sources.list' to point to the Sarge version and do a 'apt-get update' followed by a 'apt-get dist-upgrade'.

Good luck with Debian.

Ben136 12-18-2004 01:42 AM

Thank you. I shall have a look at Sarge.

Tonight I also managed to fix my Gnome desktop, get Apache and PHP etc all working.
So I am really feeling good about Debian right now!

All times are GMT -5. The time now is 09:49 AM.