-   Linux - Hardware (
-   -   Re: Boot problem. (

matsyuf 11-15-2007 09:41 AM

Re: Boot problem.

I have a problem, when i boot my Debian Linux it loads the boot loader and I choose Linux as I also have windows XP on same machine but on later stage it brings an error below;-

VFS: Cannot open root device"hdb5" or unknown-block(0,0)
Please append a correct "root= "boot option
Kernel panic - not syncing: VFS:Unable to mount root fs on unknown-block(0,0)

and i doesn't go beyond this stage.

Before it happened I did apt-get dist-upgrade which was successful and later from Konsole I rebooted #reboot then this error came.

anyone there please help me.


kilgoretrout 11-15-2007 10:29 AM

You update may have caused the root partition to change name. The error message shows that grub can't find your root partition. This can happen if you installed a new kernel as the newer kernels are changing the designation of IDE hard drives from hdx to sdx, just like sata hard drives. However, if you did that, grub is generally configured to give boot options for both the old and new kernel, so you should be able to still boot with the old kernel.

You are probably going to need a live cd like sidux to access your root partition and get to the bottom of what changes where made, particularly to /boot/grub/menu.lst. I suggest sidux because it's debian based and has a recent kernel.

There's other things you can do if you don't have access to a livcd like sidux. You can do some investigative work from the grub boot prompt to see where grub thinks your root filesystem is located by running:

grub> find /sbin/init

Before getting into all that, post back with a better description of what you did during your dist-upgrade.

matsyuf 11-15-2007 11:01 AM


I have knoppix live CD can it help?

before i did apt-get dist-upgrade, i wanted to apt-get install trace route but it was failing because of some locked /var/.... which i cant remember well so i tried apt-get update which was successful and later i tried upgrade which will work up to the unpacking stage then it would also bring errors .

later i did apt-get dist-upgrade and again i got an error so what i did was to try apt-get -f install again i got this error, finally a friend of mine advised me to do dpkg -i --forceall - /var/..... and it worked and then it brought another window prompting me that am it had to reboot kde, smba and some other, i removed kde and let it reboot samba, this was successful, later i did apt-get remove samba because i didn't need it.

After all that i rebooted and then got that problem.

kilgoretrout 11-15-2007 05:48 PM

Boot up with your knoppix cd and find your /etc/fstab and /boot/grub/menu.lst files and post them here. Also, in /boot/grub see if there is a backup file for menu.lst; it's usually designated like "~menu.lst". menu.lst is the main configuration file for the bootloader grub. Changes here can render your system unbootable and I suspect that something in your update process may have changed menu.lst. If that happens, your system will automatically make a copy of your previous menu.lst and name it "~menu.lst".

I have to tell you that given the procedure you describe, you may be better off copying your data off the hard drive with your knoppix cd and reinstalling. It looks like something really got trashed.

All times are GMT -5. The time now is 04:34 AM.