-   Linux - Hardware (
-   -   random mouse clicks SuSE 9.3 (

MichaelLange 08-21-2005 07:21 PM

random mouse clicks SuSE 9.3

I've recently installed SuSE 9.3 Pro (from downloaded CD images) onto my Gericom "Webgine" Notebook. I now have a problem of my mouse pointer regularly going bananas:

Frequently, when i move the pointer onto a KDE-widget, it hangs briefly. If i move the mouse, movements are either exaggerated by the pointer (often putting it to the edge of the screen), or interpreted as clicks/doubleclicks, or both. If I react quickly enough and keep the mouse still for a second or two, it goes back to normal, until next time. I also noticed that the CPU fan speed increases briefly whenever the mouse comes back from "crazy" mode. I have never had this problem on the KDE graphical login screen, only in a user session

I don't think it has to do with the mouse hardware or driver, because this happens with both the internal touchpad and an external PS2 mouse (Genius optical wheelmouse, operated in parallel with the touchpad - both working well under WinXP), and also pretty much regardless of which mousedriver is installed (even "2-button PS2 mouse"), as long as it works at all.

It appeared to become less frequent but more more violent after I enabled both serial ports in the BIOS (before, only one had been enabled and shared with IrDA). Disabling IrDa support with YAST, or setting it to halfduplex in the BIOS didn't help.

Ideas, Anybody?

PS: Sorry for not providing any config files - bit difficult to post or even transfer files from that machine

kevinatkins 08-22-2005 01:53 PM


I've seen exactly this sort of behaviour using Mandrake 10.1 on a couple of machines, but only when using PS/2 mice - swapping to a USB mouse solved the problem in both cases. At the time, I did quite a bit of googling, and managed to discover that there was a problem with the PS/2 driver some time ago but it apparently had been 'fixed'... It was to do with interrupt timing as far as I remember.

Anyway, try a USB mouse and see if the issue goes away.

MichaelLange 08-23-2005 08:54 AM


actually, the problem did go away using a USB mouse. It also matches your description, because as i have found out by now, the internal touchpad also emulates a PS/2 mouse.

Anyway, since I have some kind of a solution now, i'll try and figure out what to do to get it working properly. Then i'll be back here with the 'howto'.

In any case, thanks mate!

MichaelLange 03-09-2006 05:10 PM

Just for those few having the same problem as me: installing ubuntu (breezy badger) last week solved the problem - seems linux is finally entering the windows age where you "just" need to install a new OS to solve a minor problem...

All times are GMT -5. The time now is 11:02 PM.