LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Hardware (http://www.linuxquestions.org/questions/forumdisplay.php?f=18)
-   -   Rampage IV Extreme - Unable to handle any Linux (http://www.linuxquestions.org/questions/showthread.php?t=4175497406)

Pavcio 03-07-2014 11:59 AM

Rampage IV Extreme - Unable to handle any Linux
 
I have serious problems with installing any linux at all on my Asus Rampage IV Extreme/i7

1. Direct boot Kubuntu 13.10 from DVD - Sometimes installer starts, sometimes not (freeze on Kubuntu logo) - when it starts it installs just fine, after that login screen shows after login freeze while being on "hard drive" icon, however once it started don't know why

2. Direct boot Ubuntu 13.10 - freeze and stop reading from CD at install screen (this one with passing dots)

3. 12.04 - same thing in both cases

4. Wubi 12.4 from Windows installed just to do it - install on Windows completes fine, after restart: "To show other install options press ESC now" then "0" shows and freeze

5. Recommended by manufacturer 11.4 same thing

6. OLE/openSUSE/other RedHat based - "waiting for hardware to initialize" or "starting udev..." before installation, then freeze

7. Gentoo - after detailed 2h text mode install. Without graphical interface so far, booted fine 1st time. After reboot freeze on "Waiting for ueevents to be processed..."

Tried with different combinations of BIOS settings/install options like nomodprobe but nothing worked.

Is that system incapable of handling any linux? I have license to professional softwarte to Linux platform, and now I'm stuck with not usable PC. Perhaps anyone know proper BIOS setup or any hints at all ?

mostlyharmless 03-07-2014 01:51 PM

Which i7 and BIOS revision do you have?

Pavcio 03-07-2014 02:27 PM

Bios 4802, i7 4930k

mostlyharmless 03-07-2014 03:03 PM

I have a 4930k and 9502 (beta) bios, which work without problems with default bios settings. I'd try reflashing the bios, if you upgraded it yourself. I used the previous 45xx bios without problems too, but you might have had a bad flash.

OR return the board as defective if possible with an RMA.

You might want to check the forum at rog.asus.com to make sure your memory is appropriate for the board as well. From my reading and experience, these particular boards are pretty finicky, or unforgiving or flaky depending on your philosophy.

Pavcio 03-07-2014 05:12 PM

Thanks for reply
My RAM: Kingston HyperX DDR3 4x 8GB 1600 MHz CL9 XMP Beast
I didn't touch bios flashing yet. Where should I get this 9xxx BIOS, on official website newest is 4xxx? (sorry if it's a dumb question)

mostlyharmless 03-07-2014 05:43 PM

You can find it on the rog.asus.com forum; however I'm only using the 9502 because it has VT-d enabled for ivybridge. You should be ok with the stock bios; I'd re-download it and reflash it.

See post #23 http://rog.asus.com/forum/showthread...s&goto=newpost

[EDIT]: I see a new BIOS is out 4804 which enables vt-d, whoopee!

DiskChris 03-14-2014 04:40 PM

So since you used WUBI I am assuming Windows installed just fine? I would try running memtest+ and or prime95 to make sure the hardware is ok.

cascade9 03-18-2014 04:52 AM

Possibly you'll need one of the boot options like 'nomodeset' or 'acpi=off noapic'.


All times are GMT -5. The time now is 09:47 AM.