-   Linux - Hardware (
-   -   RALink RT3090 wireless card refuses to do anything I tell it to do! (

prushik 06-18-2010 02:37 AM

RALink RT3090 wireless card refuses to do anything I tell it to do!
I bought a new netbook a few days ago. Its great, I love it. Its an MSI Wind U135 (TW), it came with Windows 7 Starter (which is crap). I installed XUbuntu Lucid on it immediately, uninstalled XFCE and installed Enlightenment R17, now it looks beautiful. I got the webcam working after only a few tries, but now I am having wireless troubles.

I did some research and found out that my wireless card is the RAlink RT3090 (MS-6891). First thing I tried was ndiswrapper (easiest thing I could think of, since I had the windows drivers). The wireless card came up, looked like it was working, I could scan and see all the wireless networks that were in range, but as soon as I try to connect to any wireless network (and I mean any), it fails to DHCP. So, I checked out RAlink's website, saw that they have a linux driver, so I was like "Yay!", but I can't get it to work. I uninstalled the ndiswrapper driver, and built the linux driver from RAlink, but insmod refused to load it. Eventually, I gave up and rebuilt my kernel, it looked like there was a driver for that card already in the kernel, so I enabled it when I rebuilt, but it didn't work (was marked [EXPERIMENTAL]). So in my new kernel, I rebuilt the RAlink driver and after some tinkering, got insmod to load the new module that I built from the RAlink source code.

So I got my hopes up once again. This time my device came up as ra0 instead of wlan0, but whatever. iwconfig recognizes it as a wireless device, and iwlist can use it to scan for wireless networks.
However, wicd does not acknowledge the existence of ra0. It will not scan for networks, let alone connect to one.
So I tried to do it manually with iwconfig. but when I run:

sudo iwconfig ra0 essid "default"
The command acts like it was successful (no output), but a subsequent call to iwconfig shows no change.

How can I make this work?

prushik 06-18-2010 02:51 AM

Ok, the problem with wicd was a simple one, I just went to preferences and changed the setting from wlan0 to ra0.

But it is still failing on the "Obtaining IP address" step.

Command line tools still give me the same problems.
sudo iwlist ra0 scan: Gives me a valid list of all the wireless APs near me.
sudo iwconfig ra0 essid <essid>: seems to have no effect. (no output)
sudo iwconfig ra0 mode managed: seems to have no effect. (no output)
sudo iwconfig ra0 commit: Fails. says "operation not supported".

prushik 06-18-2010 03:49 AM

Ok, this seems weird to me.
I still had network manager installed from xubuntu, it just wasn't running. So I started it up via the command line:

nm-applet &
sudo nm-connection-editor

set it up to automatically connect to unsecured wireless APs with essid "default", saved the configuration and closed the connection editor. A minute later, I was connected to default. iwconfig shows the connection, and so does wicd.

So, two more questions, 1. how do I get network-manager to show up in my Enlightenment System Tray? 2. Why the hell don't iwconfig and wicd work but network-manager does?

Thank you

Atrumsalus 12-16-2010 05:09 AM

Just to clarify. Easiest way to get file is to use netpkg, aptitude or something like that to install rt2860-firmware-26-fw-1.txz. If you webget use the site is


Originally Posted by Chuck56 (Post 4086189)
I'm using a Ralink 2870 USB wireless adapter but this should work for your adapter as well. The rt2800 modules are loaded and conflict with the rt2x00 modules. The way I fixed this was to blacklist all the rt2800 modules by creating the file: /etc/modprobe.d/ralink.conf


# blacklist Ralink kernel drivers
blacklist rt2800pci
blacklist rt2800usb
blacklist rt2800lib

That will take effect on the next reboot. I didn't have to install any additional drivers from Ralink with 13.1. Hope that works for you too!

This worked great for me. Just make sure you do ifconfig wlan0 up before you reboot. Also for Noobs in order to make the ralink.conf file type nano, vim, geany, pico, or whatever your terminal text editor is before the path. IE: Nano /etc/modprobe.d/ralink.conf Also, helps if you are either signed in as root or in root terminal. Sorry for any typos it is 4am here and little sleepy. Cheers.

All times are GMT -5. The time now is 12:12 AM.