-   Linux - Hardware (
-   -   Raid Dell PowerEdge 2970 (

stioanid 12-15-2008 08:13 AM

Raid Dell PowerEdge 2970
I have just installed Centos 5.2 in a DELL PowerEdge 2970.
I've managed to configure my Raids through Dell™ PowerEdge™ Expandable RAID Controller 5/i.
I have install DKMS module in order to be able to see my raids through Linux.
Is this the correct way to go?
How can I manage my arrays through linux?

farslayer 12-15-2008 08:17 AM

I would start by looking at Dells Linux Storage portal.

stioanid 12-15-2008 09:03 AM


Originally Posted by farslayer (Post 3376135)
I would start by looking at Dells Linux Storage portal.


How can I check which version of megaraid I am using in order to run

dkms build -m <module_name> -v <module version> -k <kernel version>
dkms install -m <module_name> -v <module version> -k <kernel version>

strick1226 12-15-2008 01:46 PM


$ rpm -q megaraid_sas
will show you the currently-installed megaraid_sas kernel modules (I think v00.00.03.21-4 is the latest, at the time of this writing, for the PERC 5 and 6 series, and version is latest for SAS 5/6 cards)


$ rpm -q dkms
will show you the currently-installed dkms package ...

farslayer 12-15-2008 02:02 PM

modinfo megaraid_sas


modinfo mptsas

Depending on which driver your system is using,..

It looks like you should be using MegaCLI and MegaRAID Storage manager from LSI or Dells Open Manage Storage Administrator.


Use OMSA 5.1 or higher, including the OM Storage Services component, to manage your PERC 5 (and earlier) controllers.

The PERC 5 SAS RAID adapters cannot use the same LSI management tools as their SCSI RAID counterparts (PERC 4 and earlier). Instead, use the new LSI SAS RAID tools: MegaCLI, MegaRAID Storage Manager, MegaRAID SAS SNMP. Moritz Mertinkat has created a PERC 5/i + MegaCLI cheat sheet which provides useful instructions for managing this controller via the command line tool.
But that is just speculation since you never told us WHICH controller is actually in your machine ? PERC 5, PERC 6, other ?

stioanid 12-16-2008 02:44 AM

I managed to configure my megaraidsas(5 is the Perc controller) and by the way thanks for all the help.
Now I'm thinking to install Dells OMSA RPM Repository so I can manipulate my disks through OS and not through the BIOS. Do you know if it it will work with Centos 5.2? In the official site says that it's not supported but it should work.
Has anybody tried it?
As well I want to use likewise open to join my Centos 5.2 client to an AD server. I know there is support for RedHat, but again has anyone tried it with Centos?

Thanks again in advance

All times are GMT -5. The time now is 01:14 AM.