LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 08-07-2014, 10:34 PM   #1
sirabhorn
LQ Newbie
 
Registered: Jan 2012
Location: helsinki
Distribution: debian
Posts: 16

Rep: Reputation: Disabled
Radeon GPU does not work - some games are slow


Symptoms: mame [arcade emulator] & fceu [nes emulator] are too slow to be used. surprisingly zsnes [snes emulator] & videos on the internet work finely.

I doubt the problem is related to severe looking complaints on dmesg about the integrated Radeon GPU

Here's the dmesg output about GPU & Radeon:
http://pastebin.com/HjX501Zg

I think everything worked with the previous version of Debian, but in the current version this has been the problem. I wonder if some driver has changed in the update.
 
Old 08-08-2014, 03:21 AM   #2
ReaperX7
Senior Member
 
Registered: Jul 2011
Location: California
Distribution: FreeBSD 11.0-Current Slackware64-Current
Posts: 4,867
Blog Entries: 15

Rep: Reputation: 1456Reputation: 1456Reputation: 1456Reputation: 1456Reputation: 1456Reputation: 1456Reputation: 1456Reputation: 1456Reputation: 1456Reputation: 1456
Try this first:

Install driconf package and see if you can tune your video card driver options.

If problems still persist try rebuilding MesaLib to use the Gallium API and any other optional features if packages allow.

Last edited by ReaperX7; 08-08-2014 at 03:23 AM.
 
Old 08-09-2014, 02:00 AM   #3
gbcbooks
LQ Newbie
 
Registered: Aug 2014
Posts: 19

Rep: Reputation: Disabled
what game do you play on linux ?
 
Old 08-09-2014, 02:22 AM   #4
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,787

Rep: Reputation: 645Reputation: 645Reputation: 645Reputation: 645Reputation: 645Reputation: 645
Have you installed firmware-linux package?
It shows you're missing something
Quote:
[ 6.322777] platform radeon_cp.0: firmware: agent aborted loading radeon/R300_cp.bin (not found?)
[ 6.323133] [drm:r100_cp_init] *ERROR* Failed to load firmware!
https://packages.debian.org/search?s...on/R300_cp.bin
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel integrated graphics + Radeon 7950 GPU DcMc Debian 6 07-09-2013 02:56 PM
Something is wrong with my GPU, Radeon X700 LexMK Linux - Hardware 10 12-26-2012 02:45 PM
GPU fan too loud with radeon drivers pwnage101 Linux - Hardware 3 11-06-2012 05:22 PM
FPS drop in games with nvidia gpu dxlr8r Linux - Hardware 11 01-15-2008 08:20 PM
other games work but armagetron to slow foustware Linux - Games 1 08-15-2004 04:41 PM


All times are GMT -5. The time now is 07:25 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration