-   Linux - Hardware (
-   -   Radeon Drivers, X1950 pro and Radeon 9600 (

moparcrazy 08-26-2010 04:01 PM

Radeon Drivers, X1950 pro and Radeon 9600
Let me start with my system. I have a home built system (from a long time ago). I have a msi motherboard 2.0Ghz, 1G ram, Running Ubuntu 10.04. I have 2 video cards Radeon 9600 and a Radeon X1950 pro (both AGP) and I think the motherboard has a AGP 4X.

I am wanting to get the X1950 pro working with Ubuntu but I am not sure how. From what I have found in my research is that Radeon (mostly older) are not supported very well in Ubuntu. I would like to keep Ubuntu 10.04 (because it is fast), but I am not apposed to going backwards. I have heard that some of the older Ubuntu's will support the cards and will work just fine. I also have the Radeon 9600 (which in installed right now), both cards run the same resolution and is the same quality picture.

I have tried to use the Catalyst (I think that is what it was called) and I have also have tried to use the fglx driver. Neither of them worked (and I lost the second monitor option).

Right now I am about to return an adapter for DVI to HDMI and the cable and just use my old card with the VGA port. Can I get the x1950 pro working with Ubuntu or should I return my adapter?

PS I am still a little new to Linux. I have been working with linux for just under a year now but it has been slow learning. Right my windows has crashed and so I am trying to keep from going to back to windows.

Thank you in advances.

More system info:

moparcrazy@moparcrazy-desktop:~$ lspci
00:00.0 Host bridge: VIA Technologies, Inc. P4M266 Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8633 [Apollo Pro266 AGP]
00:05.0 Multimedia video controller: Brooktree Corporation Bt878 Video Capture (rev 11)
00:05.1 Multimedia controller: Brooktree Corporation Bt878 Audio Capture (rev 11)
00:07.0 Network controller: RaLink RT2561/RT61 802.11g PCI
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge
00:11.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 50)
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 74)
01:00.0 VGA compatible controller: ATI Technologies Inc RV350 AP [Radeon 9600]
01:00.1 Display controller: ATI Technologies Inc RV350 AP [Radeon 9600] (Secondary)

moparcrazy@moparcrazy-desktop:~$ uname -r

I hope that there is enough info to some help.

adamk75 08-26-2010 08:25 PM

Catalyst is the same as fglrx. Ubuntu 10.04 uses the 'radeon' driver by default, and it is the only option for either of those video cards. It's actually quite well supported, though 3D performance isn't as good as fglrx (back when fglrx supported your cards).

I think the best place to start is by telling us exactly what the problem was when you first installed Ubuntu 10.04 and started X with the radeon driver.


moparcrazy 08-26-2010 09:37 PM

Well to start I am not sure what you mean by X. I just install Ubuntu and when it booted up everything seamed to be fine. I am not really have any "problem" peruse but I noticed that they display options does not go very high on the resolution. I also noticed the if I want to be able to read anything on Ubutnu (and my 42" LG TV) I have to use the resolution 800X600. If I use any other setting I either cant read it, because it is to blurry or my TV doesn't support the lower resolutions. I also noticed that when I compared the 9600 to the x1950 pro I got the same results. They both run the same resolutions. Well thinking about it I guess the problem that I would have to say that I had is when I try and play facebook games the flash player crashes all the time and the games runs very choppy and almost unplayable I was going to try and use the X1950 pro to solve the problem of not enough video card power. I have a laptop that is also running Ubuntu 10.04 (Dell Inspiron 6000 with a dedicated video card, I think it is a 128 CPU is 1.6, 512mb RAM) and it runs the games better. If it has a slower processor then my desktop and less RAM and it runs better I assumed that the video card is the problem (or the support). I also noticed that when I plugged the computer into my monitor (17" CTX LCD) at higher resolutions the picture was amazing (compared to what I am getting on the TV).

PS I am sorry about righting so scattered but that is just how my brain works. I hope that it is not to hard to follow and this is the right info.


All times are GMT -5. The time now is 10:33 AM.