-   Linux - Hardware (
-   -   Radeon Artifacts (

Phathead 10-18-2003 10:28 PM

Radeon Artifacts
I just installed an ATI Radeon 9200 today. I had to replace my GF4 because the fan on the heatsink died and fried the card. Never again will I use a sleeve bearing fan.

Anyway, my question is this: I've got the drivers working wonderfully. It was a bit harder than Nvidia's setup, but still doable, even when your system doesn't like rpm dependency hell. My only issue is that I have artifacts on the screen whenever I run 3D applications (such as glxgears) or a video overlay (DVD playback with xine). I can't take a screenshot of them, because they don't show up, but the best way I can describe them is a bunch of about 50x1 pixel horizontal lines that are off color and scattered all over the screen very rapidly like snow (the kind on your TV without a signal, not the kind outside). They are not very dense, but they are very annoying.

Has anyone seen this before? I'm using the latest drivers from ATI. My Slackware installation includes XFree 4.3.0, so I downloaded the proper driver for that. I'm running at 1280x1024x24 at 85 Hz. The monitor can easily handle that--it's what I used with the GF4.

Has anyone seen this before, or better yet, know how to fix it?


Phathead 10-19-2003 09:39 AM

No one has any ideas?

dsnuggs 10-20-2003 07:56 AM

It just so happens that at granmas video cards, they mention this. So try
It's in Chinese or something like that, but look around. I'll see if I can find it also.

Phathead 10-20-2003 09:15 AM

I'm trying to find something there, but since I don't know Chinese, it's a bit tough. I assume you know Chinese or you wouldn't know it's there. Let me know if you do find it.


Lempour 11-16-2003 06:08 PM

I have this card too and it gives me the same lines-snow artifacts. I got also add-on: I cannot set the AGP transfer rate more than 1x, or X just freezes when starting.
I noticed that when I disable page-flipping, the lines are less dense (or almost disappear)

I suspect the memory on the card to be bad, but when I try the same card in windows, it runs beautifully (damn)

if someone finds some kinda solution or workaround, please let me know



Lempour 11-18-2003 03:28 AM

ummmm...still nothing :(

I found out that there's an IRQ sharing on my machine. Maybe this could be the point. The video card, sound card, and network adapter are sharing a single IRQ channel. I tried to change it (by disabling devices, swapping cards in PCI slots...), but there's always some device left and shares the radeon's IRQ.

dsnuggs 11-18-2003 03:59 PM

Right. I've found it. :D

To quote:-

"Uninstall all previous Display driver by Windows remove program or Add & remove (must do or will have artifacts with old Nvidia drivers)." :scratch:

Although this applies to windows, it does mention Nvidia drivers. Phathead does mention Nvidia, but not you, Lempour.

Also, from a windows point of view. It does mention Power Strip and quotes:-
"Improper running Power Strip may burn the Graphics card Slowly or immediately or causing strips appear on the screen." :eek:

So if we now apply this to the Linux set-up, it may help. I do hope it does for you both.

Let me know. :)

Lempour 11-18-2003 08:25 PM

I don't know what you mean :scratch:

I'm trying to get my radeon 9200 working with the DRI's radeon driver. I had to fake the chip ID (in XF86Config) to make the card pretend to be some R200 chipset card, because Xfree86 4.3.0 doesn't fully support the RV280 chip. My card runs good in windows (without artifacts), even with page-flipping enabled, at least I know that it is not broken. No overclocking, default core & memory clock. Valid modeline. Now I'm gonna try the Xfree86 - CVS version. good night

dsnuggs 11-19-2003 06:00 AM

Ok Lempour.

What I have written is from some information that I found from Granmas Graphics cards, I.e. Radeon 9700. It came with my 9700 card. If you go to the top of this thread, you will see what the gist of my answer is to Phathead. It just so happens that you have come into the conversation half way through, and not understood what I am saying. It is just a bit of info that 'may' help to solve problems. I am not saying you damaged your card. I am saying that if the card is not set up exact, then this could be the problems you're getting.

Have you been to ATI to get their new drivers for the 9700 for XFree86 ver 4.3?

There is also a good readme file to go with it.

Lempour 11-19-2003 03:36 PM

I think I got it!!! :cool:

I have just compiled the CVS version of Xfree86 4.3.99, installed and it runs all without artifacts - no snow, just pure bright picture. And with page-flipping on I'm getting 2200 fps in glxgears....

Lempour 11-20-2003 03:36 AM

:confused:'s me again...

AGP transfer rate more than 1x still not working...X just freezes when loading the wallpaper (a liitle weird..the wallpaper is displayed only in lower 2/3 of the screen, the rest is black), log says that X freezes trying to get the modelines...:scratch: ...any ideas?

thanks in advance


Menestrel 11-20-2003 04:28 AM

help needed
I also have a RAdeon 9200 and I just couldn't set it up on my Slackware 9.1 Linux. I am using the kernel 2.4.22 and have a motherboard with the KT400 chipset. I installed the drivers from and they loaded just fine but when I'm trying to enter KDE it says: (WW) fglrx: No matching Device section for instance (BusID PCI:1:0:1) found. Could it be from the KT 400 chipset ? Could you please post your XF86config file or a brief description of how you installed the drivers ?

All times are GMT -5. The time now is 07:14 AM.