LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Radeon 9800 Pro w/ KT400 chipset Direct Rendering not working (https://www.linuxquestions.org/questions/linux-hardware-18/radeon-9800-pro-w-kt400-chipset-direct-rendering-not-working-116159/)

nemesis636 11-14-2003 09:20 PM

Radeon 9800 Pro w/ KT400 chipset Direct Rendering not working
 
I currently have Fedora Core 1 installed, however I've had this same problem on at least 3 different distributions. I have an ATI Radeon 9800 Pro installed, and my motherboard is an ABIT KD7 with the Via Apollo KT400 Chipset. I've tried both the drivers from ATI.com and Schneider Digital's drivers. X loads just fine and, as 2d is working wonderfully, however direct rendering isn't working. In my XFree86.0.log file are the following lines:

(EE) fglrx(0): [agp] unable to acquire AGP, error "xf86_ENODEV"
(EE) fglrx(0): cannot init AGP
(II) fglrx(0): [drm] removed 1 reserved context for kernel
(II) fglrx(0): [drm] unmapping 8192 bytes of SAREA 0xf8a14000 at 0xbf4bb000
(WW) fglrx(0): ***********************************************
(WW) fglrx(0): * DRI initialization failed! *
(WW) fglrx(0): * (maybe driver kernel module missing or bad) *
(WW) fglrx(0): * 2D acceleraton available (MMIO) *
(WW) fglrx(0): * no 3D acceleration available *
(WW) fglrx(0): ********************************************* *

my lsmod shows this:

fglrx 186760 0

I would prefer using the internal agpgart module supplied by ATI, but the linux agpgart module is fine, I guess. I get this error from dmesg regarding it:

Fire GL built-in AGP-support
Based on agpgart interface v0.99 (c) Jeff Hartmann
agpgart: Maximum main memory to use for agp memory: 816M
agpgart: Detected a Via Apollo KT400 chipset in AGP v2 compat mode at 00:00.0
agpgart: Detected Via Apollo KT400 chipset
agpgart: unable to determine aperture size.
[fglrx:firegl_unlock] *ERROR* Process 5833 using kernel context 0
[fglrx:drm_ioremapfree] *ERROR* [mappings] Attempt to free NULL pointer

I'm using kernel version 2.4.22 (which came with Fedora). Thanks for any help you all can provide!

nemesis636 11-15-2003 01:16 AM

well nevermind. I found out how to fix it and 3d acceleration is working wonderfully.

Screenshot

FairyFighter 11-27-2003 05:10 AM

So,

can You tell us what was the problem and how did You fixed it?

I am asking cuz this part of your post is killing me:
agpgart: unable to determine aperture size.

As I am at work I can not secify two lines before but they look ok, I hope..

:newbie:

xhawk 11-27-2003 07:32 AM

Yeah, you should tell where did you find the help because a lot of people are struggling with this same problem.

nigey2k2 11-27-2003 12:07 PM

i just checked my logs and i have the exact same problem, can you please tell us how you resolved this issue as it seems to be extremely frequent and very annoying.

nigey2k2 11-27-2003 05:44 PM

Oki ill jus put this here as its a kind of resolution .. got mine working anyway.

Dont try to get ati agp working , from what i can see its not going to, compile the kernel 2.4.22 src etc etc boot it then install the agp driver from ati, when it asks to use agpgart answer yes .. this is the only way i can get acceleration working on mine, if any knows how to get the ATIAgp module working feel free to let me know.

wops forgot to add, make sure u compile in agpgart as a module to the kernel .. also if you have a nforce / nforce 2 chipset make sure Nvidia Chipset support is compiled in, as default it wasnt on mine.

griffouille 12-22-2003 07:30 AM

Hi all

Nemesis.... it will be great if you can tell me how u resolved your problem...
Im running under Mandrake 9.2, kernel 2.4.22
I can't make my Grphic card (radeon 9800 pro) working under Xfree 4.3

I got the same output error message in my XFree86.0.log:
(EE) fglrx(0): [agp] unable to acquire AGP, error "xf86_ENODEV"
(EE) fglrx(0): cannot init AGP

(i also have an error like this one : unable to determine aperture size)

(My motherboard chipset is a KT400 Via apolo AGPv2 too)

lsmod show me that the fglrx module is loaded, (not the agpgart)
i can startx xfree4.3 in 2d but i cant make it working with 3d acceleration

Can someone help me to solve this problem ?

thx

nemesis636 12-22-2003 09:16 AM

I've written an entire howto you can view either

http://www.linuxquestions.org/questi...hreadid=117520

or

http://codenix.net/radeon-howto.html


All times are GMT -5. The time now is 05:54 PM.