LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Radeon 9800 3D Acceleration (https://www.linuxquestions.org/questions/linux-hardware-18/radeon-9800-3d-acceleration-180504/)

Xoliath 05-11-2004 08:31 PM

Radeon 9800 3D Acceleration
 
I did do a search but I did not find anything that referenced 3D acceleration for a Radeon 9800 Pro.

I'm using SuSE Linux 9.1, I had installed the drivers that I downloaded from the ATI website, but 3D acceleration was not being supported. So, I went to the support section and they told me to go to the DRI website and download and install their binaries, so I did so. I did that configured and installed, but I'm still not getting 3D acceleration. I cannot play games because it's bogged up so terribly bad.

Please someone tell me how to fix this. :) Thanks.

leonscape 05-11-2004 08:41 PM

Use the ati drivers. ( these support 3D accelaration ) and make sure that the /etc/X11/XF86Config-4 file is using the correct driver.

Then in a console type glxinfo and make sure the output mentions ati.

Xoliath 05-11-2004 08:47 PM

I will reinstall them and give it another whirl.

Xoliath 05-11-2004 09:24 PM

I'm not getting any 3D acceleration. I'm not sure if I'm doing something wrong or not.

Hammett 05-12-2004 05:15 AM

Post all the output form fglrx and exactly what you did, otherwise we cannot see what's going wrong.

zaraza 05-12-2004 05:29 AM

did you compile fglrx module? i had same problems, after i compiled them, everything was ok....

zidane2010 05-12-2004 09:10 AM

Are you using a NForce2 motherboard? if so, i am having the same problem.... :(

Xoliath 05-12-2004 12:37 PM

Zaraza: If they were from the ATI drivers, yes, I did. If not, then no.
Zidane: Nope. I have an ASUS A7V8X

Xoliath 05-13-2004 01:40 AM

Ok, I went through force installed the RPM from ATI website once again, and read it very carefully. It said I needed to build the fglrx modules in lib/modules/fgrlx/build_mod, so I went there and executed command: sh make.sh to compile the module. But I am getting an error that says:

Code:

ATI module generator V 2.0
==========================
initializing...
kernel includes at /usr/src/linux/include not found or incomplete
file: /usr/src/linux/include/linux/version.h

If it is incomplete, how can I complete it? Where can I get it? I'm running SuSE 9.1, with kernel 2.6 and XFree86 4.4

If you know how I can resolve this, let me know, thanks!

monkie 05-13-2004 04:51 AM

Have you installed your kernel source?
This is required to build the modules

Xoliath 05-13-2004 01:48 PM

Bleeeeh...
Okay, I built the modules from the linux sources, and re-ran the ATI drivers. Everything seems to install correctly, and my XF86Config-4 says that the driver is: fglrx. But I still cannot get 3D acceleration, when I type fglrxinfo I still get Mesa settings.
Code:

display: :0.0  screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.1)

What could be going wrong? :/

leonscape 05-13-2004 05:17 PM

In the modules section at the top of the XF86Config-4 there must be an entry for glx. this maybe missing. Also what your output log for xfree look like? any errors, and what modules are loaded, ( of course anything that mentions ati would also be useful ). just post them here.

( usually /var/log/XFree86.0.log is where XFree puts the log. )

Xerop 05-13-2004 05:41 PM

tyr reinstalling and compiling the driver again then when you are configuring it via fglrx make sure you say use external module then reboot everything should work although I have never been able to get the thing working after a second reboot. It all goes back to mesa string after the second reboot. Can anyone say what I can do to make the module load at boot time?
- Hope this helps

leonscape 05-13-2004 05:54 PM

Modules are set in modules.conf, usually distros have diffrent tools to help you set this up. try looking through your distros site for module configuration.

Xoliath 05-14-2004 12:28 AM

Okay, leanscape, I was looking through my Free86.0.log for any Failures, and this is what I found:

Code:

(WW) Open APM failed (/dev/apm_bios) (No such device)
(WW) fglrx(0): Cannot read colourmap from VGA.  Will restore with default
(II) fglrx(0): UMM area:    0xe8953000 (size=0x076ad000)
(II) fglrx(0): driver needs XFree86 version: 4.3.x
(II) fglrx(0): detected XFree86 version: 4.3.99
(II) Loading extension ATIFGLRXDRI
(II) fglrx(0): doing DRIScreenInit
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (Unknown error 999)
drmOpenDevice: open result is -1, (Unknown error 999)
drmOpenDevice: Open failed
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (Unknown error 999)
drmOpenDevice: open result is -1, (Unknown error 999)
drmOpenDevice: Open failed
[drm] failed to load kernel module "fglrx"
(II) fglrx(0): [drm] drmOpen failed
(EE) fglrx(0): DRIScreenInit failed!
(WW) fglrx(0): ***********************************************
(WW) fglrx(0): * DRI initialization failed!                  *
(WW) fglrx(0): * (maybe driver kernel module missing or bad) *
(WW) fglrx(0): * 2D acceleraton available (MMIO)            *
(WW) fglrx(0): * no 3D acceleration available                *
(WW) fglrx(0): ********************************************* *
(II) fglrx(0): FBADPhys: 0xe8000000 FBMappedSize: 0x08000000
(II) fglrx(0): FBMM initialized for area (0,0)-(1600,8191)
(II) fglrx(0): FBMM auto alloc for area (0,0)-(1600,1200) (front color buffer - assumption)
(==) fglrx(0): Backing store disabled
(==) fglrx(0): Silken mouse enabled
(II) fglrx(0): Using hardware cursor (scanline 1200)
(II) fglrx(0): Largest offscreen area available: 1600 x 6988
(**) Option "dpms"
(**) fglrx(0): DPMS enabled
(II) fglrx(0): Using XFree86 Acceleration Architecture (XAA)
        Screen to screen bit blits
        Solid filled rectangles
        Solid Horizontal and Vertical Lines
        Offscreen Pixmaps
        Setting up tile and stipple cache:
                32 128x128 slots
                32 256x256 slots
                16 512x512 slots
(II) fglrx(0): Acceleration enabled
(II) fglrx(0): Direct rendering disabled

Hopefully, I got all the errors there.

In my XF86Config-4 file, I do see a module setting that says:
Code:

    Load                  "glx"
Thanks


All times are GMT -5. The time now is 02:54 AM.