LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 05-27-2003, 05:45 PM   #1
jhahn
LQ Newbie
 
Registered: May 2003
Posts: 6

Rep: Reputation: 0
Radeon 9700 help


Ok, I think I may have narrowed down my problem. I have a Radeon 9700 Pro video card. My distro is Suse 8.1. I have found out that my kernel, which is 2.4.19 only supports agp 2.0 specifications. My motherboard bios doesn't allow me to set my video card to 4x to support those specifications. It forces it to run in 8x mode. Which means that the only kernels that will work with my video card (atleast in 3d acceleration mode) are the beta 2.5 kernels. I have tried to update to the newer kernel, but to no avail. Apparently Suse uses a custom kernel, and I don't have enough experience to change it to standard/generic kernel. I am thinking about spending some time and doing a LFS install and updating everything to the most current and seeing if I can get my video card to work from there. That seems like my only options at this point. The new Suse (8.2) supposedly has drivers for my card, but they only support 2d mode. So far, I know of no one who has gotten a radeon card working in 3d acceleration in suse 8.2. Any ideas?
 
Old 05-28-2003, 10:32 AM   #2
Mirar
Member
 
Registered: May 2003
Location: Falun, Sweden
Posts: 62

Rep: Reputation: 15
Sounds similar to my problem. Which motherboard do you have?
It all comes down to the agpgart, I think.

My Radeon 9700 pro worked excellent on a normal "AGP 4x" motherboard, using the ATI drivers (emerge ati-drivers in gentoo, dunno about other dists).

You can always use X with the "vesa" driver, even if it isn't *that* fun.
 
Old 05-28-2003, 01:59 PM   #3
jhahn
LQ Newbie
 
Registered: May 2003
Posts: 6

Original Poster
Rep: Reputation: 0
I have an Abit AT7-Max 2
 
Old 05-28-2003, 03:07 PM   #4
Mirar
Member
 
Registered: May 2003
Location: Falun, Sweden
Posts: 62

Rep: Reputation: 15
It's a VIA KT400 chipset. Make sure that it's supported by the agpgart.
(Last time I checked, it wasn't. )

Hey, this forum thread (another forum then this) might be something?
http://forum.matrox.com/mgaforum/For...ML/002138.html

The fellow there has an ABIT KD7 and the same problems.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI Radeon 9700 looph0le Fedora 0 06-27-2004 02:53 PM
Radeon 9700 not getting 3D KillerFry Linux - Hardware 10 03-05-2004 12:01 PM
Radeon 9700 wiek Linux - Newbie 0 02-18-2004 05:32 AM
Radeon 9700 Issues Slebine Linux - Hardware 18 09-02-2003 12:56 PM
Radeon 9700 help Slickfty2 Linux - Hardware 2 04-23-2003 03:16 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 10:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration