LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Radeon 9600 XT in MDK10 (no 3d) - tried all other forums (https://www.linuxquestions.org/questions/linux-hardware-18/radeon-9600-xt-in-mdk10-no-3d-tried-all-other-forums-178067/)

UberNo0ber 06-09-2004 04:17 AM

Excellent DaneM I'm working through this.
however I have a few problems right now.

1st) during xconfig..... in the first part
i. loadable module support-->loadable module support, module unloading, automatic kernel module=M
there was no choice of M (dot) for me to choose so I went ahead and just said Y (checkmark) am I in big trouble now or what ??

2nd) during make modules the following came up.
[root@ujan linux-2.6.6]# make modules
make[1]: `arch/i386/kernel/asm-offsets.s' is up to date.
Building modules, stage 2.
MODPOST
*** Warning: "errno" [drivers/media/dvb/frontends/tda1004x.ko] undefined!
CC drivers/video/aty/radeonfb.mod.o
LD [M] drivers/video/aty/radeonfb.ko
[root@ujan linux-2.6.6]#

Oh o what have I done now?
3rd) So onward I go and type in the next command > make modules_install
and the following comes up.
if [ -r System.map ]; then /sbin/depmod -ae -F System.map 2.6.6; fi
WARNING: /lib/modules/2.6.6/kernel/drivers/media/dvb/frontends/tda1004x.ko needs unknown sy
make: *** [_modinst_post] Error 1
[root@ujan linux-2.6.6]#

ok ...... hmmm what should I do now besides wait for another sane post from DaneM
:UberNo0ber
Thx for all the help so far.

UberNo0ber 06-09-2004 12:46 PM

After taking some advice elsewhere about this error I installed module-init-tools.3.0
and had done everything over again..... but to no avail. The same error exist.
So I forged forth anyways and maybe i can deal with the error at a later time.
However I'm finding the BACK UP stuff a little fuzzy. Could you explain this part a bit more please.
Thank you.
:UberNo0ber

UberNo0ber 06-09-2004 03:18 PM

Thought I'd just add to the problems by saying ( still trying to back things up/ but I'm at the place where you'd make entries for them in one's boot loader )

as ROOT user login I ended up just copy/pasting the going to be backup(vmlinuz-2.6.3-7mdk) into vmlinuzbackup which resides in file:/boot
Note: there is no yellow square in the vmlinuz-2.6.3-7mdk
and so its not in the file:/etc liloconf.
is it engaged ..... if not howto ?
:UberNo0ber

DaneM 06-10-2004 05:26 AM

OK...don't worry; we'll figure this out.
 
Hi, Ubernoober.

Don't worry about having to choose "Y" instead of "M" (dot). In most cases (ie. you're not inserting a custom module for that particular item, which you're not) it can even be better to load something directly into the kernel instead of loading a module. Modules take more time to load if they're not compiled into the kernel already (using the "Y" option). :)

That bit about "*** Warning: "errno" [drivers/media/dvb/frontends/tda1004x.ko] undefined!" is somewhat "different." The fact that it's right before a line referencing "radeon" might give us a clue. The first thing you should try is going and uninstalling the radeon drivers (I assume you tried to install them before posting here). To do this, type (as root), "rpm -q --whatrequires fglrx". If it says that nothing requires "fglrx", then type, "rpm -e fglrx". (If something requres "fglrx" then you'll first have to type "rpm -e [thing that requires fglrx]" before you can remove fglrx.) If that doesn't work, type "rpm -qa | grep fglrx". What this will do is cause the rpm command to list everything that's been installed from RPM packages. Using a "|" ("pipe"), followed by "grep fglrx" will cause the output of the rpm command to become the input of the grep command. Since grep is used to look for the thing specified, it will try to find any references to "fglrx" in the output of "rpm -qa". This means that if you have anything at all with the string "fglrx" in it, it will be displayed after rpm is done doing its thing. You can then insert that line (if one comes up) into the command, "rpm -e [fglrx line here]". This will remove anything related to the ATI drivers.

Now try doing "make modules" again. If all goes according to plan (*twiddles fingers deviously*), that problem should no longer exist. If it DOES still exist, start trying to figure out "why in the heck" it's looking for "[your/kernel/install/directory]/drivers/media/dvb/frontends/tda1004x.ko". If you've installed any modules on your own, try to find out if any of them installed (or tried to install) that file. To see if a particular RPM file has that file somewhere in it, you can type "rpm -q --filesbypkg [file.rpm] | grep tda1004x.ko". You can sort through them all manually by leaving out the "| grep tda1004x.ko" part. Next, I would try doing some searches on the internet for that particular filename. In google, for example you would type in the filename surrounded by quotes. This will make sure you get *exactly* what you typed in, instead of subjecting it to its search parsing engine.

The "make modules_install" command is related to the same file. I suspect that if you fix the file in the first command you'll fix it here too.

BACKUP STUFF:

Here's an exerpt from my etc/lilo.conf file.

[code]

boot=/dev/sda
map=/boot/map
default="linux-2.6.6"
keytable=/boot/us.klt
prompt
nowarn
timeout=200
#message=/boot/message
menu-scheme=wb:bw:wb:bw
image=/boot/vmlinuz
label="2.4.x"
root=/dev/sda1
initrd=/boot/initrd.img
append="devfs=mount resume=/dev/sdb1 acpi=ht"
read-only
image=/boot/vmlinuz-2.6.3-7mdk
label="linux-2.6.3-7"
root=/dev/sda1
initrd=/boot/initrd-2.6.3-7mdk.img
append="devfs=mount resume=/dev/sdb1 acpi=ht"
read-only
image=/boot/vmlinuz-smp
label="linux-smp"
root=/dev/sda1
initrd=/boot/initrd-smp.img
append="devfs=mount resume=/dev/sdb1 acpi=ht"
read-only
image=/boot/vmlinuz
label="2.4.x-failsafe"
root=/dev/sda1
initrd=/boot/initrd.img
append="failsafe resume=/dev/sdb1 devfs=nomount acpi=ht"
read-only
other=/dev/fd0
label="floppy"
unsafe
image=/boot/vmlinuz-2.6.6
label="linux-2.6.6"
root=/dev/sda1
initrd=/boot/initrd-2.6.6.img
append="devfs=mount resume=/dev/sdb1 acpi=ht"
# append="lockd.udpport=4001 lockd.tcpport=4001 devfs=mount resume=/dev/sdb1 acpi=ht"
read-only

[end code]

The parts that have a "#" in front of them are "commented out." They will have no effect whatsoever. The parts you should especially pay attention to are the bits mentioning "linux-2.6.3-7mdk" and "linux-2.6.6". The "linux-2.6.3-7mdk" part talks about my old kernel. I still have it in the boot loader in case I need to boot to my old version for some reason. The part refering to "linux-2.6.6" is talking about my new kernel. Now look at the line that says "image=" on the "linux-2.6.3-7mdk" part. This here is the path to my OLD boot image. This is the file you need to backup. All you have to do is type (as root) "cp /boot/vmlinuz-2.6.3-7mdk /boot/vmlinuz-2.6.3-7mdk.bakup". (Of course, if your old kernel line, which is probably also "linux-2.6.3-7mdk" points to a different file, you should back that one up instead using the same basic command.) Now, look at the part that says "initrd=/boot/initrd-2.6.3-7mdk.img". This is my OLD initrd image. You should back this up too. To do this, type (as root) "cp /boot/initrd-2.6.3-7mdk.img /boot/initrd-2.6.3-7mdk.img.backup". (If yours is different, substitute your information into that command.) It's worth noting that there might be one or more symbolic links. If either of these files are symbolic links (if they show up in teal or have a "@" sign after them) you need to back up whatever file they point to instead. To find out what they point to, type "ls -l [filename]". Now just go to the directory where the REAL file is and copy that file to [filename].backup.

The other thing you should pay attention to is what the "2.6.6" entry says after you do "make install". It's likely that it's going to point to a set of files that's different than the ones your old image= and initrd= point to. In that case, you don't have to change anything in /etc/lilo.conf. If, however, it tries to point to the same things as your old lilo entries do, you need to change your OLD entries to point to the .backup files you just made instead of the ones that your new kernel entry points to. To do this without erasing anything important (or that might be important now or later) you can just put a "#" in front of the lines that you would otherwise change or delete. Now just make new lines with the information you need to type in. If you find that something isn't working in your boot loader, you can always "comment out" the new lines with a "#" sign and remove the "#" from the old lines. Now everything is back to how it was before. Hopefully this answers your backup-related questions. If not, post some more questions and info.

Reading your last post, it looks like you've already done some of the backing-up I mentioned earlier. Good job! I'm not clear, however on what is meant by the "yellow square" and your question as to whether or not it's "engaged." Please give me some console output that pertains to it, or otherwise just do some more explaining. :)

Important note!: After you're done messing around in the /etc/lilo.conf file, you need to type (as root), "lilo". This will update the boot loader with all the new settings that you put into the /etc/lilo.conf file.

Also, you might want to do some looking around at www.rage3d.com (.org?). I know they have some info about getting ATI stuff working under linux. Since I have the 9600 XT and not the 9800, you might need to do some things differently.

Also note: if all the above fails when you're trying to fix the errors in the modules commands, try going back into the kernel configuration ("make xconfig" from the build directory) and make sure you don't have anything under the ATI section that isn't related to your card selected. (Radeon generic stuff IS related to your card.) Then do a "make" and see if you can do the modules commands without errors.

Happy hacking!

--Dane


All times are GMT -5. The time now is 02:24 AM.