LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Radeon 9600 XT in MDK10 (no 3d) - tried all other forums (https://www.linuxquestions.org/questions/linux-hardware-18/radeon-9600-xt-in-mdk10-no-3d-tried-all-other-forums-178067/)

DaneM 05-05-2004 05:22 AM

Radeon 9600 XT in MDK10 (no 3d) - tried all other forums
 
Hi, everybody!

I've recently installed Mandrake 10.0 Community :Pengy: on my P4 2Ghz computer with 1Gb RAM and 4x AGP. Unfortunately, I can't seem to get 3d acceleration to work at all with my new Built-By-ATI Radeon 9600 XT card. I've tried their proprietary driver, and when I check to see what driver is in use after install, it says that the default MESA driver is still being used. When I restart it won't boot into X until I replace the X config file with the backup of the previous one. I've tried all the other forums ad nauseum! Nothing seems to work! :confused: Please help me to get this figured-out. Thanks!

--Dane

xanas3712 05-05-2004 05:25 AM

how did you install the driver?

rpm --force --install driverfile.rpm in root console?

that worked fine for me with radeon 9800 pro on same linux version.
Of course I had to run fglrxconfig.. oh.. and one other thing, of course you need your kernel source installed (use rpmdrake to find this if it's not on the system or you don't know).

That's under development labeled kernel-source.

DaneM 05-05-2004 05:39 AM

Thanks for posting, Xanas!

To install, I followed the instructions from their site as follows:

rpm -Uh --force <ati_package_name>.rpm

(inserting the whole long string for package name)

I ran fglrxconfig afterwards and it made it through that process without any problems.

I have installed the Kernel source from the CD and made sure that the comptuer is booting into a kernel for which I have it installed.

Does it matter if I use Enterprise as opposed to regular? I haven't thought about that before, but I'm kind-of curious now. I basically have everything installed from all 3 CD's, and plenty of space set aside for more if necessary.

I appreciate your help. Let me know if you would like to see any printouts of console output.

Thanks

--Dane

xanas3712 05-05-2004 06:06 AM

hmm.. now I'm clueless for helping you past this point and I'm sorry about that but I'm probably more of a newbie than you are.. just that I got that working and was happy with it. Just did it again in the last few minutes (after reinstalling from official source).

DaneM 05-05-2004 06:41 AM

:-) It's alright. Thanks for the help anyway!

monkie 05-05-2004 10:57 AM

Same problem here.
Been to many forums including the Rage3D Linux + ATI how to page. No joy with any solutions. All I know is that it works for some people but not for me.

NForce2 Ultra 400 + ATI 9800Pro + Mandrake 10

V_LESTAT 05-05-2004 01:07 PM

im not sure exactly where you got your ATI drivers, but my 9700 pro wont work for the new kernel either.
and i was pissed until i read that the current ATI drivers from ati.com DO NOT SUPPORT the new kernel.
no hardware acceleration is possible. no matter what you do. as far as i know.
of course even with suse 9 and mandrake 9 i was unable to get hardware video.
its a bunch of poop as far as im concerned. not being able to get hardware graphics even in the old kernel i mean.
something odd i noticed also during suse 9.1 install is that it says at least for my 9700 pro that hardware acceleration is not possible with a dual output card. (not th eexact words but close enough)
so i removed the second ati output (ANY ati card shows 2 ati devices, even in windows.) One is the real VGA output the other is the tv output. disabling the second one makes no difference.

so i guess ill wait and wait and and and and and wait, for someone somewhere to make compatible drivers.

and make a surefire way to enable agpgart in linux without having to go thru all the flipping bullcrap.

DaneM 05-05-2004 06:53 PM

Hmmm...That's bothersome. Well, thanks for the heads-up, V-Lestat; I guess we're in the same boat. :-1 I'll post a reply if I find some new...working...drivers.

DaneM 05-16-2004 04:12 AM

I've just come across a web page (mentioned in a recent thread) that has what seem to be some rather sound instructions on getting this to work with the new 2.6.x kernel. I haven't had a chance to try them yet, but will soon. I'll post my results.

--Dane

DaneM 05-16-2004 04:15 AM

*Bonks head* I just realized that I forgot to post that web page. Here it is.

http://blahserver.greatnow.com/atihowto.html

--Dane

stuness 05-16-2004 06:19 AM

Howdy folks. There is hope. But the solution is not easy.
It took me about 3 weeks to get hardware acceleration
on my radeon mobility 9600 (NP) M10.

There is a lot of good info at http://www.rage3d.com
They seem to be down at the moment so I can't give specific links,
but go the the linux/ATI propriatary drivers section.

One thread discusses whether you will need to use internal (ati)
or external (kernel) agp acceleration, based on your graphics board.

One discusses general support issues for various cards and kernels.

If you want to use the previously posted link,
http://blahserver.greatnow.com/atihowto.html,
I would suggest a few changes/additions:

a) While perhaps not necessary for some cards, I suggest that you get the latest
kernel source (2.6.6 at the moment) from http://kernel.org/.
It was necessary for me. I've heard that the regparam patch is not needed
anymore. I didn't use it.

5) If you don't use the regparm patch, you may have to disable REGPARAM
support in the kernel. I disabled it.
I guess you could go either way. (use patch and enable REGPARAM,
or the opposite.) This may be important if you use modules built
by someone else.

9.5) forgive me for shouting, but BACKUP YOUR CURRENT IMAGE!
In /boot, copy your current vmlinuz and initrd (or whatever they point to)
to backup copies. Then add entries for them in your boot loader
(ie: /etc/lilo.conf).

10.5) don't forget to run /sbin/lilo after "make install"

11.5) reboot to your new kernel before installing and compiling fglrx.

12) make sure you follow this step. (init 3) don't install fglrx with X running.

16) i didn't have to do this. I don't know what he did this for.

19) I don't really know what is best to do for this step, but what you need
to do is insure that the modules load in the correct order. There are 3 to consider,
agpgart, <vender>-agp, fglrx. ("make modules_install" should make it
so that the first two are loaded in the proper order, via
/lib/modules/<kernel-version>/modules.dep) The best I can do
is tell you what I did, based on several posts.

In /etc/modules.conf, i have the line:
Code:

pre-install fglrx /sbin/modprobe "agpgart"
In /etc/modprobe.conf, i have the line:
Code:

install fglrx /sbin/modprobe --ignore-install fglrx && { /sbin/modprobe sis-agp; /bin/true; }
good luck

DaneM 05-16-2004 06:24 PM

Great!
 
Thanks for your post, Stuness! :-) I just started downloading the latest kernel source last night. Any pointers for dummies before I press "make"? Those changes you made to the previous instructions are well-appreciated. I was a bit worried about any problems that might arise from using a more recent kernel than what the author had used. I'll keep you posted. Have a good one!

--Dane
:study:

DaneM 05-21-2004 05:07 PM

It works!! Thanks for all the help, everybody. I followed the instructions at http://blahserver.greatnow.com/atihowto.html and did all of stuness' suggestions. Now I'm playing tuxracer and chromium with full 3d glory. I'll post a more detailed description of my exact process later. Cheers!

--Dane

UberNo0ber 06-07-2004 02:27 PM

Hi guys. I'm trying to understand whats going on here with building or compiling a kernel source code ( in mandrake10 ) inorder to link up my newly obtained driver for my ati Radeon 9800xt pro.( they are the latest)
I've read the readme file that came with the kernel source code (confusing)
I've been to http://blahserver.greatnow.com/atihowto.html (not enough info as to whats going on)
I have as a source code > linux-2.6.6 < unzipped in /home/pauly/desktop/downloads
I have the source code patch > patch-2.6.6 < unzipped in the same directory
I have the ati radeon driver > fglrx-4.3.0-3.9.0.i386.rpm<unzipped in the same director as above.
So at this point I feel I'm ready to start umm building a kernel source code, i think.
To my limited understanding I believe I'm suppose to go into /home/pauly/desktop/downloads and in this window I'm to click TOOLS then OPEN TERMINAL . From here the dirctories shell konsole comes up.
[pauly@ujan downloads]$
From here I type > su - < to go after root, so i can be at a place where I can actually make the changes work.
ie. [pauly@ujan downloads]$ su -
then the password comes up
ie. password:
then the following comes up
ie. [root@ujan downloads]#
and its here I'm unsure as to what to do. they're is some confusion here. In this forum it say /usr/src/linux <--( i don't know what this is for ) I think its the next step but I'm unsure. and if so the Readme file that came with the kernel source code says Do Not use the /usr/src/linux because this area has a usually incomplete set of kernel headers that are used by the library header files. they should match the library, and not get messed up by whatever the kernel -du-jour happens to be.
So it comes down to me needing the exact text to type my next command.
and maybe a little/alot of explanation as to whats going on.
Thank you all who help in advance !!! :Uban the UberNo0berlinux user

DaneM 06-08-2004 09:42 AM

Here's my three bits:
 
Hi, Ubernoober. It's cool to see you (working on) compiling your new kernel! It's a lot less difficult than it sounds. (Don't worry; I'm mostly a noobie too, so it can't be THAT tough...)

I've been meaning to write out what I did to fix my problem, so here it is as best as I can remember. I'll try to be as complete as possible.

Here are the first three pre-steps: (0.1) Read this document all the way through before trying anything; make sure you understand everything (at least mostly); (0.2) Print out this document; and (just for good measure) (0.3) print out the document found at http://blahserver.greatnow.com/atihowto.html . There will be a point in the setup where you'll have a hard time getting things straight if you don't...trust me.

Now to the "meat" of it. We'll be following the advice on the blahserver site with some interjection from stuness and myself. It'll be good to have all of that in-hand before you start.

1. Get super-user priveledges (su -)
Explanation: you can't do much to your system without it. (which is a good thing!)

2. Install kernel source and goto that directory (cd /usr/src/liux)
a. Stuness has it right on the money here. Go to www.kernel.org and get the newest stable version available.
b. Ignore the bit about "regparam". (You don't need it with kernel 2.6.6.)
c. What is meant by "install the kernel source and go to that directory" is that after you download the file from www.kernel.org (or wherever you got it), you should copy that file into a directory somewhere in /usr/src. DO NOT COPY IT TO AN EXISTING DIRECTORY! Doing so will REALLY mess things up. You should do something like: "mkdir /usr/src/linux-2.6.6" (to make a new directory just for your new kernel) and then, AFTER you've made that directory, copy the .tar.gz (or .tar.bz2 or whatever) file into "/usr/src/linux-2.6.6" (from the directory with the downloaded file, "cp kernel-file-name.tar.gz /usr/src/linux-2.6.6".) Of course, you should do as much as you can from the command line; it will pay off. It's generally best to install the kernel into a "neutral" directory that only root can change (not even you without the password--this is a good thing). Wherever you put this file is where your new kernel is going to be installed, and where the system is always going to need to look for it in. It's best not to put it anywhere where it might be changed, or almost as bad, denied access to because of who's logged-in.
d. Now that you've got the "tarball" file (the file you downloaded) in the directory you intend to install your new kernel in, you need to decompress it. If the file ends in ".tar.gz" then you need to type (from that directory) "gunzip kernel-file-name.tar.gz". If it ends in ".tar.bz2" then type (from that directory) "bunzip2 kernel-file-name.tar.bz2". If you have a different ending than either of these let me know and I'll see what I can dig up.
e. Now you should have a file that looks somethink like "kernel-file-name.tar". This is an archive file that is no longer compressed. Basically it's all the files that you need to get your new kernel started, packaged in one tidy, but currently unusable filename. So now you need to get all those files out of the .tar file and into a "working directory." (A working directory, or a "build" directory refers to the place where you're going to do all the compiling--the real work.) To accomplish this, type (from that directory) "tar -xvf kernel-file-name.tar". (The "x" means "extract"; the "v" means "verbose" [so you can see what it's doing]; and the "f" means "files". See "man tar" for more info.)
f. Now you should have another directory off of the one you're in called something like "linux-2.6.6". Type "cd [directory name]" to get into it. Type "pwd". This will tell you what your current directory is. It should say something like "/usr/src/linux-2.6.6/linux-2.6.6". (.tar files *usually* make their own directories, but it's always good to make a new one anyway to make sure you don't extract a few hundred files into a directory with other stuff in it.) Now type "ls". You should see a whole bunch of stuff that wasn't there before. It will look very familiar to any other .tar.gz installation (if you've done one before).

3. Always start with a fresh source (make mrproper then make clean)
a. (Still in the "working directory") This is to make sure you don't already have a "tweaked" version of the kernel sitting in this directory, which is unlikely, but you should check anyway. The two commands you need to issue to do this are, in this order, "make mrproper" and "make clean". (I don't know exactly what they do individually, but the result is a fresh set of installation files.)

4. start the kernel configuration (make xconfig or make menuconfig)
a. This is where the real fun begins (and where you start becoming a real "kernel compiling fool!"). You have two options here. The easiest is to type (from the same directory as above) "make xconfig". Almost as easy is to type "make menuconfig". Xconfig has mouse support and pretty buttons; menuconfig doesn't. If you're feeling REALLY daring, you can use "make config", but I wouldn't recommend it; it's pure text.
b. This is where you get to choose what you want your kernel to support. The more stuff you choose, the larger (and possibly slower) your kernel will be, but the more likely to see your hardware and do stuff right (*in general*). I'd stay away from anything that says "experimental" or "advanced users only," but it's up to you. Just choose the stuff you need to make your system work (processor type, etc.), and if you don't know then just leave it all how it is (except for what comes next).

5. In the kernel configuration change these options:

i. loadable module support-->loadable module support, module unloading, automatic kernel module=M
ii. processor type and feature-->register of argument=N, MTRR=Y
iii. character devices-->/dev/agpgart=M, [select only your chipset]=M
a. By "[select only your chipset]=M" I mean to disable all the ones except the one you're using, and give it the "M" (for module) option.
iv. kernel hacking-->kernel debugging=N

a. OK. We've just covered a lot of ground here. Here's what all the "blahblahblah=X" options mean: N (or blank) means "disabled"; M (or a dot) means "load from a module (and enable it)" (it'll usually make its own modules for stuff unless it's something custom like this ATI driver.); and "Y" (or a check mark) means "compile this into the kernel (and enable it)."
b. More "code." So what does the "blahblahblah-->blahblahblah-->stuff, morestuff" mean? Here's the "key:" anything with a "-->" after it is a directory tree within the kernel configuration tool. Anything after a "-->" that doesn't have a "-->" after it is an option. These are always followed by "=" signs. Anything after a "blahblah-->blahblah-->option," is another option in the same directory tree. (For example, "processor type ad feature-->register of argument=N, MTRR=Y" is telling you to disable "register of argument" and enable "MTRR" by compiling it into the kernel.)
c. Here's a relevant note from stuness: since you're not going to be using the regparm patch (I assume), you might want to disable any options you can find that make mention of it. Don't worry; it's not critical to anything as far as I can tell.

6. Save your configuration and compile a new kernel (make)
a. If you're using xconfig, click on the "floppy disk" icon then close the window. If you're using menuconfig, just keep hitting escape (slowly; it's kind-of slow in acting on it) until it asks you if you want to save your changes. Choose "YES."
b. Type "make" (from the directory with all the stuff you extracted; you should already be in there). This will take a long time. Probably 2 hours on a P4 at 2GHz and up to 8 on a Pentium 2. Go find something else to do for a while.

7. Build your boot images (make bzImage)
a. First off, be sure to note the capital "I" ("eye"). This will put your new kernel into a form that your computer can boot off of. This will also take a while.

8. Build kernel modules (make modules)
a. This command tells the kernel to go and compile all the stuff that you told it to load as a module (except for any custom stuff that you're going to compile and install yourself). It'll take about 1-10 minutes on a reasonably new computer.

9. Install the kernel modules (make modules_install)
a. This command puts the modules where they need to be on your system. Also about 1-10 minutes.

9.5 (As per stuness' wise advice) BACK UP YOUR CURRENT BOOT IMAGE! In /boot, copy your current "vmlinuz" and "initrd" or whatever those links point to (type "ls -al" in that directory to find out, then go to wherever they point and copy that stuff) to backup copies (like vmlinuzbackup and initrdbackup) and make entries for them in your boot loader. You can do this by just going into /etc/lilo.conf as root and copying what you currently have in the entry for the image you're now working under (your old kernel) to something with a new label and changing the "image=" part to whatever you renamed the file(s) that it mentions to. Now change the "default=" line to whatever the new label is for the section you just changed. Hopefully you won't need this image anymore when you're done here, but just in case....

10. Prepare and install boot images (make install)
a. OK...take a deep breath, type in the command (FROM YOUR BUILD DIRECTORY) and press [Enter]. This will make a new entry in /etc/lilo.conf for your new boot image and put your new boot image someplace sensible, such as in "/boot". Wait a while. This shouldn't take *too* long.
b. Stuness recommends that you run "lilo" as root after install. I think it's optional, but it couldn't hurt.

11. Make note of what new lines were created in /etc/lilo.conf. If this works, you can change this new image to your default!

11.5 Another good idea from stuness: reboot into your NEW kernel after you finish all the above. If you don't, the ATI drivers won't know what they need to be messing with!

12. Now it's time to install the ATI driver (init 3 and login as root)
a. To do this, open a console window and type "su -" and then "init 3". Wait a little while. Now you have a screen that says "login:".
b. Stuness: be sure to follow this step (init 3) don't install fglrx with X running.
c. I second (third?) that. I made the mistake several times before reading up on all this of installing (or even just reconfiguring) the ATI driver with XWindows running. It will make X unuseable if you do it!
d. Here's my own personal advice to make sure you don't "kill" X even if you mess something up. Go into /etc/X11 and make a backup of "XF86Config-4" (I'm pretty sure that's the correct name) by typing (from that directory) "cp XF86Config-4 XF86Config-4.bak". Now, if you find yourself unable to get into X, just log in as root, go back into /etc/X11, and type "cp XF86Config-4.bak XF86Config-4", and tell it to overwrite anything that's already there.
e. Aren't you glad you printed all this out?

13. Install your brand-spankin'-new ATI driver! (rpm -ivh --force the-ati-driver-name.rpm)
a. Make sure you downloaded the version that ends in ".rpm" before you try this. The "i" means "install"; the "v" means "verbose"; the "h" means "make a progress bar out of hash marks"; and the "--force" means "I don't care what you have to do; just do it!" You should now have the driver installed. Now to configure it.

14. Again, don't worry about that regparm stuff...

15. Yup, you still don't need to worry about the regparm stuff...

16. Neither stuness nor I had to do this. Unless your driver doesn't seem to be working (ie. no tuxracer :(), then don't bother with this; you might end-up breaking something.

17. Now build your kernel module (cd /lib/modules/fglrx/build_mod ; sh ./make.sh)
a. I don't remember doing this (although I might have), but if it lets you, then it's probably a good thing to go ahead with it.

18. Now install the module you just build into the kernel (cd /lib/moduels/fglrx ; sh ./make_install.sh)
a. Another thing that I don't remember doing but that I might have, and which you should try to do. :)

19. Add "/sbin/modprobe fglrx" to the bootl.ocal file in (/etc/rc.d/boot.local)
a. This tells your computer to load your driver at boot. Use your favorite editor (as root!) to edit "/etc/rc.d/boot.local" and add a line that says "/sbin/modprobe fglrx".
b. Stuness' better way of doing it: (the one that worked for me)

In /etc/modules.conf, I have the line:

pre-install fglrx /sbin/modprobe "agpgart"


In /etc/modprobe.conf, I have the line:

install fglrx /sbin/modprobe --ignore-install fglrx && { /sbin/modprobe sis-agp; /bin/true; }


20. Run "fglrxconfig" and select appropriate settings, edit your bootloader so it loads yoru new kernel then reboot.
a. I can't help you much here. Leave stuff at the default if you're not sure what it is. Otherwise, just make the best guesses you can on your monitor and the like. My monitor, which is a SAMSUNG SyncMaster 955 DF, used all the highest settings for the refresh rate, and its refresh capabilities aren't all that great at higher resolutions. It'll more-or-less figure it out once you start X anyway. Be sure not to enable an "enlarged virtual desktop" or anything like that. It's a giant pain in the hind-side in my opinion. Also, make sure to switch the mode to 24-bit color when it gives you the option, and enter ALL the resolution modes your monitor can handle, STARTING WITH the one you want to use as the default. (Mine used something like "31245678". You might want different options.)
b. The bit about editing your boot loader just means that you can set your new kernel as your default if you want. Only do this if it seems like you want to keep it.

21. Reboot and (hopefully) enjoy your desktop in full 3D glory!



I hope this has helped you out. Feel free to make some more posts if you get stuck (and I'll see if I can help you out). Have fun and good luck!


--Dane

UberNo0ber 06-09-2004 04:17 AM

Excellent DaneM I'm working through this.
however I have a few problems right now.

1st) during xconfig..... in the first part
i. loadable module support-->loadable module support, module unloading, automatic kernel module=M
there was no choice of M (dot) for me to choose so I went ahead and just said Y (checkmark) am I in big trouble now or what ??

2nd) during make modules the following came up.
[root@ujan linux-2.6.6]# make modules
make[1]: `arch/i386/kernel/asm-offsets.s' is up to date.
Building modules, stage 2.
MODPOST
*** Warning: "errno" [drivers/media/dvb/frontends/tda1004x.ko] undefined!
CC drivers/video/aty/radeonfb.mod.o
LD [M] drivers/video/aty/radeonfb.ko
[root@ujan linux-2.6.6]#

Oh o what have I done now?
3rd) So onward I go and type in the next command > make modules_install
and the following comes up.
if [ -r System.map ]; then /sbin/depmod -ae -F System.map 2.6.6; fi
WARNING: /lib/modules/2.6.6/kernel/drivers/media/dvb/frontends/tda1004x.ko needs unknown sy
make: *** [_modinst_post] Error 1
[root@ujan linux-2.6.6]#

ok ...... hmmm what should I do now besides wait for another sane post from DaneM
:UberNo0ber
Thx for all the help so far.

UberNo0ber 06-09-2004 12:46 PM

After taking some advice elsewhere about this error I installed module-init-tools.3.0
and had done everything over again..... but to no avail. The same error exist.
So I forged forth anyways and maybe i can deal with the error at a later time.
However I'm finding the BACK UP stuff a little fuzzy. Could you explain this part a bit more please.
Thank you.
:UberNo0ber

UberNo0ber 06-09-2004 03:18 PM

Thought I'd just add to the problems by saying ( still trying to back things up/ but I'm at the place where you'd make entries for them in one's boot loader )

as ROOT user login I ended up just copy/pasting the going to be backup(vmlinuz-2.6.3-7mdk) into vmlinuzbackup which resides in file:/boot
Note: there is no yellow square in the vmlinuz-2.6.3-7mdk
and so its not in the file:/etc liloconf.
is it engaged ..... if not howto ?
:UberNo0ber

DaneM 06-10-2004 05:26 AM

OK...don't worry; we'll figure this out.
 
Hi, Ubernoober.

Don't worry about having to choose "Y" instead of "M" (dot). In most cases (ie. you're not inserting a custom module for that particular item, which you're not) it can even be better to load something directly into the kernel instead of loading a module. Modules take more time to load if they're not compiled into the kernel already (using the "Y" option). :)

That bit about "*** Warning: "errno" [drivers/media/dvb/frontends/tda1004x.ko] undefined!" is somewhat "different." The fact that it's right before a line referencing "radeon" might give us a clue. The first thing you should try is going and uninstalling the radeon drivers (I assume you tried to install them before posting here). To do this, type (as root), "rpm -q --whatrequires fglrx". If it says that nothing requires "fglrx", then type, "rpm -e fglrx". (If something requres "fglrx" then you'll first have to type "rpm -e [thing that requires fglrx]" before you can remove fglrx.) If that doesn't work, type "rpm -qa | grep fglrx". What this will do is cause the rpm command to list everything that's been installed from RPM packages. Using a "|" ("pipe"), followed by "grep fglrx" will cause the output of the rpm command to become the input of the grep command. Since grep is used to look for the thing specified, it will try to find any references to "fglrx" in the output of "rpm -qa". This means that if you have anything at all with the string "fglrx" in it, it will be displayed after rpm is done doing its thing. You can then insert that line (if one comes up) into the command, "rpm -e [fglrx line here]". This will remove anything related to the ATI drivers.

Now try doing "make modules" again. If all goes according to plan (*twiddles fingers deviously*), that problem should no longer exist. If it DOES still exist, start trying to figure out "why in the heck" it's looking for "[your/kernel/install/directory]/drivers/media/dvb/frontends/tda1004x.ko". If you've installed any modules on your own, try to find out if any of them installed (or tried to install) that file. To see if a particular RPM file has that file somewhere in it, you can type "rpm -q --filesbypkg [file.rpm] | grep tda1004x.ko". You can sort through them all manually by leaving out the "| grep tda1004x.ko" part. Next, I would try doing some searches on the internet for that particular filename. In google, for example you would type in the filename surrounded by quotes. This will make sure you get *exactly* what you typed in, instead of subjecting it to its search parsing engine.

The "make modules_install" command is related to the same file. I suspect that if you fix the file in the first command you'll fix it here too.

BACKUP STUFF:

Here's an exerpt from my etc/lilo.conf file.

[code]

boot=/dev/sda
map=/boot/map
default="linux-2.6.6"
keytable=/boot/us.klt
prompt
nowarn
timeout=200
#message=/boot/message
menu-scheme=wb:bw:wb:bw
image=/boot/vmlinuz
label="2.4.x"
root=/dev/sda1
initrd=/boot/initrd.img
append="devfs=mount resume=/dev/sdb1 acpi=ht"
read-only
image=/boot/vmlinuz-2.6.3-7mdk
label="linux-2.6.3-7"
root=/dev/sda1
initrd=/boot/initrd-2.6.3-7mdk.img
append="devfs=mount resume=/dev/sdb1 acpi=ht"
read-only
image=/boot/vmlinuz-smp
label="linux-smp"
root=/dev/sda1
initrd=/boot/initrd-smp.img
append="devfs=mount resume=/dev/sdb1 acpi=ht"
read-only
image=/boot/vmlinuz
label="2.4.x-failsafe"
root=/dev/sda1
initrd=/boot/initrd.img
append="failsafe resume=/dev/sdb1 devfs=nomount acpi=ht"
read-only
other=/dev/fd0
label="floppy"
unsafe
image=/boot/vmlinuz-2.6.6
label="linux-2.6.6"
root=/dev/sda1
initrd=/boot/initrd-2.6.6.img
append="devfs=mount resume=/dev/sdb1 acpi=ht"
# append="lockd.udpport=4001 lockd.tcpport=4001 devfs=mount resume=/dev/sdb1 acpi=ht"
read-only

[end code]

The parts that have a "#" in front of them are "commented out." They will have no effect whatsoever. The parts you should especially pay attention to are the bits mentioning "linux-2.6.3-7mdk" and "linux-2.6.6". The "linux-2.6.3-7mdk" part talks about my old kernel. I still have it in the boot loader in case I need to boot to my old version for some reason. The part refering to "linux-2.6.6" is talking about my new kernel. Now look at the line that says "image=" on the "linux-2.6.3-7mdk" part. This here is the path to my OLD boot image. This is the file you need to backup. All you have to do is type (as root) "cp /boot/vmlinuz-2.6.3-7mdk /boot/vmlinuz-2.6.3-7mdk.bakup". (Of course, if your old kernel line, which is probably also "linux-2.6.3-7mdk" points to a different file, you should back that one up instead using the same basic command.) Now, look at the part that says "initrd=/boot/initrd-2.6.3-7mdk.img". This is my OLD initrd image. You should back this up too. To do this, type (as root) "cp /boot/initrd-2.6.3-7mdk.img /boot/initrd-2.6.3-7mdk.img.backup". (If yours is different, substitute your information into that command.) It's worth noting that there might be one or more symbolic links. If either of these files are symbolic links (if they show up in teal or have a "@" sign after them) you need to back up whatever file they point to instead. To find out what they point to, type "ls -l [filename]". Now just go to the directory where the REAL file is and copy that file to [filename].backup.

The other thing you should pay attention to is what the "2.6.6" entry says after you do "make install". It's likely that it's going to point to a set of files that's different than the ones your old image= and initrd= point to. In that case, you don't have to change anything in /etc/lilo.conf. If, however, it tries to point to the same things as your old lilo entries do, you need to change your OLD entries to point to the .backup files you just made instead of the ones that your new kernel entry points to. To do this without erasing anything important (or that might be important now or later) you can just put a "#" in front of the lines that you would otherwise change or delete. Now just make new lines with the information you need to type in. If you find that something isn't working in your boot loader, you can always "comment out" the new lines with a "#" sign and remove the "#" from the old lines. Now everything is back to how it was before. Hopefully this answers your backup-related questions. If not, post some more questions and info.

Reading your last post, it looks like you've already done some of the backing-up I mentioned earlier. Good job! I'm not clear, however on what is meant by the "yellow square" and your question as to whether or not it's "engaged." Please give me some console output that pertains to it, or otherwise just do some more explaining. :)

Important note!: After you're done messing around in the /etc/lilo.conf file, you need to type (as root), "lilo". This will update the boot loader with all the new settings that you put into the /etc/lilo.conf file.

Also, you might want to do some looking around at www.rage3d.com (.org?). I know they have some info about getting ATI stuff working under linux. Since I have the 9600 XT and not the 9800, you might need to do some things differently.

Also note: if all the above fails when you're trying to fix the errors in the modules commands, try going back into the kernel configuration ("make xconfig" from the build directory) and make sure you don't have anything under the ATI section that isn't related to your card selected. (Radeon generic stuff IS related to your card.) Then do a "make" and see if you can do the modules commands without errors.

Happy hacking!

--Dane


All times are GMT -5. The time now is 02:53 AM.