-   Linux - Hardware (
-   -   Radeon 9600 Pro 2.6.6 Works, 2.6.7 doesn't (

AlgebraicSpore 07-14-2004 12:08 AM

Radeon 9600 Pro 2.6.6 Works, 2.6.7 doesn't
Sorry for another post about the fglrx drivers but it seems I am having a problem that I have not found the post for, if there is one please point me to it. I am running Debian Testng on a KT600 chipset with a Radeon 9600 Pro 256 MB video card.

I downloaded the drivers from the ATI website and then changed the rpm into a .deb using alien.
I then installed it using dpkg and built and configure the module by running sh in /lib/modules/fglrx/build_mod/ and then running sh in /lib/modules/fglrx/ after loading the module and fglrxconfig it worked fine and has been working fine for about 2 months on 2.6.6.

However I recently updated to 2.6.7 and tried the same process that I used on installing the drivers under 2.6.6 but now when I run the command sh in the build_mod folder I get the following output:

ATI module generator V 2.0
patching 'highmem.h'...
skipping patch for 'drmP.h', not needed
skipping patch for 'drm_os_linux.h', not needed
assuming new VMA API since we do have kernel 2.6.x...
doing Makefile based build for kernel 2.6.x and higher
make -C /lib/modules/2.6.7/build SUBDIRS=/lib/modules/fglrx/build_mod/2.6.x modules
make[1]: Entering directory `/usr/src/linux-2.6.7'
CC [M] /lib/modules/fglrx/build_mod/2.6.x/agpgart_be.o
/lib/modules/fglrx/build_mod/2.6.x/agpgart_be.c: In function `agp_generic_alloc_page':
/lib/modules/fglrx/build_mod/2.6.x/agpgart_be.c:1405: error: structure has no member named `count'
/lib/modules/fglrx/build_mod/2.6.x/agpgart_be.c: In function `ali_alloc_page':
/lib/modules/fglrx/build_mod/2.6.x/agpgart_be.c:4416: error: structure has no member named `count'
make[2]: *** [/lib/modules/fglrx/build_mod/2.6.x/agpgart_be.o] Error 1
make[1]: *** [_module_/lib/modules/fglrx/build_mod/2.6.x] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.7'
make: *** [kmod_build] Error 2
build succeeded with return value 0
ln: `./fglrx.ko': File exists
duplicating results into driver repository...
cp: cannot stat `fglrx.ko': No such file or directory
You must change your working directory to /lib/modules/fglrx
and then call ./ in order to install the built module.

I really do not know what is behined the error messages besides someone referencing a variable count out of context in the driver code, and I have no idea how to fix this.

Any help would be much apperciated.

motub 07-14-2004 07:21 AM

Are you sure that you need to fix it? The process does complete and instruct you to run the install script to install the module.

Have you tried that? Does it work?

It may very well be a non-critical (or even completely unimportant) error that has no bearing on the correct building or installing of the driver, and I wouldn't worry about it until I had reason to believe that it was something else.

Hope this helps.

AlgebraicSpore 07-14-2004 11:20 AM

I forgot to put the output of what happens when I run the script. Here it is:

*** WARNING ***
Tailored kernel module for fglrx not present in your system.
You must go to /lib/modules/fglrx/build_mod subdir
and execute './' to build a fully customed kernel module.
Afterwards go to /lib/modules/fglrx and run './'
in order to install the module into your kernel's module repository.
(see readme.txt for more details.)

As of now you can still run your XServer in 2D, but hardware acclerated
OpenGL will not work and 2D graphics will lack performance.



I got it fixed by editng the code as follows:

In file /lib/modules/fglrx/build_mod/2.6.x/agpgart_be.c change the following:

line 1405 count to _count
line 4416 count to _count

in file /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c change the following

line 2013 count to _count


motub 07-14-2004 01:36 PM

Glad you got it fixed, but what possessed you to make those particular changes in that particular way?

In other words, please provide a link to the source of this fix, so others can know if it would help with problems they might have.

Myself, I'd just like to read the thread/article/whatever where this is suggested-- always looking to learn :) .

AlgebraicSpore 07-14-2004 05:36 PM

The error messages pointed to the bad code, there was another one that came up after I made the first to changes that was about the firegl_public.c file that showed a similar error.

/lib/modules/fglrx/build_mod/2.6.x/agpgart_be.c: In function `agp_generic_alloc_page':
/lib/modules/fglrx/build_mod/2.6.x/agpgart_be.c:1405: error: structure has no member named `count'

/lib/modules/fglrx/build_mod/2.6.x/agpgart_be.c: In function `ali_alloc_page':
/lib/modules/fglrx/build_mod/2.6.x/agpgart_be.c:4416: error: structure has no member named `count'

I found what to change the name to on a thread from the linux mailing list here:

All times are GMT -5. The time now is 05:54 AM.