LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 06-30-2003, 11:57 AM   #16
malcidragon
Member
 
Registered: Feb 2002
Location: Leeds UK
Distribution: Fedora Core 3
Posts: 67

Rep: Reputation: 15
ati probs


Mine _seem_ to work OK, but they are not stable.
They crash on UT2003,UT,SOF and other games at the same point
I have SMP athlon?
Any ideas here?
Or how to debug this?
 
Old 06-30-2003, 04:53 PM   #17
Thetargos
Senior Member
 
Registered: Mar 2003
Location: Mexico City
Distribution: Fedora, Ubuntu & Mint
Posts: 1,679

Rep: Reputation: 45
You may want to check Rage3D's linux forum I don't think ATi drivers support SMP on Linux just yet.
 
Old 07-01-2003, 04:32 AM   #18
h@rier
LQ Newbie
 
Registered: Jul 2003
Posts: 1

Rep: Reputation: 0
Last ATI Radeon drivers for XFree 1.3 too

Hi all

Last ATI Raden drivers for XFree 4.1, 4.2, 4.3 you can download form
http://www.schneider-digital.de/html...nload_ati.html
 
Old 07-01-2003, 04:56 AM   #19
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
Raedon 9800 Pro success.

I've got a 9800 Pro in my new box...and It's taken me three days to get all the issues sorted.
This is for a raedon on an nforce motherboard.
If your running a 2.4.20 kernel you need to patch it with the nvidia agp patch that can be found in the latest nforce driver package, if your running 2.4.21 (as I am) you need to apply this patch,
http://penna.dyn.dhs.org/~penna/linu...-agpgart.diff.

Then you need to rebuild your kernel - pay attention to the instructions in the readme.txt that comes in the nvagp directory (part of the nforce package), then you need to build the fglrx kernel module against your new kernel (instructions and scripts are in the package from schneider-digital).
I'm getting 207 fps in quake3 at 1280x1024 with all the eye candy on and glxgears is giving me the following,
Code:
bern@beast bern$glxgears
26234 frames in 5.0 seconds = 5246.800 FPS
26366 frames in 5.0 seconds = 5273.200 FPS
26524 frames in 5.0 seconds = 5304.800 FPS
26421 frames in 5.0 seconds = 5284.200 FPS
26379 frames in 5.0 seconds = 5275.800 FPS
26295 frames in 5.0 seconds = 5259.000 FPS
26393 frames in 5.0 seconds = 5278.600 FPS
Details of my new system,
AthlonXP 3000+
Asus A7N8X Deluxe
Saphire 9800 Pro
512MB Corsair XMS3200 (2x256)
Saegate Barracuda V 80gb SATA
Samsung SyncMaster 172t LCD panel

Installing slackware to the SATA drive took a bit of work, as did getting it working at a decent speed without lockups.
 
Old 08-27-2003, 12:57 PM   #20
JimboJones
LQ Newbie
 
Registered: Aug 2003
Location: England
Distribution: Redhat 9.0
Posts: 18

Rep: Reputation: 0
Hi, I have exactly the same system specs as you Aussie but seeing this is my first day using Linux I am finding it slightly difficult to comprehend. Could you please enlighten me?
 
Old 08-27-2003, 02:08 PM   #21
JimboJones
LQ Newbie
 
Registered: Aug 2003
Location: England
Distribution: Redhat 9.0
Posts: 18

Rep: Reputation: 0
Woops! I installed those drivers from schneider-digital and i now dont have a desktop! If anyone can help me out of that as well it would be very much appreciated.
 
Old 08-27-2003, 05:29 PM   #22
Thetargos
Senior Member
 
Registered: Mar 2003
Location: Mexico City
Distribution: Fedora, Ubuntu & Mint
Posts: 1,679

Rep: Reputation: 45
First make sure you boot into console and not to X, re run the fglrxconfig script to replace your current XF86Config file with ATi's settings. Then just try first launching X, if it does not work, then re run script... usually that helps, if you keep having problems, post back.
 
Old 08-30-2003, 06:56 AM   #23
JimboJones
LQ Newbie
 
Registered: Aug 2003
Location: England
Distribution: Redhat 9.0
Posts: 18

Rep: Reputation: 0
How do you boot to console? Via safe mode?

<edit> I reinstalled linux by the way to get back to KDE.

Last edited by JimboJones; 08-30-2003 at 06:57 AM.
 
Old 08-30-2003, 09:56 AM   #24
Thetargos
Senior Member
 
Registered: Mar 2003
Location: Mexico City
Distribution: Fedora, Ubuntu & Mint
Posts: 1,679

Rep: Reputation: 45
You enter into console by changing the runlevel of your distro, there should be a file called inittab under /etc, there should be a number coded set of runlevels, check which corresponds to pure console (or pure multiuser) Usually (as it is a convention in Red Hat) runlevel 0 and 6 mean halt (and poweroff) and reboot respectively, 1 is not used (or used by the safemode console) 2 is multiuser without networking capabilities, 3 full multiuser with network (no X), 4 is not used (to be a custom mode) and 5 is full Multiuser under X. You must edit the file to reflect the desired runlevel in the line
Code:
id:5:initdefault:
Alternatively you can switch the runlevel by exiting to a system console (by pressing ctrl+alt+F1-F6), log in as root, and then just issue the command init followed by the desired runlevel, eg. init 3 (in my case). Once in the console, go to the directory where the driver rpm lies, install it and switch back to X runlevel, in my case init 5.
 
Old 08-30-2003, 11:00 AM   #25
JimboJones
LQ Newbie
 
Registered: Aug 2003
Location: England
Distribution: Redhat 9.0
Posts: 18

Rep: Reputation: 0
Ok, got it. I have got to the console and set up fglxrconfig (or whatever it is called) and i issue the command startx afterwards but X refuese to start because it still cant find any displays.

Thanks for putting up with me, i know Windows inside out but when it comes to Linux, i'm not so sure at the moment!
 
Old 08-31-2003, 01:27 PM   #26
Thetargos
Senior Member
 
Registered: Mar 2003
Location: Mexico City
Distribution: Fedora, Ubuntu & Mint
Posts: 1,679

Rep: Reputation: 45
You'll get the feel of it, it is not that different, but of course there are fundamental differences, but not when it comes to the interface... Anyway, usually reconfiguring with the script fglrxconfig solves most of the problems, although you may have some garbage when it comes to the configuration file X looks up (the one the script creates) and my got confused. To look into this first posibility (the most likely) go the location of this configuration file, i.e /etc/X11. If you ls the contents of that directory, you'll probably find many intances of a file called XF86Config*, in order to have a clean configuration file, I'd suggest to delete any instance of it by rm XF86Config* (as root) then re-run the script, and then (it is my personal recomendation) rename the resulting file (XF86Config-4) to plain XF86config.

Prior releases of XFree86 4 (4.0, 4.1 & 4.2) looked to the file XF86Config-4 to apply the cofiguration to the version 4 of the X Free Window system, and the XF86Config to the versions 3.x, this in systems whith both X systems. But as of version 4.3 the configuration file is plain XF86Config (as in version 3.x), so if you have XFree86 version 4.3 (you may know about the version by looking at the log file in /var/log/XFree86.0.log, it should be in the one of the top lines in that file), my suggestion would be to rename the XF86Config-4 file to XF86Config by:
Code:
# mv XF86Config-4 XF86Config
In the event that doesn't work, make sure your monitor is connected to the VGA output of the card, if you configured the driver to use only one monitor (the DVI corresponds to the [b[second[/b] head!) otherwise if you have a DVI connected monitor choose dualhead mode in clone mode.

That should be the easiest to trouble shoot the No screen found error message.
 
Old 09-01-2003, 03:21 PM   #27
JimboJones
LQ Newbie
 
Registered: Aug 2003
Location: England
Distribution: Redhat 9.0
Posts: 18

Rep: Reputation: 0
It turned out to be a garbled file, so now it does attempt to work. I say attempt becasue all it does is give me a blank screen. I can here disk activity so the X window system is doing its stuff, its just that I can't see it! I have tried the most possible configurations within the scope of my hardware but to no avail.

Almost there (i think!).
 
Old 09-01-2003, 05:42 PM   #28
Thetargos
Senior Member
 
Registered: Mar 2003
Location: Mexico City
Distribution: Fedora, Ubuntu & Mint
Posts: 1,679

Rep: Reputation: 45
In my experience, some times (rarely) the driver intialises not accordingly to your XF86Config specs, when this happens to me, I simply go off to a console (ctrl+alt+F1) log in as root and type
Code:
killall X
What this does is that it will kill the X server, but since I am under graphical mode, the deamon GDM (the gnome display manager) restarts, forcing X to restart and hence to re-read the config file. Try that... or may be you misconfigured your Hsync/VSync values? (I always check anyhow, you never know when you specified an out of range value).
 
Old 09-02-2003, 12:44 PM   #29
JimboJones
LQ Newbie
 
Registered: Aug 2003
Location: England
Distribution: Redhat 9.0
Posts: 18

Rep: Reputation: 0
I did CTRL + ALT + F1 and found that X was actually hiding an error from me (here goes!):

fglrx: No matching device section for instance (busID PCI:3:0:1) found

fglrx.o: init module: no such device

it then says 2 lines about 'insmod failed fglrx.o'

fglrx(0): DRIScreenInit Failed!


Something wrong with the drivers i guess?!
 
Old 09-02-2003, 05:20 PM   #30
Thetargos
Senior Member
 
Registered: Mar 2003
Location: Mexico City
Distribution: Fedora, Ubuntu & Mint
Posts: 1,679

Rep: Reputation: 45
Ok, try uninstalling the drivers (rpm -e fglrx-blah-blah) and then reinstall it. Alternatively you may simply erase fglrx.o from /lib/modules/<kernel version>/kernel/drivers/char/drm (or simply change to /lib/modules and make a find . -iname fglrx.o and change to the directory find tells you it is on). Then just recompile the module:
Go to /lib/modules/fglrx/build_mod/ and execute the script make.sh, then change to upper directory and execute the script make_install.sh, pay close attention to the messages displayed by make_install.sh, may be the same insmod message would appear.

Remember that all these steps should be made OUTSIDE X, i. e in pure console.

Possible causes for which the module is not loading:
The first that comes to mind is to check your kenrel configuration, if you run a custom kenrel, make sure NO other DRM modules are compiled INTO the kernel (specially the Radeon module, which recognizes the Radeon, or any other like the tdfx module for 3dfx cards), otherwise the kernel will complaint about an already loaded module, and will not be able to load the fglrx module.

So check your kernel (if you configured it yourslf) or install an upgraded kernel version from your distribution's web services, and try again recompiling the module with the script make.sh under /lib/modules/fglrx/build_mod
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ati radeon 9500 pro video options pottyscum101 Linux - Hardware 0 01-07-2004 03:46 PM
ATi Radeon 9500 Pro +SuSE 8.2 Marvelloard Linux - Hardware 41 12-05-2003 09:08 AM
ATI Linux drivers for Radeon 9500 Pro Hammett Linux - Software 0 08-18-2003 12:45 PM
Can't install ATI Radeon 9500 Pro Drivers Lon3wolf Linux - Newbie 3 07-21-2003 11:55 AM
ATI Radeon 9500 Driver Issues martinman Linux - Hardware 15 04-27-2003 05:09 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 07:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration