-   Linux - Hardware (
-   -   Radeon 9000 2D Works 3D Doesnt ? (

MrSmith 02-22-2003 08:48 AM

Radeon 9000 2D Works 3D Doesnt ?
I know this is a well know annoyance yet i managed to get 2D working relatively easily on Debian 'Woody'
downloaded driver
converted to deb using alien
installed driver
ran fglrxconfig (then edited Xf86-Config-4 to set Bus ID)
then ran the build script for the 3D modules -> no problems
ran the install script for the 3D Module got

[[fglrx:firegl_stub_register] *ERROR* Fire GL kernel modules has to be loaded prior to any other DRM kernel module!

i tried making it run on startup befor Xfree or anything loads i get the same error, am i loading something i shouldnt be ?

Thanks in advance

verigoth 02-22-2003 04:47 PM

i got 3d support working without ati's drivers, but it's quite a bit of work. here's a link to my howto (, it involves building and installing XFree86 form source, which you could do without the 'make install && make' if you don't want to chance running an unsupported x server (I haven't had any problems with it)


activematrix 02-23-2003 01:45 AM

Just a side note, I would like to add that the ATI Radeon 9000 driver does not play well on a Radeon 9000 Pro MOBILITY package. The native driver in RedHat 8.0 seems to work well, but the ATI driver doesn't seem to work well at 60Hz (for LCD screens)--even when forced in XF86Config. Any ideas?

MrSmith 02-23-2003 11:41 AM

All Fixed and Running
A linux guru gave me a hand and now it all works, had to recompile the kernel without and form of DRI support and make it run the script on boot now it all works 2D 3D and overlay

activematrix 05-22-2003 02:21 PM

Cool, thanks for the info! I'll give that a try, maybe that's my problem too!

All times are GMT -5. The time now is 04:06 PM.