LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
LinkBack Search this Thread
Old 12-03-2004, 04:06 PM   #1
Lleb_KCir
Senior Member
 
Registered: Nov 2003
Location: Orlando FL
Distribution: Debian
Posts: 1,765

Rep: Reputation: 45
PS/2 scroll mouse not working properly


debian sarge distro
KDE 3.2.x
kdm
generic scroll 2 button mouse

i know scroll will work, but for the life of me i can not get this mouse to work properly in debian.

currently this is what my XF86config-4 looks like for that area....

Code:
Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "mouse"
        Option          "CorePointer"
# added 12-2-04
#       Option          "SendCoreEvents"        "true"
        Option          "Device"                "/dev/psaux"
#       Option          "Device"                "/dev/input/mouse0"
#       Option          "Protocol"              "ImPS/2"
        Option          "Protocol"              "PS/2"
        Option          "Emulate3Buttons"       "true"
        Option          "ZAxisMapping"          "4 5"
EndSection
Section "InputDevice"
        Identifier      "Generic Mouse"
        Driver          "mouse"
        Option          "SendCoreEvents"        "true"
#       Option          "Device"                "/dev/input/mouse0"
        Option          "Device"                "/dev/misc/psaux"
        Option          "Protocol"              "ImPS/2"
#       Option          "Protocol"              "PS/2"
        Option          "Emulate3Buttons"       "true"
        Option          "ZAxisMapping"          "4 5"
EndSection
i have tried setting it to ImPS/2 i have adjusted the /dev/input/mouse mice, etc...

if i can get the scroll portion to work, the mouse pointer gets real jumpy around desktop icons or around the edge of a window. making it worthless as it can not be accuartly controlled around icons and the edge of windows, so what good is it...

FYI i took the USB scroll mouse out that was working as scroll and mouse because at random it would go nuts. by that i mean it would start flying (blindingly fast) around the screen and left right clicking at random around the screen causing all kinds of a mess on my desktop. could be reset by unplugging the mouse and plugging it back in, but that is a bit crazy so i left the USB for a more common/standard PS/2 device in hopes of resolving this issue.

now i can not get the scroll to work. the mouse works fine if i am not using the imps/2 and just the older ps/2, but i would like to have my scroll function working.

help please.
 
Old 12-03-2004, 04:28 PM   #2
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Try disabling 3 button emulation and add the following line before or after your ZAxisMapping line,

Option "Buttons" "5"
 
Old 12-03-2004, 05:48 PM   #3
Lleb_KCir
Senior Member
 
Registered: Nov 2003
Location: Orlando FL
Distribution: Debian
Posts: 1,765

Original Poster
Rep: Reputation: 45
that did not do the trick. i still had a very jumpy mouse curser when in ImPS2, and with PS/2 i have no scroll.
 
Old 12-03-2004, 06:37 PM   #4
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
back your xfree86 configuration file and try to reconfigure your xserver.
 
Old 12-03-2004, 07:11 PM   #5
Lleb_KCir
Senior Member
 
Registered: Nov 2003
Location: Orlando FL
Distribution: Debian
Posts: 1,765

Original Poster
Rep: Reputation: 45
ok i can back it up by

cp /etc/X11/XF86config-4.back

yes?

how do i rerun the config tool again? dpkg-???
 
Old 12-03-2004, 08:56 PM   #6
Lleb_KCir
Senior Member
 
Registered: Nov 2003
Location: Orlando FL
Distribution: Debian
Posts: 1,765

Original Poster
Rep: Reputation: 45
ok ran

dpkg-reconfigure xserver-xfree86

no love after running that with my mouse. still no scroll, and when prompted for it to use scroll i told it YES.
 
Old 12-07-2004, 02:54 PM   #7
Lleb_KCir
Senior Member
 
Registered: Nov 2003
Location: Orlando FL
Distribution: Debian
Posts: 1,765

Original Poster
Rep: Reputation: 45
ok have done all sujestions still no luv for my little mousy not being jumpy... help please.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mouse scroll not working? tehnick Linux - Hardware 3 03-25-2005 12:56 AM
Scroll in Mouse Stopped Working ddrfreak Mandriva 9 12-16-2004 07:23 PM
USB mouse and scroll not working. Slovak Slackware 18 11-16-2004 09:20 AM
Why is my mouse scroll not working? Honoriu *BSD 8 05-05-2004 11:59 AM
Scroll mouse not working in RHL7.2 kghoshal Linux - Newbie 1 07-26-2003 05:13 AM


All times are GMT -5. The time now is 02:32 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration